Pages: 1 [2]   Go Down
Author Topic: Solarbotics Ardweeny  (Read 2095 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 28
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Nevermind guys, I just bought an Arduino Pro Mini from sparkfun.com instead.  I got it today and it works perfectly.

So I appreciate all the help guys, but I'm going to chalk the ardweeny up to a $10 learning experience.

Thanks again!
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had trouble with the ardweeny until I set the port to send RTS on close.

I am using the FTDI 3V cable.  TTL-232R-3V3 USB
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks to ladyada.net for the tutorial.  An image of the config can be found here...

http://www.ladyada.net/images/boarduino/advancedsettings.jpg
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino does rock
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I am using the Solarbotics Ardweeny and am having similar problems to the ones described here.

Specifics:

Solarbotics Ardweeny
Windows Vista OS
Sparkfun FTDI Basic Breakout, 5 V version

Error Message in console:

Binary sketch size: 1010 bytes (of a 30720 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Background info:
I assembled four Ardweenies and tested them all. The fourth one does not work whereas the other three worked as expected with the Blink.pde sketch available with the Arduino 0021 download.

The LED on Pin 13 blinks about once every three seconds. When  I press the reset button, the LED blinks once upon release and then once every three seconds.

When I upload the sketch to the board, the LED on Pin 13 blinks three times and the TX LED on the Sparkfun FTDI Basic Breakout board blinks three times but the RX LED stays off. While this is going on, the IDE continues to say uploading to the board and then I get the error message given above.

I tested the continuity between the ISP headers as connected to the Sparkfun board, GND to both GND pins, 5 V to + and A+, TX Sparkfun pin to Adrweeny D0, and RX Sparkfun pin to Ardweeny D1. I do not know what the CTS and OTR Sparkfun pins do. The Sparkfun header ISP pins GND, 5 V, TX, and RX have continuity to their respective pins. These are also the pins as on the working Ardweenies.

When I tested the board for voltages with the Sparkfun board in place
+ to GND was 5 V,
A+ to GND was 5 V,
but AR to GND was 0.6 V.

On the working boards, AR to GND was 0 V or very close to it.

Any suggestions?
Logged

Pages: 1 [2]   Go Up
Jump to: