Poll
Question: Troubleshooting of Arduino diecimila
connection - 18 (36%)
Troubleshooting - 32 (64%)
Total Voters: 21

Pages: [1] 2 3 ... 11   Go Down
Author Topic: avrdude error  (Read 44622 times)
0 Members and 2 Guests are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

compiles blink fine, but when upload to I/O board i get:
Binary sketch size: 1108 bytes (of a 14336 byte maximum)


avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51


this is on XP
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Try the suggestions in the troubleshooting guide: http://www.arduino.cc/en/Guide/Troubleshooting#toc2
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

yes i went through all the suggestions and to no avail
Logged

0
Offline Offline
Sr. Member
****
Karma: 0
Posts: 375
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Can you give us some more information? smiley

Board Style?
OS?
Comport#?
Micro?

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

im on xp
com1
just got a new arduino Diecimila usb board  from sparkfun :
http://www.sparkfun.com/commerce/product_info.php?products_id=666

"Board comes fully assembled and tested with ATMega168 pre-loaded with bootloader."

Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmm...

Is the power LED on?  What does the L / pin 13 LED when you reset the board?

Is the jumper positioned for USB power?

Is there anything connected to the board?

Are you running any programs that might block access to the com port (e.g. firewalls, pda sync applications, etc.)?

Try setting upload.verbose to true in your preferences.txt file (in Documents and Settings/<USERNAME>/Application Data/Arduino) - make sure to edit the file when the Arduino software is not running.  Then try uploading again and post the messages you get.

If you can, try it under Mac OS X.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

when i connect the usb
the pwr light is on, i also connect an led from gnd to 13 and it blinks in rapid succession. when i reset the there are 3 distinct blinks then nothing for a while then it goes back to blinkning

currently nothing is connected to the board other than the usb and an led

jumper is position on usb

i dont have any firewall, or blocking programs, this is all thats running


verbose reads:
 
         Using Port            : COM1
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 19200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.

is that baud rate suspect?
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Huh.  Is there a built-in LED on pin 13?  They didn't happen to send you an Arduino NG instead of a Diecimila, did they (i.e. what does it say on the board)?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i just put the led in myself to try and get "Blink",
 it is a Diecimilia, says it right on board

hmm still no luck and im getting mails from people with the same problem wondering if i solved it smiley-sad

obviously there is a connection problem, is there a way to see if there are any conflicts with other versions of dlls or previous software on this pc because i have done lots of dev on this machine.
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Actually, I'm suspicious of the board itself, and in particular the bootloader on it.  There should be an on-board LED.  If you remove your LED, does the on-board LED blink in the same way that your LED did?  What blinking do you see?  Three quick flashes, then nothing for a few seconds, then three quick flashes again, and so on?  Did your Arduino board come in a bag with an Arduino-shaped sticker on it?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ok well i cant recall an arduino sticker but it says "arduino diecimilia" on it and looks exactly like http://www.arduino.cc/en/uploads/Main/ArduinoDiecimila400.jpg

y, there is an onboard led , a few.

when i plugin in the usb i get a constant light on from the pwr
and then there are several brief  flahes on the TX and RX leds which then stop flashing
then on the L Led there are contant flashes that come in triplets and do not stop

when i press the reset button, the "L" led lights up three times in slightly longer succession then goes silent for about 15 secs and then changes to the rapid triplets identical to above.

when i put the led in grnd and 13 the blinks mimic the "L" led.

thanks for the replies guys, much appreciated

ere is an
so when i plug in the usb i get a couple flashes briefly
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

one more thing that i noticed is happening when i click upload to i/o board, the "L" light goes into a longer triplet , followed by a  long 15 sec pause, then repeats into the fast triplets, my interpretation is the board is laughing at me.
Logged

0
Offline Offline
God Member
*****
Karma: 0
Posts: 731
skcor oniudrA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
my interpretation is the board is laughing at me.

The relay on my board screech's just before the LED's go out of sequence!

If it ever starts laughing at me, then I'll know it's time to take a vacation.

 ;D ;D ;D
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

It sounds like the board you got from SparkFun has the wrong bootloader on it (i.e. the NG one instead of the Diecimila one).  While it sometimes works, it doesn't always.  I'm not quite sure how it happened, since every Arduino Diecimila leaves Italy with the Diecimila bootloader and in a sealed bag.  Did your board arrive in a small plastic / static bag?  
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
compiles blink fine, but when upload to I/O board i get:
Binary sketch size: 1108 bytes (of a 14336 byte maximum)


avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51


this is on XP

Hi

I have the same problem. I have a arduino NG plus and I used it for like 4 months. last week I got this error :  

Binary sketch size: 6378 bytes (of a 14336 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

when i used a other computer the problem was gone. now after 3 days of programming the arduino has te same problem  and i can't program the arduino anymore.

on the arduino is a program that controls 4 servo motors by commands from the serial port.
when i use hyper terminal the arduino programs works correct accept that the arduino sends no text back to hyper terminal.

this project has to be finisched the day after tomorrow and this is a big problem. now i will use my wiring board for this project.
but i need to solve this problem.

(problem computer: both P4Dual
                              WinXP SP2
                              2 arduino NG plus rev c.



greets arrens
Logged

Pages: [1] 2 3 ... 11   Go Up
Jump to: