Go Down

Topic: avrdude error (Read 90200 times) previous topic - next topic


i have a freeduino and xp on my pc..
the power is on cause the pwr light is on

it happen immideatly when i runned it first time.(blink)
i also couldend instal the drivers.. so how to do that


i guy of my school helped me... it was a error in my pc.
so now it works tnx


Normaly my arduino (duemilanove) board workt, but I have changed the atmega168 MC. So ther is now a new microcontroler in this board, that's because I want to program that one, but I have the same error.

Binary sketch size: 920 bytes (of a 14336 byte maximum)

        Using Port            : \\.\COM3
        Using Programmer      : stk500v1
        Overriding Baud Rate  : 19200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.

The TX and pin13 LED's don't light up. I use Arduino 0016 and I have windows vista.

Mike T

Do you use a ATmega with a preprogrammed Arduino bootloader, or is is just a stock ATmega? The ones with the bootloader are only sold by shops which support the Arduino platform and also sell Arduino boards.

There are ways to do the programming yourself, just use the search function in the forum / playground.



FYI - I was getting a similar error programming with an FTDI Basic board from Spark Fun:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

After some debugging I determined the problem was my connection from the FTDI board to my Arduino board.  Everything is working after adding 1k between the FTDI RX/TX and AVR RX/TX and a 100u Cap between the reset line on the AVR and the DTR on the FTDI.

Hope someone finds this helpful!


Hi I got the same issue with my Freeduino board. I ordered it at nkc_electronics. It was not ready but I got all the pieces necessary to solder it.

When I plug in the USB then the PWR LED is on and the RX/TX LEDs flash shortly.

When I try to upload "Blink", then pin 2 (RXD) flashes shortly, but pin 3 (TXD) keeps being "silent". On the scope I see constant 5 Volts.

Do you have any idea what the reason could be? Me and my colleage have locked at the board but couldn't find any assembly error.

My assumption is that there is no bootloader code on chip at all or the bootloader is damaged.

regards Jensen

Hmm ich habe das gleiche Problem mit meinem Freeduino,

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

der Freeduino ist ganz frisch, habe ihn erst die Tage zusammengelötet. Wenn ich den USB anstecke, leuchtet die PWR LED und RX/TX flackern kurz.

Wenn ich "Blink" hochladen will, "zapppelt" der Pin 2 (RXD) am Atmega328 aber auf Pin3 (TXD) sehe ich nur konstante 5 Volt.

Woran kann dass denn liegen. Ich habe das Board schon mehrfach auf Fehler kontrolliert aber finden konnten wir nichts...

Viele Grüße



I'm getting the same avrdude error on my brother's Arduino Nano.

I've tried it with a Mac running OSx, a dell laptop running Vista, and one running XP. I have another Arduino (Duemilanove) which I can upload to fine from all these machines. I have verified that I'm using the correct port, and that I have the correct board selected. I've tried changing to a different COM port (the one that had been successfully used with the Duemilanove) with no success. I have also tried hitting the reset button on the board at various times during the upload, and unplugging and replugging the USB cable.

The power light is on, and when I hit the reset button the onboard LED 'L' blinks once. When I try to upload a sketch (such as the blink example),  the 'L' LED blinks three times quickly, then the RX light blinks three times with slightly longer intervals between. Then there is a pause of about eight seconds, then one more short blink from the RX light. About 6 seconds after that I get the error in the Arduino IDE.

The board worked fine for about a week before this error appeared. The last thing the board was used for before it got hooped was running an experimental alarm system with a laser pointing at a small solar panel going into an analog input.  For a while the laser was being powered off the 5v pin on the Arduino, but not immediately before the error. Also previously someone had tried to power the board with a wall wart battery charger PS, which it didn't seem to like much, but that was also a while before the error appeared.

What is particularly puzzling is that the board continues to function with the program that's on it.

The avrdude not in sync error is obviously quite generic and can be caused by anything from a simple software configuration mistake to a fried chip. What would perhaps be useful would be to set up a wiki page for troubleshooting this error, where different causes could be identified by what the LEDs are doing, setup configuration, etc.

If anyone has suggestions for getting this Nano to talk again, I would much appreciate it.



I'm having the same problem right now with a Duemilanove.  I'm running Windows XP.  When I plug it into the computer, the power light turns on.  The blinking LED plugged into pin 13 works fine, but whenever I try to upload something, I get this error:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51


Dec 03, 2009, 08:06 pm Last Edit: Dec 03, 2009, 08:10 pm by dufferdev Reason: 1
Hi Friends,

I just got my Freeduino 328 and while I was trying to upload the Blink program I got the same error.

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

When I connect an external LED to pin 13 and GND it mimics the L LED (whick keeps blinking)

Kindly guide me resolve this issue.


Ye and I forgot add the other stuff:

1) I use a Win XP
2) I use the latest Arduino-0017 development environment.
3) I was trying to upload the Blink sketch for the first time


Hello Friends....

I got my issue solved.... This will help people who use Freeduino 328

If your board contains ATMega328 then please select Arduino Duemilanove or Nano w/ ATmega 328.

Open the boards.txt file located in /arduino-0017/hardware folder with your favorite text editor. Change the default speed of atmega328 from 57600 to 19200

atmega328.name=Arduino Duemilanove or Nano w/ ATmega328 atmega328.upload.protocol=stk500 atmega328.upload.maximum_size=30720 atmega328.upload.speed=19200

Then try to upload... you will see Upload Done message.

Hope this helps someone.



When you say "atmega328.name=Arduino Duemilanove or Nano w/ ATmega328 atmega328.upload.protocol=stk500 atmega328.upload.maximum_size=30720 atmega328.upload.speed=19200", is that the newly changed part?  I don't have it with me at the moment, so I can't see what you're talking about yet.


I'm having verification errors with my Duemilanove Arduino Board.  After attempting to upload any program it states:

avrdude:verification error, first mismatch at byte 0x0002 0x61 !=0x62
avrdude: verification error; content mismatch

Have tried different computers and platforms, usb cables, power supplys, reset button but still nothing, it seems that the last successful upload is still active inside the board.

Many people are saying that they're finding the atmega328p chip to be faulty. I can buy an atmega328p but will I have to flash it prior to installing on the duemilanove? Can't the duemil. flash it? How is this done?
Any info much apprec.


Dec 20, 2009, 05:02 pm Last Edit: Dec 20, 2009, 05:48 pm by hkwmon Reason: 1
I´m also unable to upload a example program (Blink).
I receive always the same  messages:
avrdude:stk500_getsync():not in sysc:resp=0x00
avrdude:stk500_disable():protocol error, expect=0x14, resp=0x51

I bought by Sparkfun a FTDI Basic Breakout - 5V and a Arduino Pro 328-5v 16MHz and have installed the IDE 0017. (Windows)

All advice (troubelshooting) why I can't upload my programs I have done and done again. Also the advice from dufferdev change the default speed of atmega328 from 57600 to 19200.
All was unsuccessful.
What else can I do ?  Has somebody any Idea where the problem is ?


Dec 23, 2009, 06:38 am Last Edit: Dec 23, 2009, 06:41 am by balajitenetchat Reason: 1
Hi All,

Please check the link below manual what we have made from Tenet Technetronics.

Hope this will get you progress.

[URL]http://www.tenettech.com/Arduino Mega USB Manual.html[URL]

Tenet Technetronics - we are providing the Arduino to India

Technical Consultant,
Tenet Technetronics.


Can anyone help?  I am a newbie and getting the same error but have something to add.  

In the Arduino Troubleshooting Guide it says:  "Check that you're not running any programs that scan all serial ports, like PDA sync applications, Bluetooth-USB drivers (e.g. BlueSoleil), virtual daemon tools, etc. ".  I am running MS Windows ActiveSync for my cell phone.  Is there a workaround?  Can anyone help?  

The error is:  
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Other Info:  Port set to Com22, Duemilanove with ATMega168 set in software and on board.  

Any help would be really appreciated.  


Go Up