Go Down

Topic: avrdude error (Read 46 times) previous topic - next topic

yeahdixon

ok well i cant recall an arduino sticker but it says "arduino diecimilia" on it and looks exactly like http://www.arduino.cc/en/uploads/Main/ArduinoDiecimila400.jpg

y, there is an onboard led , a few.

when i plugin in the usb i get a constant light on from the pwr
and then there are several brief  flahes on the TX and RX leds which then stop flashing
then on the L Led there are contant flashes that come in triplets and do not stop

when i press the reset button, the "L" led lights up three times in slightly longer succession then goes silent for about 15 secs and then changes to the rapid triplets identical to above.

when i put the led in grnd and 13 the blinks mimic the "L" led.

thanks for the replies guys, much appreciated

ere is an
so when i plug in the usb i get a couple flashes briefly

yeahdixon

one more thing that i noticed is happening when i click upload to i/o board, the "L" light goes into a longer triplet , followed by a  long 15 sec pause, then repeats into the fast triplets, my interpretation is the board is laughing at me.

John_Ryan

Quote
my interpretation is the board is laughing at me.


The relay on my board screech's just before the LED's go out of sequence!

If it ever starts laughing at me, then I'll know it's time to take a vacation.

;D ;D ;D

mellis

It sounds like the board you got from SparkFun has the wrong bootloader on it (i.e. the NG one instead of the Diecimila one).  While it sometimes works, it doesn't always.  I'm not quite sure how it happened, since every Arduino Diecimila leaves Italy with the Diecimila bootloader and in a sealed bag.  Did your board arrive in a small plastic / static bag?  

arrens

Quote
compiles blink fine, but when upload to I/O board i get:
Binary sketch size: 1108 bytes (of a 14336 byte maximum)


avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51


this is on XP


Hi

I have the same problem. I have a arduino NG plus and I used it for like 4 months. last week I got this error :  

Binary sketch size: 6378 bytes (of a 14336 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

when i used a other computer the problem was gone. now after 3 days of programming the arduino has te same problem  and i can't program the arduino anymore.

on the arduino is a program that controls 4 servo motors by commands from the serial port.
when i use hyper terminal the arduino programs works correct accept that the arduino sends no text back to hyper terminal.

this project has to be finisched the day after tomorrow and this is a big problem. now i will use my wiring board for this project.
but i need to solve this problem.

(problem computer: both P4Dual
                             WinXP SP2
                             2 arduino NG plus rev c.



greets arrens

Go Up