Poll
Question: Troubleshooting of Arduino diecimila
connection - 18 (36.7%)
Troubleshooting - 31 (63.3%)
Total Voters: 20

Pages: 1 ... 3 4 [5] 6 7 ... 11   Go Down
Author Topic: avrdude error  (Read 33327 times)
0 Members and 1 Guest are viewing this topic.
UK
Offline Offline
Sr. Member
****
Karma: 1
Posts: 491
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I think I've just borked the bootloader on my Nano. I'd been reading all the tales of woe about avrdude errors thinking I was safe, and suddenly it happens to me. I strongly believe (but have no absolute proof) that it happened when my sketch ran out of memory - I guess it must have crunched something vital. Now the autoreset has stopped working, and like others before me I can only upload by manually resetting the Nano just before the IDE initiates the upload. What I don't understand is how a runtime software error can stop autoreset working when I thought it was a hardware thing (capacitor between serial chip i/o line and atmega's reset line).

If I get a programmer I'll try reflashing the bootloader on my Nano and see if that cures the problem - in the meantime I just watch the verbose output of the build process in the terminal window and hit reset when the "Sketch size blah blah blah" pops up.

Andrew
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
had some trouble uploading my first test program (the standard ledpin 13 blink) to my new Duemilanove w Atmega 328 from a an ibook G4.
after trying half a day to reinstall drivers and trying different cables and resetting in different ways, the error was all in what board I chose in the arduino/tools/board menu: don't select "arduino w diecimila or duemilanove", choose the "arduino w atmega328" instead...
 :-[
Logged

Boston Ma.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
new guy needs help
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I just ran into the same problem. i joined this forum and in 30 seconds I found your post and the solution to my problem. Thanks for banging you're head all day so I don't have to.

 joe
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi!

I was learning how to control dc motor and stepper motor with my Arduino and something has gone wrong...

My servo cable was not connecting very well, and I disconnected and reconnected it from the board (from 5V and GND) while running the sketch; board powered by USB.

At that moment, my Windows XP made that "USB-device-disconnecting-sound" (like when you unplug a pendrive), and from now on I get this error when trying to upload sketches:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

More symptons:

- 13-pin Led dos not blink when I press reset
- when I connect Arduino board to computer, RX and TX blinks 4 times
- when I try to upload some skecth ("Blink", for example), RX blinks 3 times about 2 seconds after I press "upload". Then, after 7 seconds, it blinks again, but just once. And about 5 seconds later I get the error from Arduino program.

I've read and tried almost everything suggested in another posts. I'm using Arduino Decimilia (Freeduino clone), Arduino 0012, Windows XP.

I don't have easy access to a bootloader burner. But if this is the solution, I'll try to get one...

(Was it a big fault to disconnect and reconnect the servo motor "on the fly"? Should I never do this again? Or should I never power the servo using 5V and GND from the board?)

Thanks a lot!
Mturuchiu  
Logged

0
Offline Offline
God Member
*****
Karma: 0
Posts: 588
LumiNet rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It is your board (or was your board) but I do not recommend powering a servo via the 5V of the USB port.

Try to use another USB port and of course reboot your computer.

Are you sure that it was the 5V and not the 3.3V pin? Because in that case it is very likely that you destroyed the FTDI chip. Because this is the one that connects to your PC's USB port and you seem to have problems with the USB connection now...

Are there any LEDs blinking when you power on the board? Try to remove the USB cable and apply external power to the board, what happens then?


Logged


0
Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Not to speculate whether one thing has to do with the other, but this happened to me when I was trying some POV sketches and changed the timer 0 prescaler. Initially pin 3 stopped working (I was using 2 through 9 as outputs,) then pin 4 started working intermittently, then after a final sketch upload the error started happening.

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Pin 13 was blinking at several Hz., and when I tried to upload the sketch I got 3 bliinks out of TX/RX, then another blink a few seconds later, then the error in the Arduino IDE, then after about a minute pin 13 stopped blinking.

When I looked up this error I was a bit distraught to see the variety of solutions people had found to solve or work around the problem, which brings me to my point..

With my Seeduino plugged in I opened a blink sketch, pushed upload, then immediately unplugged the USB cable and plugged it back in. The sketch uploaded and the board seems to be functioning normally now.

It doesn't make sense to me, but it worked. Though the Seeduino is SMT, it appears it's possible to jumper the ICSP to the UART and reload the bootloader via BitBang, http://www.geocities.jp/arduino_diecimila/bootloader/index_en.html
I'm happy to not spend the afternoon doing that.
« Last Edit: March 24, 2009, 11:20:46 pm by Doctor_Wang » Logged

Global Moderator
0
Offline Offline
Newbie
*****
Karma: 0
Posts: 40
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Slightly different story, but I'm guessing it's the same bug:

Platform: Ubuntu Linux
IDE rev: 13 alpha
Arduino: Duemilanove with ATMEGA328

Error:
avrdude: verification error, first mismatch at byte 0x0006
         0x8d != 0x7d
avrdude: verification error; content mismatch

But there are two weird things:

1. It worked OK at first, through about a dozen downloads, then suddenly started exhibiting this problem
2. The same version Arduino is showing no problems when uploaded from a Windows computer running rev 14

At first I suspected a problem with the Linux version 13 alpha, but now I'm not so sure.

Suggestions?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi
I have the same problem with the same symptoms, the plate came sealed, bought in the distributor in Spain.
    and 3 to see if we find the solution.

saludos carlos
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi saludos carlos,
What platform are you using and please my you post the exact error you are getting and tell us the error occurs after doing what?

Mturuchiu
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 17
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

same problem here...
was able to upload 3 times,basic sketch,
since, i get this  :-[

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

i know this is the 4536 time you see it ...
but,i can not do nothing with arduino now.

system is XP and windows 7
went threw all the threads about that subect,
none helped  :-/

thanks

Logged

"The old Europe"
Offline Offline
Edison Member
*
Karma: 1
Posts: 2005
Bootloaders suck!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Do the yellow LEDs still blink briefly if you press upload (L-LED and RX-LED) ?

In case you run windows and it turns out the bootloader program on the ATMega chip is damaged, you can reburn it using this method:

http://www.geocities.jp/arduino_diecimila/bootloader/index_en.html



BTW, couldn't we get a sticky post with information on how to identify bootloader / FTDI / other problems ?
Logged

• Upload doesn't work? Do a loop-back test.
• There's absolutely NO excuse for not having an ISP!
• Your AVR needs a brain surgery? Use the online FUSE calculator.
My projects: RGB LED matrix, RGB LED ring, various ATtiny gadgets...
• Microsoft is not the answer. It is the question, and the answer is NO!

0
Offline Offline
Newbie
*
Karma: 0
Posts: 17
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

finally !!! problem solved  
I can upload sketch to the arduino !  
my problem was one of the system firewalls...
I stopped the windows fire wall and the kaspersky and windows defender, all completely,
and the arduino started to upload immediately  
I started these programs again, and I can steel upload,
it is like the beginning now, I am sure that in a few hours
one of this walls will kick back in, and block the com again.
I will try to isolate which one later on...
Logged

0
Offline Offline
Newbie
*
Karma: 1
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Try disconnect every pins on ur board (not the usb)

it worked on mine
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 6
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i read all the topics but nothing works...
please anyone??  :'( :'( :'( :'(
Logged

"The old Europe"
Offline Offline
Edison Member
*
Karma: 1
Posts: 2005
Bootloaders suck!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Niels, please be a bit more specific.

"nothing works" is vague.

Does the arduino get power (green led lights up) when you plug it into your computer ?

What OS do you use (Mac/Linux/winblows) ?

Tell us what you do and what happens step by step and be verbose.
Logged

• Upload doesn't work? Do a loop-back test.
• There's absolutely NO excuse for not having an ISP!
• Your AVR needs a brain surgery? Use the online FUSE calculator.
My projects: RGB LED matrix, RGB LED ring, various ATtiny gadgets...
• Microsoft is not the answer. It is the question, and the answer is NO!

Pages: 1 ... 3 4 [5] 6 7 ... 11   Go Up
Jump to: