Go Down

Topic: avrdude error (Read 46 times) previous topic - next topic

billtodd

SOLUTION!!!

If you skipped over Da_Hero's solution go back and give it a try, it even works with SparkFun's Ft232R Breakout Board!  If it works for you spread the word and make a note in this thread so others won't miss it.

twico

Tried that, didn't work.

Vankar

#117
May 19, 2010, 10:17 pm Last Edit: May 19, 2010, 10:31 pm by Vankar Reason: 1
Hope this helps someone. I had the very same error and tried everything said here. Then I had the idea to change my usb cable, so I switched it for the one the printer has, and it worked!, now it uploads smoothly and with no errors. So maybe it's all because of faulty usb cables!.

Edit: Nevermind... It stopped working again, sigh  :'(

miso

Hi, I have the same problem :'(
When I try to upload sketches I have this output:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I am using an arduinoBT board on W7.I'm not expert so I tried only a few of the solutions above mentioned, also because many include cables, I don't need them :).I tried to reinstall the board with a different port (default was 41, I used 5) but it still doesn't work....
I need urgent help!!

(sorry if I've wrote something wrong in english  :-[)

Juliano

SOLVED!

The suggestion of Da_Hero works for me.

I was getting the
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51




Go Up