Go Down

Topic: Windows XP won't recognise driver and install (Read 24 times) previous topic - next topic

mellis

einy and Taygun: we've definitely got lots of people using the Uno and Mega 2560 with lots of different varieties of Windows, so it should be possible to get working.  Can you give some more information about what you see in the device manager?  

einy

Under Ports (COM and LPT) General tab
     Arduino Uno (COM3)

        Device Type:   Ports (COM & LPT)
        Manufacturer:   Arduino LLC (www.arduino.cc)
        Location:        Location 0 (Arduino Uno)


Under Driver tab
        Driver Provider:  Arduino LLC (www.arduino.cc)
        Driver Date:       15.11.2007
        Driver Version:    5.1.2600.0
        Digital Signer:     Not digital signed

Under Details tab
        Driver instance Id: USB\VID_2341&PID_0001\64938323131351718032

I have tried to change COM port nr from COM3 to an available port, for instance COM19, but no change.

I still get the same error.

Hope this help you.
     

LeftBrain

#17
Oct 30, 2010, 05:05 am Last Edit: Oct 30, 2010, 07:56 am by MicroStan Reason: 1
Update : I own 4 computers all with varying versions of Windows XP (I've allways been an XP fan and still am), all very nice and well equiped, two notebooks and 2 desktops the newest one purchased just a couple of months ago. Not being one to give up easily I blew out the OS on each computer and tried to re-install Arduino on each one again with total failure. FTDI's website is pretty user unfriendly as well so no help there either.  


LeftBrain

Charbot this post will probably get axed but if you are trying to teach an after school robotics class try Parallax, they have a whole line devoted to teaching robotics directed at boards of education, fully supported and backed by texts in the form of books all very user friendly.

einy

I've bought a new PC with Windows 7 Ultimate. Of course I had to try Uno once more.

Plugged in and installed the driver as described.
Same error as earlier.

I tried and tried. Got angry. The Uno is useless so I almost banged the on board switch, somtimes at the same time when uploading,  and - then it worked!

Tried it on my XP PC and it worked there to!

I've rebooted both PC, tried for seveal days, no problem!

Is there som explanation on this matter?

There is no bad solderings on Uno (checked with magnifying glass).

colonel sanders

I followed these steps and the Arduino Uno worked with my Acer Aspire One with Windows XP Home:
 - downloaded and installed Arduino 0021
 - plugged the Arduino uno in via USB
 - Ran Add Hardware from Control Panel
 - pointed the wizard to the Arduino Uno driver that came with Arduino 0021,
 - it is working.

john.olsen

I am having the same issues as einy and LeftBrain and am also just about ready to throw my UNO in the trash. But as a last effort, I will try to describe here the exact process that fails in hope of getting help. I follow the instructions provided exactly and XP seems to be installing everything perfectly. I see usbser.sys flash past on the screen. Then as the last item a windows message pops up that says:

Cannot Install this Hardware
There was a problem installing this hardware
Arduino UNO
The system cannot find the file specified.
Click Finish to close the wizard.

At this point the hardware manager shows the Arduino under the serial ports but with a yellow triangle. Clicking to fix the problem here only leads to a process that results in the same message as above.

Does anyone know what file is missing and where to get it? I have also tried getting the latest from the FTDI web site with the same results.

Also, does anyone know if other Arduinos have the same issues or whether the UNO will run with Linux without these issues.  

pluggy

Gonna have to buy a Uno and see if all these problems are real or just finger trouble.  I know first hand the Duemilanove and several of its clones work with XP and Linux.  The Uno was supposed to make life  easier because it didn't need a driver for Windows - just an .inf file to configure the existing one.
http://pluggy.is-a-geek.com/index.html

pluggy

#23
Nov 27, 2010, 08:45 pm Last Edit: Nov 27, 2010, 08:47 pm by stephen_t Reason: 1
Just placed an order with my genuine Arduino supplier of choice for a Uno.........

How hard can it be ?         ;)

A bit cheaper than my Duemilanove cost back then :)
http://pluggy.is-a-geek.com/index.html

pluggy

#24
Nov 27, 2010, 08:57 pm Last Edit: Nov 27, 2010, 09:22 pm by stephen_t Reason: 1
@john.olsen, you're wasting your time with the FTDI site since the Uno doesn't contain an FTDI chip.  Its there for the old sods like me with Dumilanoves and earlier which did.......
http://pluggy.is-a-geek.com/index.html

jcarrr

This usually fixes our xps that have this problem.  Uno have never  been a problem

http://www.ftdichip.com/Drivers/CDM/CDM20802_Setup.exe

john.olsen

OK, I give up trying to run an UNO under XP. Does anyone know whether any of the other Arduinos run under XP? Do any of the others use a real USB chip that does not need serial port emulators? One of the main points of USB was to avoid all this serial port nonsense.

From all the info on the Arduinos I am anxious to start working with them and will even set up a Linux machine if that is the only way

PaulS

Quote
Does anyone know whether any of the other Arduinos run under XP?

I never had any problems with the Duemilanoves using XP.

Quote
Do any of the others use a real USB chip

No. They all use a USB to serial converter.

Quote
One of the main points of USB was to avoid all this serial port nonsense.

What "nonsense" are you referring to? The Arduino is NOT a USB device. It is a TTL serial device. The use of real serial ports on computers have declined so much that virtually no
computers ship with serial ports these days. So, some kind of adapter is required. The USB to serial chips are perfect for that.

Quote
From all the info on the Arduinos I am anxious to start working with them and will even set up a Linux machine if that is the only way

It's a way, but not the only way.

einy

Sad news, Uno stopped working on XP (still working on Win7).
Realy sad, because:

1. The HW is good and shield comaptible with Netduino.

2. I found "Visual Micro". That means Uno can be programmed with   Visual Studio.

3. You can develop project with Uno, program the CPU, take it out and put it directly in to your homemade circuits, which isn't possible with Netduino.

For how long will it work with Win7? I havn't got time to take that risk.

Is there anyone who know something about that there will be a fix for this problem?

mellis

For the people having problems: are you running the 32 or 64-bit version of Windows?

Go Up