Go Down

Topic: Windows XP won't recognise driver and install (Read 25353 times) previous topic - next topic

LeftBrain

Oct 19, 2010, 09:08 am Last Edit: Oct 19, 2010, 11:02 pm by MicroStan Reason: 1
Tried for 6 hours, up until 3am on a work night. Windows XP home will not find and/or recognise the drivers. Please help before I wing my Uno out the window.

LeftBrain

Update - After much internet research and hearing the common theme 'this doesn't work' that doesn't work' can't do this ' can't get that to work' I'm finished with Arduino. I've been programing with other micro controllers for years with much success and will be sticking with those. Lesson learned.

DustinB

I don't have an UNO, but I had no problem installing. How did you try and install?

You should let the window box pop up, then specify the location to search. Select the arduino/drivers folder and windows should do the rest. You may have to do it twice as sometimes the "found new hardware" thing seems to pop up 2 instances.

No sense in getting frustrating and saying "I quit". What kind of thing to say is that for someone messing with DIY electronics. When you have a problem you don't submit and move on, you beat that problem into submission! A few more details would definitely help others help you.

pluggy

I'd be prepared to wager money, that if Windows was scrubbed and re-installed , it would work straight off.........
http://pluggy.is-a-geek.com/index.html

LeftBrain

#4
Oct 20, 2010, 02:01 am Last Edit: Oct 20, 2010, 02:01 am by MicroStan Reason: 1
Dustin, I like how you think, you are right.

Installing the drivers should be the easiest thing about this though.

I've posted here, scoured the internet and even contacted FTDI with no success (FTDI said not their product not their problem by the way. Contrary to the suggested direction to go in other threads).

After spending nine hours on this the next step is to scour computer files, com port configs, PID and VID files but I'd rather put the Uno back in it's box and wait for the makers to publish executable driver disks.

Pluggy if what you mean is, to format and recover my OS, thanks, I've thought of that to but it shouldn't be that hard to install drivers

All in all I'm having to much fun with other microcontroller platforms that are fully supported.

nettinelli

I had the same problem. My solution was, that I had chosen wrong folder. I took folder Arduino-0021 -> Drivers -> FTDI USB Drivers. And it didn't work... But when I chose folder Arduino-0021 -> Drivers, the installation succeed.  
(I have Windows XP.)

nettinelli

I rejoiced too soon  :-[ I succeed in Blink, but then I tried servo. At first it worked okay, but then L-led (pin13) turned off and now my computer won't detect Uno anymore. Any ideas? ON lights when I connect Uno via USB, but it doesn't appear to my system-tree. Is there anything to do? Or is my very first Uno kaput?

(P.S. Sorry for my bad English... I'm from Finland and this is the first time I have the face to take part in these conversations... So I'm really desperate  :o

pluggy

#7
Oct 22, 2010, 08:06 pm Last Edit: Oct 22, 2010, 08:09 pm by stephen_t Reason: 1
Quote
I've thought of that to but it shouldn't be that hard to install drivers


You're right, but its not an Arduino problem, its a Windows problem. Over time it gets mangled and it stops things working. The arduino driver problem is likely just a symptom. ¬†Mangled Windows causes all kinds of problems that just vaporise after a major clean up. ¬†I know the Arduino works fine on a clean Windows system.  First course of action is to try it on another computer, if it works on another PC, its your computer that is the problem.

http://pluggy.is-a-geek.com/index.html

einy

I'm also finished with Arduino (Uno).
I have the same (famous) problem:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51.

For several hours I've scanned forums for this error and followed the suggestions for solving this problem, but no avail.

I have also programmed other micro controllers (from motorola 6800 to msp430-xxxxx). There was (of course) som minor problems, but I was able to solve it in short time.

I've tried it on two computers; my XP laptop and a Server 2003 (only SQL server running), but the same error.

The funny thing is that there when I'm using the "Serial Monitor" and TX- RX pin connected together, I get feedback...

I was lucky once, I managed to upload a modified version of "Blink". Thats all...

My Uno is now in the dustbin!

mellis

einy: did you try going to the Device Manager, right-clicking the Arduino device and doing an update driver?  

einy

Many times. Uninstall, reinstall, update, reboot etc...

As I also mentioned i my post, I tried it on another computer with the same result.

As I also mentioned is that I did get reply from the serial montor, but now this has also stopped.

I think it is the driver which is the big problem here.
There are also several cases same as mine, when I searched the internet on this error.

But I have also good news here. I also bought a Netduino together with Arduino Uno. I installed the driver, and... it just worked!!! Every program (I/O, sensors, motors) I have tried just work!!!
Was I just lucky? I got curious, so I installed and tested it om a MS 2003 server. I was very relived, it worked here too!!!

I've been programming C# for years so this is just great!

I've been dealing with PC, hardware, software and programming for years so I think I'am not a newbie, but in this fragmented world I have learned myself a humble approach to this matter.

I must also admit that I picked up Uno from my dusbin, waiting for a better driver...

Thank you for your reply!



Charbot

Im having a similar problem with an afterschool robotics class that I am (trying to )teach.   the computers will not recognize any of our 8 duemilanove boards. Every time I plug in a board I get the new hardware wizard  and after a "sucessful"  driver install,  a "new hardware detected" message  immediately pops up.?
    I tried selecting the drivers foler, ftdi usb drivers folder....
Arduine 0021 runs and appears to upload but along with "done uploading" im getting an AVRDUDE timing error /out of sync.   We are using school comuters with some pretty intense security settings, but even in "admin" it didnt work.  The schools computer tech and I tried for hours yesterday.   Any ideas?

Taygun

Too much confusion for an easy attempt. Arduino is slowly losing its usefullness and simplicity due to this issue. I am trying for a week but i can not get mega2560 to work with any windows xp.

einy

If there is no fix for this problem, Arduino is nothing more than a flop. Pity, because the hardware is excellent.

The real bad thing here is the beginners who want to learn about this exciting world, encounter such problems, may give up because this is to difficult.

To Charbot: I think you have to choices, wait for a better driver or go for Netduino. Visual Studio (Express is free) is an excellent programming environment and you learn C#.

The drawback is C is used in the industry and you are locked to one platform (though mono is a way around) and M$ as well.

Wish you good luck!


mellis

charbot: the Duemilanove USB communication and drivers are totally different from the Uno, so it might be best to start a new thread.  That said, with the FTDI chip on the Duemilanove, the new hardware wizard will typically appear twice, once for "USB-serial device" and one for "USB-serial port" or something like that.  I'd try the troubleshooting suggestions: http://arduino.cc/en/Guide/Troubleshooting and starting a new thread with the verbose output and OS details, etc.

Go Up