Pages: [1]   Go Down
Author Topic: not in sync / protocol error  (Read 5695 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Dear all

I received my Arduino Duemilanove today.  To my surprise not with the ATmega168, but with the ATmega328.  That's good.

Trouble is that I can't upload a sketch
It simply says

avrdude: stk500_getsync(): not in sync: resp=0x20
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0xe0

I am using Ubuntu 8.10 (Intrepid Ibex)
I installed everything as follows :

$ sudo apt-get remove brltty
$ sudo apt-get install sun-java6-jre
$ sudo apt-get install gcc-avr
$ sudo apt-get install avr-libc
$ gzip -cd arduino-0013-linux2.tgz | tar xf -

$ cd arduino-0013
$ ./arduino

When I connect the board, this shows up in /var/log/messages :

Feb 26 20:17:57 infinity kernel: [36725.976167] usb 3-1: new full speed USB device using uhci_hcd and address 5
Feb 26 20:17:57 infinity kernel: [36726.181187] usb 3-1: configuration #1 chosen from 1 choice
Feb 26 20:17:57 infinity kernel: [36726.185594] ftdi_sio 3-1:1.0: FTDI USB Serial Device converter detected
Feb 26 20:17:57 infinity kernel: [36726.187908] ftdi_sio: Detected FT232RL
Feb 26 20:17:57 infinity kernel: [36726.189613] usb 3-1: FTDI USB Serial Device converter now attached to ttyUSB0

The arduino tool correctly sees my board as /dev/ttyUSB0

On the board, the PWR LED lights up and the pin13 LED flashes twice.  There is also some short activity on TX and RX (is that normal ?)

When I try to upload the Blink sketch, the LEDs play
the same sequence (autoreset I suppose) and then I get the

avrdude: stk500_getsync(): not in sync: resp=0x20
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0xe0

error.

Any ideas would be very welcome


Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What an idiot I have been !
Under Tools -> Board I had selected
"Arduino Decimila or Duemilanove"
where I should have selected
"Arduino w/ ATmega328"

Sorry for the trouble

inetd
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

My friend, I am the beginner. I encounter the same problem with you.
The experience you share here is helpful me. I am now seeing my LED blinking with lots pleasures. smiley
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

your my hero... thanks for posting this information...
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 13
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hey thanks for that. got me also  smiley-sad
Logged

Pages: [1]   Go Up
Jump to: