Pages: [1]   Go Down
Author Topic: Mega error while programming bootloader  (Read 1643 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I get this error while trying to program the bootloader on a Mega board. Linux Fedora Core 10 & Arduino 0016. Same problem in Windows. Same problem on different hardware.  Had no problems running sketches. Gave below error while programming bootloader. Any ideas why?

avrdude: verification error, first mismatch at byte 0x1f000
         0x0c != 0xff
avrdude: verification error; content mismatch
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

What programmer are you using?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

USBTinyISP with avrdude. Tried two different USBTinyISP's with same result. In addition to using the avrdude that came with arduino-0016, used the latest version (5.smiley-cool. Same problem. When programming the mega with c programs and no bootloader, I have no problems.
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

It's possible the USBtinyISP won't program the Mega.  It's not quite as flexible as the AVRISP mkII in terms of the things that it tolerates on the SPI lines.  
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That doesn't make sense to me though. If I don't use the Arduino Mega bootloader and just use avrdude to load up regular code written in C and compiled with avr-gcc I have no verification errors. It's only when loading the bootloader I get the exact same error every time. Windows or Linux. I'm still going to try an AVRisp and see if I get the error.
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

So you can "burn" code to the board using the USBtinyISP?  What command line do you use?
Logged

The Netherlands
Offline Offline
Newbie
*
Karma: 0
Posts: 6
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi there,

I'm having the same problem as Gary Nutbeam describes: when I try to burn the Arduino Mega bootloader with the USBtinyISP from Arduino 0017 I get the following error:
Code:
avrdude: verification error, first mismatch at byte 0x1f000
         0x0c != 0xff
avrdude: verification error; content mismatch

On the other hand, when I burn the "arduino-0017\hardware\bootloaders\atmegaATmegaBOOT_168_atmega1280.hex" file with AVR Studio and the AVR Dragon the bootloader gets burnt just fine.

And the strangest thing is that the firmware burnt with the USBtinyISP and Arduino-0017 seems to work just fine; I can compile and upload programs just fine.
Logged

The Netherlands
Offline Offline
Newbie
*
Karma: 0
Posts: 6
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've done a little more research and verified the burned bootloader with the AVR Studio and AVR Dragon. It turns out that the bootloader does get burned correctly. My procedure was to first erase the entire Atmega1280 chip, then burn the bootloader with the USBtinyISP and Arduino-0017. This gave me (again) the error I reported in my previous post.
Afterwards, I verified the bootloader with AVR Studio and the AVR Dragon ISP. Here's the result:
Code:
OK
Reading FLASH input file.. OK
Setting device parameters.. OK!
Entering programming mode.. OK!
Reading FLASH ..      OK!
FLASH contents is equal to file.. OK
Leaving programming mode.. OK!

So it turns out the Arduino-0017 programming environment reports a verification error, but the bootloader is in fact burnt correctly. There could thus be either a bug in Arduino-0017 or a bug in the AVRtinyISP...
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,
i have exactly the same problem on arduino0018 on mac osx with usbtinyisp, it reports the error but it seems to work fine afterwards
any news about this problem? is the problem rproven to be from the usbtinyisp?
best
andre
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

yep same here with SparkFun Pocket AVR Programmer a USBTiny clone...


avrdude: verification error, first mismatch at byte 0x1f000
         0x0c != 0xff
avrdude: verification error; content mismatch


This happens on both OSX and WinXP

I also have a Atmel AVRISP MKII and that programmer burns the Arduino MEGA bootloader just fine on both Mac and PC...

CheerZ,

-M-
Logged

Orlando, FL
Offline Offline
Full Member
***
Karma: 0
Posts: 129
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I just tried it today with an Atmel 1280 chip and a USBTinyISP.  I"m getting the same error in Arduino 20.
Logged

+B011111
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Arduino IDE v0022 does the same thing while burning the bootloader to the board using the USBTinyISP...
Logged

Pages: [1]   Go Up
Jump to: