Pages: [1]   Go Down
Author Topic: serial port disappears when a servo is connected  (Read 1374 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

plzz help me iam new to arduino ...i wanted to control a servo through serial port .the problem is that when the servo is connected i cant use the com port the following error is coming and the port is working after the servo is removed ....

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

here is the image
Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 331
Posts: 16514
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Most likely your servo is drawing more then the 500ma max that a usb connection allows. Power your servo with an external regulated +5vdc supply or four AA batteries and see if the problem does not go away. Be sure to also make a wire connection from the external ground to the arduino ground.

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

tanx @retrolefty  i will try it and post the result
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

thanks again retrolefty  the problem is resolved smiley-grin
Logged

Pages: [1]   Go Up
Jump to: