Go Down

Topic: :-S arduino lilypad blues :: not in sync (Read 19378 times) previous topic - next topic


I'm sooooo bummed that I can't get my lilypad running.

I am using the mini USB adapter to connect the lilypad to my pc.

I've tried everything including:

~Checking my soldering of wires to the USB board to ensure they're clean (they are)
~Set upload.verbose=true although that does not seem to provide any extra troubleshooting or diagnotic info.
~Reset the lilypad before uploading, after uploading, during uploading, at different intervals
~Ensured the proper serial port is selected
~Ensured lilypad arduino board is selected
~installed and reinstalled the USB drivers included with arduino IDE and the updated drivers from the website
~checked the windows event log
~tried a different USB port
~tried different machines: one XP and one Vista
~turned off windows firewall
~rebooted my PCs
~reduced and increased the baud rate on the com port

The LED on the lilypad is blinking rapidly which makes me think the RX is working.

YET, I try to upload the blink sketch and it simply won't upload.

The following error info is returned:

Binary sketch size: 1112 bytes (of a 14336 byte maximum)

   avrdude: stk500_getsync(): not in sync: resp=0x00
  avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

What should i do ??

Is there a was to test the mini USB board?

What else can I do? Buy an arduino NG for $40 and see if that works??

Seems I spent $$ on something I will never be able to use :'(

Any ideas??


I dont have the answer for you, but I am here to say that you are not alone.  I have the same problem with my lilypad and mini usb adapter (exact same error message).  I believe that there is a problem with the Lilypads or the mini usb adapters.  I asked in the forum for help to solve the problem and others have too, only to be told that it could be any number of things causing that error.  Thus, I bucked up and bought a diecimila which works fine.   This tells me that the FTDI drivers are at least working as well as the stk500, which (if im not mistaken) are used with the diecimila.  

If anybody knows of a way to to check the function of the miniusb adapter, please let us know.  This will help trouble shoot the problem and narrow down a possible solution.  


I don't have an adapter to test with, but could you jumper the RX TX pins, power it up, open a serial terminal program (e.g. puTTY) and see if what you send out is looped back to you?


Anyone who is having problems, could you post a photo of your mini-->LilyPad connection?  

&, try:
* physically press on the tx/rx connections during the upload process to make sure you're getting good contact.  If bad contact w/ alligator clips is what's causing your problems, make a coaster for your LilyPad ( http://www.cs.colorado.edu/~buechley/LilyPad/coaster.html)
* swap tx & rx (maybe they're just accidentally swapped in your setup)
* make sure your LilyPad is getting power from the USB adapter.  There are different jumper settings on the USB adapter that let you use an external power supply OR the USB port for power.  If your LilyPad is blinking when you press the reset switch, you are getting power & things are OK, otherwise, find the right USB jumper setting.


other things i've tried

using telnet to connect to COM3 (verified this is right in device mgr)

using puTTY to connect to COM3

in both cases i couldn't make a connection although I must admit i don't have much experience with the tools.

Is "telnet COM3" proper syntax?

Putty has a gui which I selected COM3 with. Basically i just got a window with a green box cursor which would not allow any typing so i'm assuming the utility couldn't connect.

I suspect that my mini USB connection is working. When I attempt to upload to the lilypad I consistently see three blinks on the TX led on the mini USB board.

I made a coaster to ensure alligator clips are squeezing hard.

STILL...no upload.


Also went to http://www.ftdichip.com/Drivers/VCP.htm and ran the setup executable, restarted arduino, un/plug'd the lilypad and tried uploading again...no deal  :P


Here's a little tidbit for someone more knowledgeable than me to ponder and maybe you can tell me if things are supposed to be this way:

1.     I can remove the +5V connection from the USBMini to the Lilypad and STILL HAVE POWER TO THE LILYPAD.  Go figure.  With the TX, RX, and Ground hooked up, I have a lit LED and it will flash when reset is pressed.  If gound is unhooked at any time (even with +5V attached, there is no power)

2.     I took power readings on the USBMini (while hooked to my laptop) from TX, RX, +5V ---- with and without the jumper on and here are my readings:

       TX w/out jumper = 2.42V
       TX with jumper   = 3.75V
       RX w/out jumper = 4.80V
       RX with jumper   = 4.99V
       +5 w/out jumper = 1.53V
       +5 with jumper   = 5.15V

3.    Is there supposed to be that much juice going through the TX and RX even without data flow?

4.    How is it that either the TX or RX is somehow supplying "power" to the Lilypad and allowing it to power up even WITHOUT ANYTHING hooked to the +5V connection on the Lilypad.  Is there some monster Cap on there that can dispense power for at least a minute.  It seems as if some of the traces on the Lilypad are crossed somewhere.

All very strange.  I'm definitely a nooby, but when I disconnected the +5V and I still had power, my head almost spun off.  


Are you sure COM3 is the right port?  Look for a USB-Serial device in the Windows Device Manager, and make sure you select that COM port in the Arduino Serial Port menu.  

Also, are those pieces of black foam conductive?  You might want to remove it from the Mini-USB Adapter.  Did you check the connections between the pads on the Mini-USB Adapter and the pads on the LilyPad with a multimeter?  What's the resistance between them?  The connection between the alligator clips and the Mini-USB adapter looks like it might be a bit unstable.

Did you get any more output when you set upload.verbose to true?  It might provide an indication of whether or not any data at all is making it to the LilyPad.

Does the RX LED on the Mini-USB Adapter ever blink?



Two things happened.

1.  The foam is conducive.  I ran out into the garage after your last post, pulled the foam off of my USBMini (which I think I always had on there), hooked it to the Ohm meter and wahlah.....

2.  My RX and TX are in fact crossed.  Not my wires but it must be something on the USBMini.  My wires are all color coded and I've looked at it a dozen times, but I figured what do I have to loose by crossing them, it's as good as bricked the way it is now.  And bammmmmm  I uploaded the blink sketch without a problem...

The thing that still confuses me is why was I getting a flashing led without +5V hooked up to the Lilypad????? Even without the foam in there, it still did it.

Oh well.........Now I have a diecimila.....AND......a Lilypad.

Good luck Tickler.....I hope yours is the same problem as mine....


:-[ i think i toasted my mini USB trying to read the voltage.

Now both the rx and tx lights are on and if I leave it plugged in it gets *really* hot.

guess i have to order an arduino board and try that.

this really sux...


seems like this is a product change request and/or product opportunity



Can someone confirm that the TX on the mini USB should connect to the RX on the lilypad?

Looking more closely, it appears that my mini USB is not exactly the same as the one here
http://www.cs.colorado.edu/~buechley/images/diy_lilypad/lilypad_tutorial%20-%2041.JPG so it may have been an error to assume the location of the rx/tx contacts are the same as mine.

I suppose it makes sense that the TX (outbound) on the mini USB should connect to the RX (inbound) on the Lilypad.


I am working on a new version w/ better connection!  Stay tuned & please, send me design feedback: Leah.Buechley@colorado.edu.  


leahb and tickler,

the tx/rx issue isn't exactly as it seems.  it may be 'technically' correct to connect tx from usbmini to rx on lilypad, but this is assuming that tx and rx on the usbmini are 'traced' correctly on the printed circuit board.  I am here to tell you that i currently connect rx on my miniusb to rx on my lilypad and i connect tx to tx.  This is the way it works on mine.  (This next statement is not a slam) My only explanation is that someone made a mistake on the lilypad traces or the miniusb traces and put one of them backwards.  

There are ALOT of people that have complained about this not in sync issue.  One of the common replies is 'switch your tx and rx connections'.  i was getting the same error when trying things the 'right' way but when i put rx to rx and tx to tx, it started working fine.

Just some food for thought.  Things are not always as they seem.  i havent done this, but you may want to grab a powerfull mangifying glass and see if you can follow the traces on the pcb from the rx/tx to the pins on the lilypad and the miniusb and see what pins they go to and compare that to the schematics.

Go Up