Go Down

Topic: avrdude programmer is not responding (Read 77016 times) previous topic - next topic


Oct 14, 2010, 02:23 am Last Edit: Oct 14, 2010, 03:19 am by bubba5656 Reason: 1
Macbook 10.4.11
new Arduino Uno atmel 328

I just got it and followed the getting started instrustion on this site(mind you i have nothing but the usb plugged in). Ive tried this with a several of the example sketches all with the same out come.

plug in the usb
open arduino 0021
open a example

while Im uploading the Tx and Rx do flash a little bit (the rx flashes much more the the Tx)

then it says

"avrdude: stk500_getsync(): not in sync: resp=0x86"
a few seconds pass then
"avrdud: stk500_recv(): programmer is not responding"

I think this issue is often asked and im sorry I did search and none of the solutions seemed to work. ps does it matter which usb it is plugged into? also yes in tools its set to uno and tty.usbmodem

Thank you for your time and help

pps I also tried it on another macbook with exactly the same problem. And if this helps the L led flashes 4 times then stutters the flashes 4 times and stutters over and over when it is just plugged in

Coding Badly

Does anything here help...


No I have already read through that post and was unable to resolve my problem with that solution. But this morning I used screen /dev/tty.usbmodem..... and it wrote 5 or 6 random ascii characters and thats all. I think it is connecting because the tx and rx leds do flash a bit and my mac does seem to see the arduino.


Any ideas anyone. Im gonna try uploading onto it today using a pc hopefully its something wrong with my lap top but I have a sneaking suspicion that its not the computer causing the issue


so I did screen /dev/tty.usbmodem..... and pressed reset a few times and it printed "a"$$ ???a??  &??a?&?? "?`?a("&0$?a0& ??""?`?" so I think its communication one way or my baud is off


Oct 15, 2010, 07:36 pm Last Edit: Oct 15, 2010, 08:17 pm by bubba5656 Reason: 1
here is the output with verbose

System wide configuration file is

user configuration file is "/users/XXXXXXXXX/.avrduderc"
user configuration file does not exist or is not a regular file, skipping

        Using Port            : /dev/tty.usbmodem0000103D1
        Using Programmer      : stk500v1
        Overriding Baud Rate  : 115200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv: . [86]
avrdude: stk500_getsync(): not in sync: resp=0x86
avrdude: Send: Q [51]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

does the usb cable length matter? mines about 4 feet


Did you manage to try with Windows?  Or maybe a Mac running 10.5 or 10.6?  That could help narrow down if it's the board or the computer.


Im getting my pc back at the end of the week and see if it works in a windows 7 enviroment


I had the same problem, using an older mac with an arduino uno. I found that if I hold down the reset while plugging the usb cable into the arduino, with the computer already on that this solves the problem...

The pain is that you will have to do this every time you want to upload a new program, better than not working at all :-/


i have the same problem. other boards are fine, just the uno not.
osx 10.4.11 / 0021 / newest FTDIUSBSerialDriver

mariolh's workaround dos the job, but yes...not very elegant



I have the same problem with the UNO.
Running a G5 quatro powermac 10.4.11.

My mac recognizes the board as a modem as it should. And I can choose the right serial port (modem).
But if I start to upload it gets a sync or not responding problem.

I tried a few things and the only thing that sometimes works  is holding the reset button starting the upload. And release it when it's compiled. Or sometimes just push the reset button when it's compiled.
If I try it 15 times it will work only ones. A bit frustrating :-/. So there got to be a work around for this problem.

I thought the UNO would be even easier to use. But that ain't the truth for me. Luckily a have a few other previous gen boards lying around.

Bubba5656 let us know if you got the board running on windows 7?


I'm having the exact same problem but don't seem to be able to fix it regardless of when I push/hold reset.

Also, my led  (L) is already blinking straight out of the box...is that supposed to happen?


Also, my led  (L) is already blinking straight out of the box...is that supposed to happen?

No. It should only blink when it has power connected to it. If yours was blinking when you took it out of the box, you should put it back in the box and return it.
The art of getting good answers lies in asking good questions.

Go Up