Pages: [1]   Go Down
Author Topic: Lendo um controle de portao  (Read 1137 times)
0 Members and 1 Guest are viewing this topic.
Santo Andre, SP
Offline Offline
Full Member
***
Karma: 1
Posts: 131
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Comprei um receptor de 433Mhz e estou tentando reproduzir o codigo que existe no receptor do meu portão. De fazer o pareamento com o controle e identificar cada um dos bot[ch7869]s. Pois vou usar o mesmo controle para outras funções como ligar umas luzes na empresa (lonje do portão é claro rsssss). É coisa só de brincadeira para aprender como funciona mesmo.
Até agora não consegui nada de util, apesar de que simplesmente estou elndo a saida do receptor numa porta digital e estou saindo na porta serial o resultado. Além o druido eu não consigo identificar nenhum padrão. Estou suando um delay na leitura. Alguém já brincou com isso? Alguma dica?
[]s
Logged

Artur Porcão

0
Offline Offline
Newbie
*
Karma: 0
Posts: 21
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Vamos por partes:

Este receptor reconhece os sinais do controle?

Mostre uma das saidas quando você aperta o botão para a gente ver se entende.

Abraço

3d29
Logged

Santo Andre, SP
Offline Offline
Full Member
***
Karma: 1
Posts: 131
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Sim, recebe. Eu coloquei a saida no osciloscopio e estava lá o codigo do chaveiro.

Eu não tenho saida nenhuma, atpe agora não consegui ler nada de util no Arduino. Tentei contar o tempo em que o sinal vica em baixo e em alto para encontrar algum padrão mas não vi nada de util.
Pelo viso  transmissão usa o codigo manchester ou algo do naipe, só que nenhuma lib que eu encontrei consegue ler.
Inclusive achei essa lib aqui: http://framistats.com/arduino-projects/rf/
Não deu certo para o que eu quero mas parece ser ótima.
[]s
Logged

Artur Porcão

Santo Andre, SP
Offline Offline
Full Member
***
Karma: 1
Posts: 131
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Acabei de montar um teste dos bem simples.
Montei um TX e RX com o VirtualWire. 10 minutos de tentativa e nada de funcionar.
Usei essa lib aí de cima e funcionou de primeira. Então o RX (e TX) estão funcionando normalmente. Tantoq eu consegui ler alguma entrada. O que não tá rolando é a leitura de um sinal enviado pelo controle do portão.
[]s
Logged

Artur Porcão

Santo Andre, SP
Offline Offline
Full Member
***
Karma: 1
Posts: 131
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Esquecid e falar. Fiz uma confirmaçao super simples de frequnencia.
Enquanto o TX enviava numeros em sequencia para o RX eu aciuonei o controle do portão. A interferencia fez o RX nãor eceber os dados enviados pelo TX, o que mais uma vez confirma de que estão na mesma frequencia. Fiz o teste ocm outro controle que é 315Mhz se não me engano e nenhuma interferencia foi gerada.

[]s
Logged

Artur Porcão

Pages: [1]   Go Up
Jump to: