Go Down

Topic: Dificuldades a ligar o LCD (Read 3203 times) previous topic - next topic

Fblanco

Olá

Eu comprei um LCD mas não estou a conseguir ligá-lo ao arduino. Segui as instruções do tutorial de LCD's "Hello World" mas o display simplesmente não reage...
Ás vezes o arduino desliga-se sozinho, não sei se está a fazer algum curto-circuito :/

Será que alguém me pode ajudar?

Fblanco

Comprei nesta loja:
http://www.catalogo.dimofel.pt/catalogue/index.php?action=detailFo&id=22179&backLink=%2Fcatalogue%2Findex.php%3FsearchField%3Dtitle%26searchValue%3Ddisplay%26action%3DsearchFoSubmit

E o display vinha com esta planta do circuito:
http://www.designconceptsinc.biz/PDF/LCM_CMC216X04.pdf

Obrigado!!

Italo Lima

Como está fazendo a alimentação do LCD?

Fblanco

Estou a seguir o esquema do tutorial

http://arduino.cc/en/Tutorial/LiquidCrystal

Ligado ao USB.
Será que a tensão não chega?

Italo Lima

Quando o arduino desliga-se o computador avisa algo? Como por exemplo, que a porta USB tentou usar mais corrente do que o máximo permitido?

Tenta posta o esquema exato da ligação que você está usando.

Fblanco

O arduino desliga-se e para o computador é como se tivesse tirado o cabo usb.

Aqui vai o minha montagem, os pinos vão de 1 a 16, da esquerda para a direita.

Eu sou novo em electrónica, por isso devo estar a fazer algum erro muito básico :P


Fblanco

Aqui está a imagem... estava com dificuldades em colocar no forum

http://1.bp.blogspot.com/_weWGQYsW-Io/S2nnpS7EgyI/AAAAAAAAAOY/92IqzGA69Dw/s1600-h/Fotos-0005.jpg

Italo Lima

Não consigo ver o porquê do arduino desligar...
Mas tem um pequeno erro na configuração dos seu pinos. Reveja o datasheet do seu LCD e o esquema do tutorial do site. No site, os pinos são 1 a 14 + 15 e 16, no seu são 14 a 1 + 15 e 16.

Fblanco

Por acaso já tinha reparado nisso, mas no PCB os números estão sequenciados correctamente:

http://3.bp.blogspot.com/_weWGQYsW-Io/S2oWokfEGlI/AAAAAAAAAOg/bwt1rRZpVv0/s400/Fotos-0006.jpg

De qualquer maneira amanhã vou experimentar seguir o datasheet e depois digo alguma coisa.

Obrigado pela ajuda ;)


denadai

Caros,

Alimentação do pino de contraste é essencial para o correto funcionamento!

Não confio muito em 5V provenientes do Arduino, prefira usar uma fonte externa...

e nunca, nunca esqueça de conectar os GND's da vida!

Att,

Julio RY

Acho que o pino do GND está no lugar errado no arduino! mude ele para conector ao lado...... pois no meu dos 5v para o arduino tem uma pino vazio, e realmente parece q o GND é do lado dos 5v pelo que esta na placa.. mas não é

Fblanco

Já experimentei mudar para uma alimentação externa com uma pilha de 9V e um regulador de tensão de 5V. O arduino deixou de desligar mas o LCD continua "morto".

- Italo Lima: Experimentei mudar os pinos de 1 a 14 mas continua a não dar sinal.

- denadai: qual é o pino de contraste? é o Vo?

- Julio RY: por acaso tinha reparado nesse pormenor, mas troquei e o problema continuou. Quando uso a alimentação proveniente do arduino, este continua a desligar-se quando coloco o LCD.

Decidi experimentar a backlight do LCD com a pilha de 9V e uma resistência variável. Comecei com tensão nula e fui incrementando para ver se a luz ligava, mas nada.... :(

Como é q posso ver se o problema é defeito do LCD e não meu? Pq sinceramente n sei o que estou a fazer de errado...

Italo Lima

Coloca 5V no LCD (Vin, Vo), normalmente ele mostra caracteres aleatórios. O BackLight não funcionar é um forte indício do LCD estar quebrado...

Fblanco

Pois... experimentei por tensão no Vi e no Vo e continua a dar nada :(

enfim...

De qualquer maneira obrigado a todos pela ajuda :)


Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy