Go Down

Topic: My Arduino is a mouse?! (Read 1 time) previous topic - next topic

Nachtwind

Hi,
There seems to be some sort of error here.. each time i plug in the arduino now to my usb port it is recognized as Mouse and it moves the cursor arround (i attached a GPS receiver)..
That is indeed quite strange i think.. any suggestions?
Believe me, Mike, I calculated the odds of this succeeding against the odds I was doing something incredibly stupid[ch8230] and I went ahead

retrolefty

Yes, copyright the design and start marketing it. It should sell like hotcakes  ;)

Lefty

Nachtwind

satellite steered mouse... yes, that could do it.. unfortunately there is this 5m error margin - even on the desktio ;0)
Believe me, Mike, I calculated the odds of this succeeding against the odds I was doing something incredibly stupid[ch8230] and I went ahead

Anachrocomputer

Does your computer have any driver that might respond to a serial (RS-232) mouse?  Or a graphics tablet, perhaps?

Nachtwind

No... not really. interesteringly this only happens (now - after about a hundred tries before) when i have powered the GPS Receiver on the board 0o
Believe me, Mike, I calculated the odds of this succeeding against the odds I was doing something incredibly stupid[ch8230] and I went ahead

Nick_de

#5
Jan 06, 2009, 11:20 pm Last Edit: Jan 06, 2009, 11:20 pm by Nick_de Reason: 1
wow that must have been funny! Or even funnier to see the look on your face in that first moment! ;)

In any case good luck!

Nachtwind

ok.. symotoms are as follows:

Everything is fine except when i plug in the board with the GPS powered up at start... would be nice if someone could verify - but well....... dont think so..

Anyway, i still love the idea about that gps mouse ;0)
Believe me, Mike, I calculated the odds of this succeeding against the odds I was doing something incredibly stupid[ch8230] and I went ahead

Nachtwind

additional: Uploading a sketch is impossible: Out of Sync or the IDE crashes ;0)

Need to let the power off of the GPS Receiver
Believe me, Mike, I calculated the odds of this succeeding against the odds I was doing something incredibly stupid[ch8230] and I went ahead

skumlerud

Quote
additional: Uploading a sketch is impossible: Out of Sync or the IDE crashes ;0)

Need to let the power off of the GPS Receiver


Let me guess - the GPS receiver is connected to the Arduino via the serial port (pin 0 and 1)?

Nachtwind

yes, that is right. I already thought that this was the problem, but than again i did doubt it because i anticipated that the arduino designers would have taken such a thing in account when designing it - so i gave up the thought on this being the problem.
Believe me, Mike, I calculated the odds of this succeeding against the odds I was doing something incredibly stupid[ch8230] and I went ahead

drone

Quote
yes, that is right. I already thought that this was the problem, but than again i did doubt it because i anticipated that the arduino designers would have taken such a thing in account when designing it - so i gave up the thought on this being the problem.


... I wouldn't give up on that just yet...  =)

!c

skumlerud

Quote
yes, that is right. I already thought that this was the problem, but than again i did doubt it because i anticipated that the arduino designers would have taken such a thing in account when designing it - so i gave up the thought on this being the problem.


You have both the GPS and PC connected to the same serial port, which means that the GPS is interfering with the PC<->Arduino communication. If you need to communicate with both the PC and GPS at the same time you must use SoftSerial for one of them.

zitron

I had similar problems before. I think Windows has some legacy RS232 mouse driver that automatically activate when certain serial baud rate is used. Can't remember how I got rid of it now... Have you looked in device manager and see if there's new mouse detected? Maybe try disabling it?

Nachtwind

Well.. that softserial idea sounds fun :0)

I will try that one next time :0)

Disabling that mouse didnt work ;0)
Believe me, Mike, I calculated the odds of this succeeding against the odds I was doing something incredibly stupid[ch8230] and I went ahead

zitron

OK, found it.

Go to regedit,

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\sermouse

Find entry "Start", set value to HEX 3 (manual) or 4 (disabled). Restart.

Go Up