Go Down

Topic: GPS Libelium (Read 1 time) previous topic - next topic

Bruno Vidotto

Jan 10, 2011, 05:49 pm Last Edit: Jan 10, 2011, 05:50 pm by brunovidotto Reason: 1
Boa tarde,

Senhores recentemente adiquiri um GPS e Antena da Libelium.

http://www.cooking-hacks.com/index.php/documentation/tutorials/arduino-gps

Estou fazendo exatamente esse projeto, segui o tutorial passo a passo, porem não recebo as coordenadas.

Ao ler o serial monitor ele me da as seguintes informações:

GGA sentence: $GPGGA,001717.064,,,,,0,00,,,M,0.0,M,,0000
RMC sentence: $GPRMC,001716.065,V,,,,,,,010407,,,N
GGA sentence: $GPGGA,001718.064,,,,,0,00,,,M,0.0,M,,0000
RMC sentence: $GPRMC,001717.064,V,,,,,,,010407,,,N
GGA sentence: $GPGGA,001719.064,,,,,0,00,,,M,0.0,M,,0000
RMC sentence: $GPRMC,001718.064,V,,,,,,,010407,,,N
GGA sentence: $GPGGA,001720.064,,,,,0,00,,,M,0.0,M,,0000
RMC sentence: $GPRMC,001719.064,V,,,,,,,010407,,,N
GGA sentence: $GPGGA,001721.063,,,,,0,00,,,M,0.0,M,,0000
RMC sentence: $GPRMC,001720.064,V,,,,,,,010407,,,N
GGA sentence: $GPGGA,001722.063,,,,,0,00,,,M,0.0,M,,0000
RMC sentence: $GPRMC,001721.063,V,,,,,,,010407,,,N
GGA sentence: $GPGGA,001723.064,,,,,0,00,,,M,0.0,M,,0000
RMC sentence: $GPRMC,001722.063,V,,,,,,,010407,,,N

Conforme o datasheet do gps eu deveria estar recebendo as coordenadas dentro dessas virgulas que estão vazias(em vermelho):

$GPRMC,001722.063,V,,,,,,,010407,,,N

Alguem pode me dar algumas dicas?

DataSheet: http://www.cooking-hacks.com/skin/frontend/default/cooking/pdf/GPS_Firmware_GSC3_3.5.0_V4.2.pdf


nofxx

Saudade de ver um NMEA .. heh.

Soh checagem , mas vc esperou um tempo ae pro cold start? Alguns modulos demoram minutos....

bubulindo

Onde estás a testar isso? Dentro de casa?

O GPS apenas funciona estando numa linha directa com os satélites, ou seja, sem paredes pelo meio.

Como foi referido vários módulos de GPS demoram imenso a fixar um sinal, depois dependendo do módulo pode ser mais fácil uma vez que existem m\odulos que guardam as coordenadas usadas anteriormente para tentarem fixar o sinal ao serem ligados de novo.

Em todo o caso, esperar 10 a 15 minutos não é de todo anormal.
This... is a hobby.

Bruno Vidotto

@nofxx
Esperei algum minutos, mais o que seria "cold start"?
Obrigado pela resposta

@bubulindo
Testei dentro de casa, não sabia que tinha que estar em um ambiente aberto.
Vou esperar cerca de 10 a 15 minutos.
Já já posto o resultado, obrigado pela resposta

bubulindo

Na boa...
Acho piada porque isto lembrou-me a história da morte do telefone por satélite. LOL

Segundo um professor meu o telefone por satélite (leia-se móvel), morreu porque um certo jornalista queria estar ao telefone na cama e como não funcionava, decidiu escrever um artigo a denegrir o aparelho. LOL
This... is a hobby.

Go Up