Pages: [1]   Go Down
Author Topic: komisches Phänomen  (Read 414 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Arduino Gemeinde,
seit zwei monaten beschäftige ich mich mit Arduino Duemilanove Board um etwas C /C++ zu erlernen. Ich benutzte die Arduino Software 0017.

Mein Phänomen ist folgendes: ich benutze 3 Servos und ein Ultraschallsensor die ich über eine separate Platine mit 5 V versorge die Datenleitungen werden auf die Pins 8-10 gesteckt die vom Ultraschallsensor auf pin 2.
Wenn ich nun das Programm auf das Board spiele und den USB-Stecker stecken habe und die externe Versorgung mit 5 V,die übrigends auch das Board versorgt, dann funktioniert das Programm wie es soll. Hab ich nun den USB Stecker abgezogen funktioniert nichtsmehr... es steht im Programm aber keinerlei Code die die Serielle verbindung in anspruch nimmt.

Ist das Phänomen bekannt?  :-/
 
würde mich freuen wenn mir jemand helfen könnte.
der anfänger
Logged

0
Offline Offline
Full Member
***
Karma: 2
Posts: 184
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi..
ich weiss nicht ob Deine Ausfürungen so richtig sind:

Du schreibst das die Sensoren eine separate Spannungsversorung haben.. das ist gut so...
Du wunderst Dich das der Arduino nicht läuft wenn der USB-Stecker abgezogen wird ??

Solange Du den Arduino nicht mit 9-12V  an der Anschlußbuchse oder mit 5 V über USB versorgts wäre das verhalten völlig normal.
Alternativ kannst Du auch über die Buchsenleiste "Power" die 5 V zuführen da musst Du aber selbst auf die Qualität der Spannungversorgung achten

Der Arduino benötigt an der Spannungsbuchse eine höhere Spannung da auf dem Board ein Spannungsregler drauf ist....und der braucht eine etwas höhere Spannung um zu arbeiten.

LC
« Last Edit: September 20, 2009, 02:09:14 pm by LC_Data » Logged

Es gibt 10 Gruppen von Menschen:
Die einen können binär zählen, die anderen nicht.

0
Offline Offline
Newbie
*
Karma: 0
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Danke! Hab mein Phänomen gefunden...
Bei der seperate Spannungsversorgung benutze ich einen 7805 und die 5V führe ich auf die Spannungsversorgungsbuchse der Arduino.

Nochmals herzlichen Dank
der anfänger
Logged

Pages: [1]   Go Up
Jump to: