Pages: [1]   Go Down
Author Topic: Servo Problem.  (Read 501 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 15
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey, ich versuche momentan meinen Servo in Gang zu bringen.
Habe ihn angeschlossen wie auf dem Bild. zu finden hier: http://www.arduino.cc/playground/Learning/SingleServoExample .

Wenn ich jetzt ein Beispiel lade, tut sich beim "uploaden" etwas, minimale bewegungen. Aber wenn die loop-schleife dann laufen sollte(nach dem uploaden) tut sich nichts.. auch das Beispiel mit Processing geht nicht. Woran kann das liegen ? Ist mein Servo vielleicht kaputt ?

edit : Hat sich erledigt, das ander Beispiel(aus "examples") geht, ich musste nur das kabel auch in pin 9 stecken wie im script vorgesehen, das ändern auf 14, wie ich es angeschlossen hatte, funktionierte nicht.

Dennoch geht das beispiel mit processing nicht. aber ich glaube so wie es jetzt geht, reicht es mir.
« Last Edit: November 09, 2009, 10:52:10 am by KYL3R » Logged

Bremen / Germany
Offline Offline
Full Member
***
Karma: 0
Posts: 140
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo KYL3R,

ein Servo wird mittels PWM gesteuert. Daher kann es an Pin 14 (? welches Board hast du denn) nicht klappen.

Ein Arduino Duemilanove / Diecimila (ATMEGA168/328) kann PWM an Pin 3, 5, 6, 9, 10 und 11 liefern ;-)

Lieben Gruß
Poldi
Logged

London
Offline Offline
Faraday Member
**
Karma: 8
Posts: 6240
Have fun!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sorry to reply in English but I hope the following makes things clearer:

That example uses a software servo library that does not use PWM so it should work in any pin.  Unfortunately, the library name conflicts with the naming of servo library distributed with Arduino and its not good to have two libraries on your system with the same name. But the Arduino Servo library that comes with version 0017 will also work on any pin so I suggest you remove the software servo library (if you have downloaded it) and use the Arduino library.

edit: I see you now have it working, but you may still want to switch to the arduino library, it has the advantage that you do not need to repeatedly call the refresh function in loop.


The following version of that sketch should work with the Arduino Servo Library:
Code:
#include <Servo.h>

Servo servo1; Servo servo2;


void setup() {
  servo1.attach(14); //analog pin 0
  servo2.attach(15); //analog pin 1
  Serial.begin(19200);
  Serial.println("Ready");
}

void loop() {

  static int v = 0;

  if ( Serial.available()) {
    char ch = Serial.read();

    switch(ch) {
      case '0'...'9':
        v = v * 10 + ch - '0';
        break;
      case 's':
        servo1.write(v);
        v = 0;
        break;
      case 'w':
        servo2.write(v);
        v = 0;
        break;
      case 'd':
        servo2.detach();
        break;
      case 'a':
        servo2.attach(15);
        break;
    }
  }
}
« Last Edit: November 10, 2009, 06:11:16 am by mem » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 15
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I already wrote, problem solved, it was meant to be pin 14 , but it didn´t work. I used the other example, where pin9 was suggested, i changed code to pin14(where i put my wire in) and it didn´t work as well, then I just changed it to pin 9 again, and put my wire in pin 9 as well, and then it worked.

Poldi, ja genau, jetzt steuere ich es über pin 9 an, wie oben(in englisch) beschrieben. Beispiel war auf pin 14 ausgelegt, funktionierte nicht, anderes beispiel auf pin9 ausgelegt, ging nicht nachdem ich den code auf 14 geändert hatte(wo mein draht drinsteckte), dann wieder auf 9 geändert und auch den draht in pin9 gesteckt, dann liefs.

Danke nochmal.
Logged

London
Offline Offline
Faraday Member
**
Karma: 8
Posts: 6240
Have fun!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes, I saw you had solved the problem shortly after I posted my reply so edited my post accordingly.

Good to hear you have it going.

Viel Spaß!
Logged

Pages: [1]   Go Up
Jump to: