Pages: [1]   Go Down
Author Topic: Hintergrundrauschen  (Read 456 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 23
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

folgende Frage:
Wie kann man das gemessene Hintergrundrauschen im Arduino abstellen? :o

Im Detail: Wenn ich am analogen Port ohne irgendwas anzuschließen analodRead mache, sehe ich irgendso ein Hintergrundrauschen, dass durch irgendwelche elektronische Geräte in der Umgebung verursacht wird...das Problem: Wenn ich jetzt gewisse Sensoren anschließe, versaut mir dieses Hintergrundrauschen, mein Messergebnis...

Wie kann man das abstellen? Hilft es einen metalischen Käfig um das Arduino zu machen und an GND zu binden? oder gibt es noch einfachere Methoden ohne allzu viel basteln? :-?

Vielen Dank im Vorraus
Logged

CH
Offline Offline
God Member
*****
Karma: 19
Posts: 703
Book Writer "Arduino Praxiseinstieg"
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Was hast du für Sensoren angeschlossen?
Und wie lange sind die Leitungen?
Wie wird dein Arduino versorgt (Batterie, Netzteil oder USB)?

Mit einem RC-Glied (Widerstand und Kondensator) als Tiefpass geschaltet, kannst du das Signal etwas dämpfen.

Ein metallisches Gehäuse hat immer eine positive Wirkung. Die Störungen müssen aber nicht zwingend über die Luft auf das Board wirken.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 23
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Naja also ich hab das Arduino Nano und über USB verbunden....ohne irgendwas anzuscchließen, sieht man halt nur das blanke Hintergrundrauschen.....das variiert durchaus von Zeit zu Zeit....aber sind hauptsächkich in meiner Umgebung sehr niederfrequente Schwingungen.....

Und ich wollte einen Ee 301P anschließen...und ja dieses Hintergrundrauschen versaut das mal gewaltig....

Die Leitungen sind da nicht mehr als 10 cm....habe auch schon mit geschirmten Kabeln versucht...aber ja es scheint am oad direkt zu liegen.....

eine Sache ist mir kürzlich aufgefallen...ich war neulich im Institut an der Uni und da hab ich des mal ausprobiert und da war das Hintergrundrauschen nur noch sehr sehr flach....zuvor hatte ich sehr hohe Amplituden....also das deutet für mich schon auf Störsignalle aus der umgebung hin...
« Last Edit: May 25, 2010, 03:57:01 am by real_hunter » Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 62
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Am offenen Eingang wirst du immer irgendwelche Signale messen.
Ein Angeschlossener Sensor soll möglichst niederohmig sein <10kOhm
Zum Test kannst du ja den Eingang mit einem 10k Widerstand abschliessen dann solltest du kein Hintergrundrauschen mehr messen können.


Viele Grüsse,   Michi
« Last Edit: May 25, 2010, 04:58:55 am by komputer » Logged

Pages: [1]   Go Up
Jump to: