Go Down

Topic: IDE 1.6.0 is now available for download (Read 40911 times) previous topic - next topic


Feb 15, 2015, 12:47 am Last Edit: Feb 15, 2015, 12:50 am by Dimonira

I tried to compile Marlin 1.0.2 with EXTRUDERS = 2 (defined in Configuration.h) for Mega 2560. Arduino 1.0.6 compiles without errors. But Arduino 1.6.0 compiles with error:
temperature.cpp: In function 'void manage_heater()':
temperature.cpp:665:1: error: unable to find a register to spill in class 'POINTER_REGS'
temperature.cpp:665:1: error: this is the insn:
(insn 98 97 100 4 (set (reg/v:SF 103 [ pid_input ])
        (mem:SF (post_inc:HI (reg:HI 141 [ ivtmp.170 ])) [4 MEM[base: _101, offset: 0B]+0 S4 A8])) temperature.cpp:449 99 {*movsf}
     (expr_list:REG_INC (reg:HI 141 [ ivtmp.170 ])
temperature.cpp:665: confused by earlier errors, bailing out
What is the problem?


Feb 15, 2015, 02:13 am Last Edit: Feb 15, 2015, 02:14 am by common_ground
Arduino team has done a great job :)
Ability to change compiler flags is excellent, now i have some question.
In platform.txt mention has been made that compiler flags:
These can be overridden in platform.local.txt
What does that mean , can we change compiler optimisation flags for every sketch separately , and if we can not, then I think that would be great thing for future release.


I don't like the opening/closing window on Mac at all. Might have been there in older versions as well, but 1.0.6 is much better on Mac with regards to opening window. It just does not conform the OS X standards and so things like shortcuts in Finder cannot be used. Sorting folders by date is also not supported as it seems to be. Quite disappointed, glad I did not remove 1.0.6 yet.


Feb 16, 2015, 01:49 pm Last Edit: Feb 16, 2015, 02:08 pm by Budvar10
When I try to unzip the version 1.6.0 I get an error saying a file isn't found????
Same experience. Trying unzip with native XP tool with same result for two different downloaded copies. Under Linux it is able unzip both without problem. So I tried to unzip with Total Commander under XP and both copies worked.
Are the both copies corrupted or the zip file is created with some incompatible tool?
Arduino clone with ATmega1284P   http://forum.arduino.cc/index.php?topic=277260.0


shall Windows 7 64bit.
Uploaded am new IDE 1.6.0.
After starting me malfunctions Scrollable menus, for example in folder "Examples".
Consult, where can be error?
Thanks. Martin


Feb 16, 2015, 06:16 pm Last Edit: Feb 16, 2015, 06:16 pm by Peter_n
Windows 7 64-bit and Arduino 1.6.0 run without problem. But I have unzipped the zip-file in a folder and run it from that folder. I have no other parts of system-wide installed Arduino and I have no Java installed.
Can you give a screenshot of what is happening ?
Perhaps you have mix with older versions of Arduino or Java.


Thank you for fast reply.
Start Arduino so from folder unzipped.
Send me please e - mail and I the and send screenshot, where malfunctions scrolling.



Send me please e - mail and I the and send screenshot, where malfunctions scrolling.
As you are typing in a post to this forum, if you hit the "Preview" button, you will see a more advanced editing interface. Under the edit box, there will now be a link for "Attachments and other options." If you select that link, it will open up an interface where you can browse to your screen shot image, upload it, and attach it to your post. No email is necessary.


yes, I can understand and thank you for counsel.
attach then screenshot, where malfunctions scrolling.



Feb 17, 2015, 05:50 am Last Edit: Feb 17, 2015, 03:26 pm by filipto
problem running arduino ide 1.6.0 on some windows 8 computer.
arduino_debug.exe produces the following exceptions (launch4j failure), any idea how to get around?:

C:\Program Files (x86)\Arduino>arduino_debug.exe
Exception in thread "main" java.lang.UnsatisfiedLinkError: jssc.SerialNativeInte
        at jssc.SerialNativeInterface.getSerialPortNames(Native Method)
        at processing.app.SerialPortList.getWindowsPortNames(Unknown Source)
        at processing.app.SerialPortList.getPortNames(Unknown Source)
        at processing.app.SerialPortList.getPortNames(Unknown Source)
        at processing.app.Serial.list(Unknown Source)
        at cc.arduino.packages.discoverers.SerialDiscovery.discovery(Unknown Sou
        at cc.arduino.packages.DiscoveryManager.discovery(Unknown Source)
        at processing.app.Editor.populatePortMenu(Editor.java:998)
        at processing.app.Editor.buildToolsMenu(Editor.java:720)
        at processing.app.Editor.buildMenuBar(Editor.java:488)
        at processing.app.Editor.<init>(Editor.java:215)
        at processing.app.Base.handleOpen(Base.java:727)
        at processing.app.Base.handleOpen(Base.java:692)
        at processing.app.Base.handleNew(Base.java:595)
        at processing.app.Base.<init>(Base.java:297)
        at processing.app.Base.main(Base.java:166)


Thanks mkfloria, your issue is being tracked here https://github.com/arduino/Arduino/issues/2657


filipto is your windows a 64bit version right? Are you using the java virtual machine provided with the IDE or have you deleted IDE\java folder?


I also had launch4j problem with arduino1.6.0 on windows8.1 (only some windows 8.1 installations)
The solution I found for my problem is by replacing the contents of the java folder:

My windows 8 is 64 bit version:
I copy the contents of c:\program files(x86)\java\* to c:\program files(x86)\arduino\java\
and restarted arduino side 1.6.0 and it worked.

I got this from:



Go Up