Go Down

Topic: Arduino Duemilenova mit Eclipse reseten (Read 377 times) previous topic - next topic

kucky

Hallo Forum
Mein Arduino läuft mittlerweile mit Eclipse. Nun ist es aber so, dass der Arduino nicht mehr geflasht wird. Obwohl diese Meldung kommt:

Launching C:\WinAVR\bin\avrdude -pm328p -cstk500v1 -P//./COM4 -b57600 -F -Uflash:w:Kucky_2.hex:a
Output:

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.05s

avrdude: Device signature = 0x1e950f
avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed
        To disable this feature, specify the -D option.
avrdude: erasing chip
avrdude: reading input file "Kucky_2.hex"
avrdude: input file Kucky_2.hex auto detected as Intel Hex
avrdude: writing flash (7276 bytes):

Writing | ################################################## | 100% 3.63s

avrdude: 7276 bytes of flash written
avrdude: verifying flash memory against Kucky_2.hex:
avrdude: load data flash data from input file Kucky_2.hex:
avrdude: input file Kucky_2.hex auto detected as Intel Hex
avrdude: input file Kucky_2.hex contains 7276 bytes
avrdude: reading on-chip flash data:

Reading | ################################################## | 100% 3.08s

avrdude: verifying ...
avrdude: 7276 bytes of flash verified

avrdude done.  Thank you.

avrdude finished

Diese Meldung besagt doch, das alles OK ist. Den Resetbutton habe ich auch mal versucht, unmittelbar nach dem Uploadstart.
Nach einem Rechner-Neustart funktioniert es ca. 3mal, dann erscheint diese Meldung, aber das alte Programm ist noch aktiv. Ich kann das an einer Datumsanzeige im Programm sehen.http://www.arduino.cc/yabbfiles/Templates/Forum/yabb21/sad.gif
Die Meldung "not sync...." erscheint auch immer öfter, obwohl kein Terminal aktiv ist. Das ist aber meist durch ziehen des USP-Steckers zu beheben.http://www.arduino.cc/yabbfiles/Templates/Forum/yabb21/huh.gif
Weiß einer Rat? Ich habe in verschiedenen Foren gesucht, auch hier das "NewAvrDude.exe" ausprobiert. Hier war aber das Problem, das ich in Eclipse die "Programmer Configuation" nicht mehr einstellen konnte. Andere Patches, die auch hier im Forum angeboten werden, waren mir zu kryptisch, will sagen nur was für absolute Könner.
Ich bin wirklich am verzweifeln.http://www.arduino.cc/yabbfiles/Templates/Forum/default/tongue.gif
Gruß Kucky

Go Up