Go Down

Topic: BlackWidow / WiFly (Read 2634 times) previous topic - next topic

u2

Hey Leute,
ich bin neu hier und auch in der ganzen Materie.
In Rahmen eines Praktikums beschäftige ich mich mit dem Ardunio BlackWidow und Arduino UNO Board mit WiFly Shield.

Gestern hatte ich das BlackWidow an meinen PC(Windows XP) angeschlossen und die WIFI LED hat sofort geleuchtet und ich konnte auch eine WLAN Verbindung aufbauen. Alles top.
Dann hab ich (in meinem jugendlichen Leichtsinn  ;)) das Blink Programm upgeloaded und auch das hat super funktioniert. Nur in der Zeit ist die WIFI LED ausgegangen und seitdem kann ich keine WLAN Verbindung mehr aufbauen.
Ich habs auch mit Reset versucht, aber es möchte nicht mehr.
Kann mir jemand weiterhelfen? Bzw. hat jemand ähnliche Erfahrungen gemacht???

Danke schon mal!

Grüße
u2

uwefed

Hallo U2

Weil Du den WIFI Baustein ansteuern mußt; Im Auslieferungszustand war wahrscheinlich ein Testprogram drauf, wie es alle Arduinos und Clone in verschiedener Weise haben.

Auf http://asynclabs.com/wiki/index.php?title=AsyncLabsWiki müßtest Du alles finden (Bibliothek und Anleitungen) um den WIFI-Baustein anzusteuern.

Grüße Uwe

uwefed

Der vorprogrammierte Sketch war nur eine Demo. Es hat keinen Sinn diesen Sketch zu benutzen.

Schau mal das wiki an das ich Dir gelinkt hatte.

Grüße Uwe

uwefed

#3
Jan 06, 2011, 09:47 am Last Edit: Jan 06, 2011, 09:50 am by uwefed Reason: 1
Guten Morgen U2
Nein, tut mir led, hab das Wifly Shield nie gesehen.
Quote
der Anleitung bin ich schon gefolgt und habe das WebServer Sketch probiert, aber leider ohne Erfolg bisher.
was waren die Symptome? wie hat es nicht funktioniert?

Ich lese bei der Beschreibung des Wifly Shields:
"Das Shield kommt fertig bestückt mit den Komponenten, aber ohne Steckverbinder.
Wir empfehlen unser Stapelbare Buchsenleisten als ideale Ergänzung." Einfache Stiftleisten tun es auch; dann kannst Du aber kein weiteres Board draufstecken.

"Das Modul nutzt den Vin Pin des Arduino als Spannungsversorgung und besitzt einen onBoard 3,3V Spannungsregler."
Das heißt Du kannst den Arduino mit dem Wifly Shield nicht mit 5V von USB versorgen sondern mit 9V an der schwarzen Spannungsversorgungsbuchse. Mit USB bekommt das Wifly Shield keine Spannung. Du kannst beide Spannungsversorgungen gleichzeitig (USB und Buchse) verwenden; Arduino ist so konstruiert, daß nichts passiert.
Hier findest Du Beispiele: http://www.sparkfun.com/products/9954
Der Arduino Uno ist sicher nicht programmiert um das Wifly Shield anzusprechen. Da ich auch keinen Arduino Uno bisher in Händen hatte (ich schäme mich schon), weiß ich nicht was der im Auslieferugszustand für ein Demosketch drauf hat; wahrscheinlich Blink.

Grüße Uwe

Webmeister

Quote
Da ich auch keinen Arduino Uno bisher in Händen hatte (ich schäme mich schon)

Als "Italiener" bist du ja quasi an der Quelle und hast die Uno's (nein nicht die von Fiat) vor der Tür  ;)

inside-man

Hallo, ich habe einige Zeit schon mit dem WiFly von Sprkfun verbracht. Das Teil funktioniert recht gut. Was aber zu beachten ist, es geht einige Rechenpower fuer das Shield drauf, sobald es in Deinem eigentlichen Sketch nicht rund läuft, bricht auch der Wlan Kontakt ab. Aber wie gesgat wenn der Code stabil läuft ist die WLan Verbindung auch recht stabil.
hier de rLink, dort gibtzs auch die aktuellsten Treiber:

http://www.sparkfun.com/products/9954

sth77

Quote
Und war auf dem WiFly Shield schon ein Sketch vorhanden?
Auf einem Shield ist kein Sketch, dieser befindet sich immer auf dem Arduino, d.h. auf dem Mikrocontroller auf der Uno-, Mega- oder Duemilanove-Platine. Mit der Programmierung ändert man eben nur das Programm und damit das Verhalten des dort verbauten Mega328.
Mein Arduino-Blog: http://www.sth77.de/ - letzte Einträge: Teensy 3.0 - Teensyduino unter Window 7 - Teensyduino unter Windows 8

inside-man

Hallo, ich hatte es auf eine duemilanove, freeduino und twentyten erfolgreich im Einsatz. Beim Seeeduino ging es nicht, da muss es einen Unterschied in der Spannungsversorgung geben, das Shield blie dunkel. Wie schon erwähnt das WiFly hat dann 4 Pins über die es angesteuert wird. Das Programm läuft natürlich immer auf dem Arduino. Somit kann kein erst mal kein Programm auf dem Shield selber sein.
Gruss Inside-man

sth77

Ich gehe ganz stark davon aus, dass der gleiche Sketch wie in der Vorversion (Duemilanove) drauf ist: "Blink". Also ein Blinken der auf dem Board vorhandenen Leuchtdiode.
Mein Arduino-Blog: http://www.sth77.de/ - letzte Einträge: Teensy 3.0 - Teensyduino unter Window 7 - Teensyduino unter Windows 8

uwefed

@Webmeister
Du wirst lachen, dort steht ein grünen Golf. ;)

Mein letzter Einkauf war einfach noch in der Vor-Uno Zeit. Und bis jetzt war noch keine Neuanschaffung notwendig.

@u2
BZ steht für Bozen, Italien.

Auf dem UNO müßte ein Sketch oben sein, der das L-Led blinken läßt. Sicher nicht ein Sketch für das WiFly Shield, da das ja ein Zusatz ist.

Grüeß Uwe

inside-man

Hallo, also als erstes bevor man pingt, muesste man schauen ob eine SSID sichtbar ist. Denn gut möglich dass gar keine secured connection zu stande kommt, aber das wifi Teil arbeitet....

Und man müsste mal anhand der Diagnose LED für den wifi Teil rausfinden ob es überhaupt korrekt angesteuert wird. Das WiFly hat dort mindestens 5 LED, wenn man die beim Hochfahren beobachtet kann man sehr schoen sehen was dort abläuft, wenngleich ich nicht genau weiss welche LED was macht...

Gruss inside-man

inside-man

Selbstverstaendlich kannst Du mit dem WiFly einen Webserver abbilden, die ganz normale Demo Applikation läuft.
Mit der SSID lag ich vorhin falsch, das Shield ist natuerlich ein client, und kann sich selbst nicht als AP ausgeben. In dem WiFly Webserver Demo ist eine Zeile drin, in der der Arduino per serial rausgibt ob er sich erfolgreich einloggen konnte, das ist sehr hilfreich.

gauguer

hej. ich habe das gleiche problem. da ich nicht sonderlich bewandert bin in den ganzen netzwerk-protokollen, sagt mir auch der zweite sketch mit dem autoconnect nicht genug.

bekomme alles richtig, nur der login klappt nicht. habe mitlerweile alle securitytypen ausprobiert, bin aber auch damit nicht durchgekommen, dachte, vll. liegt es am port, aber im endeffekt geht ja nur HTTP wenn ich via browser ran will, oder?

"WiFly Shield Terminal Routine
Bridge initialized successfully!
Rebooting
Entering command mode.
Set wlan to authorization level 0
Set security phrase to 0682557522339816
Set IP localport to 80
Joining 'WLAN-001C4A07B1F5'


Failed to associate with 'WLAN-001C4A07B1F5'

Retrying...
Rebooting"

usw.

wie finde ich denn sicher heraus, dass er überhaupt ein netzwerk findet? hat jemand vll schon einen sketch dafür?

Peacekeeper

Es gibt ein Trouble Shooting Sketch der funktioniert ganz gut für das WiFly mit der Lib 2.0.
Meine Erfahrung:
  • im seriellen Monitor der IDE das Zeilenende entsprechend der Anleitung einstellen. Hängt es einfach mal das Zeilenende toggeln.
  • den Befehl 'save' nicht vergessen,da viele Einstellungen erst nach einem Reset übernommen werden.
  • mit 'scan' kann man Netzwerke finden
  • es gibt einen undocumentierten Befehl zur Verstellung der Zeitzone. Für DE muss man die Zone 23 einstellen (ok, im Moment - im März dann anders)
  • für den Arduino ist -nach dem Netzwerksetup - das ganze wie eine serielle Schnittstelle.


Go Up