Pages: [1]   Go Down
Author Topic: ethernet shield  (Read 1328 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 29
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ich habe einen duemilanove und dazu ein ethernet shield, konnte damit bereits emails versenden.
wollte nach 1 woche sensortests die sensordaten in die emails integrieren und plötzlich funktioniert das ganze nicht mehr, habe am email-sende-code nichts geändert... auch das einfache webclient beispiel funktioniert nicht mehr.
habe mir ein neues shield zugelegt und es funktioniert auch nicht, es leuchten alle leds wie sie sollten und ich verwende auch die mac addresse des shields. so wie es aussieht funktioniert die initialisierung der netzwerkeinstellungen scheinbar nicht mehr, kann das board nicht mehr pingen.

kann da was mit dem duemilanove sein?
kann mir jemand weiterhelfen?

danke
kuxi
« Last Edit: January 19, 2011, 05:35:39 am by kuxi » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 29
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

wenn ich "arp -a" aufrufe wird das shield dort nicht aufgelistet.
Logged

CH
Offline Offline
God Member
*****
Karma: 19
Posts: 703
Book Writer "Arduino Praxiseinstieg"
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Wie sieht es mit dem Duemilanove aus?
Läuft der noch korrekt?

Zum Test kannst du ja mal ein Testsketch, ohne Ethernet Shield aufgesetzt, laufen lassen.

So kann der Fehler eingegrenzt werden.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 29
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

also meine sensoren kann ich auch ohne shield ohne probleme ansteuern.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 29
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ist es möglich mac und ip adresse aus dem wiznet chip zu lesen? mich würde interessieren ob dort auch wirklich alles richtig drinnen steht.
Logged

AREA COLOGNE
Offline Offline
Edison Member
*
Karma: 21
Posts: 1128
I am 1 of 10 who understands binary
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hast du eine SD-Karte stecken wenn ja muss man vor verwendung Pin4 HIGH schrieben (abwählen SD-Karte) und Pin 10 LOW (anwählen WIZNET). Oder einfach die Karte ziehen :-) Dem bin ich bei  dem neuen Shield  auch aufgessen. Es funktionierte alles bestens.  Ein Test mit der SD karte(dann auch eine eingesteckt) gemacht so zwischendurch Karte nihct geszogen: Altes Prog draufgemacht Ethnert war nicht mehr zu erreichen die obige Lösung half weiter
« Last Edit: January 20, 2011, 09:30:58 am by volvodani » Logged

So ist das Leben:
Manchmal bis du das Denkmal, manchmal die Taube!

0
Offline Offline
Newbie
*
Karma: 0
Posts: 29
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

nein, habe ich nicht. habe es jetzt mal versucht mit dig. pin 10 auf low setzen, hat leider auch nichts gebracht.
Logged

Pages: [1]   Go Up
Jump to: