Go Down

Topic: ethernet shield (Read 1 time) previous topic - next topic

kuxi

Jan 19, 2011, 10:34 am Last Edit: Jan 19, 2011, 11:35 am by kuxi Reason: 1
ich habe einen duemilanove und dazu ein ethernet shield, konnte damit bereits emails versenden.
wollte nach 1 woche sensortests die sensordaten in die emails integrieren und plötzlich funktioniert das ganze nicht mehr, habe am email-sende-code nichts geändert... auch das einfache webclient beispiel funktioniert nicht mehr.
habe mir ein neues shield zugelegt und es funktioniert auch nicht, es leuchten alle leds wie sie sollten und ich verwende auch die mac addresse des shields. so wie es aussieht funktioniert die initialisierung der netzwerkeinstellungen scheinbar nicht mehr, kann das board nicht mehr pingen.

kann da was mit dem duemilanove sein?
kann mir jemand weiterhelfen?

danke
kuxi

kuxi

wenn ich "arp -a" aufrufe wird das shield dort nicht aufgelistet.

Webmeister

Wie sieht es mit dem Duemilanove aus?
Läuft der noch korrekt?

Zum Test kannst du ja mal ein Testsketch, ohne Ethernet Shield aufgesetzt, laufen lassen.

So kann der Fehler eingegrenzt werden.

kuxi

also meine sensoren kann ich auch ohne shield ohne probleme ansteuern.

kuxi

ist es möglich mac und ip adresse aus dem wiznet chip zu lesen? mich würde interessieren ob dort auch wirklich alles richtig drinnen steht.

volvodani

#5
Jan 20, 2011, 03:28 pm Last Edit: Jan 20, 2011, 03:30 pm by volvodani Reason: 1
Hast du eine SD-Karte stecken wenn ja muss man vor verwendung Pin4 HIGH schrieben (abwählen SD-Karte) und Pin 10 LOW (anwählen WIZNET). Oder einfach die Karte ziehen :-) Dem bin ich bei  dem neuen Shield  auch aufgessen. Es funktionierte alles bestens.  Ein Test mit der SD karte(dann auch eine eingesteckt) gemacht so zwischendurch Karte nihct geszogen: Altes Prog draufgemacht Ethnert war nicht mehr zu erreichen die obige Lösung half weiter
So ist das Leben:
Manchmal bis du das Denkmal, manchmal die Taube!

kuxi

nein, habe ich nicht. habe es jetzt mal versucht mit dig. pin 10 auf low setzen, hat leider auch nichts gebracht.

Go Up