Go Down

Topic: Grundsätzliches Problem... (Read 6 times) previous topic - next topic

Realizer

#5
Jan 21, 2011, 10:34 pm Last Edit: Jan 21, 2011, 10:36 pm by Realizer Reason: 1
Ich habe zwar nur Windowspc's, aber bei mit funktioniert alles immer einwandfrei. Uploaden der Sketches, das Auslesen der Ports, serielle Übertragungen, Displays, Sensoren und und und.

Also muss ich sagen, ich kann keine Fehler erkennen. Funktioniert super.
Eine Kuh macht muuhh.
Viele Kuehe machen Muehe

Udo Klein

#6
Jan 22, 2011, 10:53 am Last Edit: Jan 22, 2011, 10:54 am by udoklein Reason: 1
Also die Libraries sind ganz OK, wenn auch an manchen Stellen etwas schwach. Um schnell was hin zu pinseln aber eigentlich immer ausreichend. Die IDE hingegen ist unterdurchschnittlich, man muß sie ja aber nicht verwenden ;)

Gruß, Udo
Check out my experiments http://blog.blinkenlight.net

MaFu

Da muss ich Udo beipflichten. Wenn man die anderen gängigen IDEs gewohnt ist, bietet die Arduino Umgebung sehr wenig. Aber einen Fehler irgendeiner Art hat sie mir bisher noch nie produziert.
_______
Manfred

uwefed

Man muß aber bedenken an welche Zielgruppe sich der IDE wendet: an Leute die nicht an der Programmierung eines Controllers interessiert sind, sondern ihn als Mittel zum Zweck nehmen um ihre Ideen zu verwirklichen.
Da ist der Funktionsumfang ausreichend und die Einfachheit gewollt.

Viele Grüße Uwe

MaFu

Da hast Du natürlich recht. Aber gerade für Programmier-"Amateure" wären vielleicht ein paar optische Hilfen nicht schlecht.
Wenn ich meine Anfangszeit (ist inzwischen über 25 Jahre her) mit den aktuellen IDEs vergleiche: so einige der aktuellen Hilfsmittel hätten mir mit Sicherheit den Einstieg erleichtert.
_______
Manfred

Go Up