Go Down

Topic: Dieses OLED an Arduino? (Read 24770 times) previous topic - next topic

DE8MSH

#60
Jan 12, 2011, 10:25 am Last Edit: Jan 12, 2011, 10:35 am by DE8MSH Reason: 1
Hi jkw,

bei kleinerem Co wird Vripple größer.

Bei 220µ: 3,3v > 12v = 135mV.
Bei 740µ: 3,3v > 12v = 40mV.

Ich nahm den 220µ. Ich teste das nun ertmal damit. Wenn das nicht reicht können wir noch einen C in Reihe geben. Würde noch einer in die 2cm² passen?

2bcontinued

EDIT: "reihe" ich quark. Parallel muss er, der C.
Look at
http://de8msh.blogspot.com/
and
http://www.youtube.com/user/de8msharduino

jkw

Es ist also angekommen?
Ich bin mal gespannt.
Wenn du vorerst 12 V erhalten solltest, dann versuch mal bitte ne LED oder irgendeinen kleinen Verbraucher ( denk dran das da keine 200mA fließen sollen ) dran zu hängen und schau mal bitte ob die Spannung dann einbricht.
JKW

DE8MSH

#62
Jan 12, 2011, 10:29 am Last Edit: Jan 12, 2011, 10:31 am by DE8MSH Reason: 1
Die Ware noch nicht (Stand gestern). Sie wird heute / morgen kommen.

Wenn die 12v bei einer LED schon zumacht dann....  :'(
Look at
http://de8msh.blogspot.com/
and
http://www.youtube.com/user/de8msharduino

jkw

Du wirst es wahrscheinlich kaum glauben, aber ich habe heute einen MC34063A gefunden. Auf alten Platinen die weggeworfen werden sollten.
Ich hab versucht auf die schnelle die anderen Teile zu finden, allerdings gabs keine passende Diode mehr.
Ich habs jetzt mal mit einer einfach Schottky Diode probiert, doch damit erhalte ich am Ausgang nur 3V und die Schaltung nimmt >1A auf. Das ist sicherlich nicht richtig.
Wobei es mich etwas wundert. Ich hab den Schaltplan noch ein paar mal überprüft, aus meiner Sicht scheint alles zu passen.
:-/
Wie siehts bei dir aus? du hast die richtige Diode bestellt?

DE8MSH

#64
Jan 12, 2011, 09:35 pm Last Edit: Jan 12, 2011, 09:35 pm by DE8MSH Reason: 1
Das ist nicht gut... Ich habe irgendwo gelesen, dass wenn man keine Scotty Diode nimmt, die schnell genug schaltet, man nicht die volle Voltzahl erreicht. Hast Du alles bis auf die Scotty so wie in deinem Schematic verbaut?  :-[
Look at
http://de8msh.blogspot.com/
and
http://www.youtube.com/user/de8msharduino

jkw

Japp, 220uF statt 700 hab aber auch mal einen 500er parallel dazugesteckt.
Aber ich bin durchaus optimistisch, wir sind bei leibe nicht die ersten Menschen die den Step Up Wandler aufbauen. Ich versuch morgen mal bei meiner Firma eine Shottky Diode abzugreifen. Deine Teile kommen morgen nehme ich mal an?

Gruß JKW

DE8MSH

#66
Jan 13, 2011, 10:07 am Last Edit: Jan 13, 2011, 10:45 am by DE8MSH Reason: 1
Teile noch nicht da. Liegt aber an DHL.

Zum Thema nochmal: http://www.mikrocontroller.net/articles/MC34063

Die gehen aber von 4-12vIn aus. Wir haben "nur" 3,3v. Kann man aus http://www.mikrocontroller.net/articles/MC34063 etwas zu unserem Problem entnehmen?

Ich habe das nochmal zusätzlich aufgemacht:
http://www.mikrocontroller.net/topic/204344#new

Mal sehen, was die sagen... Die Einzige Frage, die dort bisher interessant erscheint ist ob die Schaltung schwingt. Lt. Rechner gab ich ja 25kHz an. Kannst Du das messen?
Look at
http://de8msh.blogspot.com/
and
http://www.youtube.com/user/de8msharduino

jkw

Mehr oder weniger gute Nachrichten:
Das weglassen des Ct wie es in diversen Schaltungen mit dem MC gemacht wurde führt bei uns zu dem katastrophalen Ergebniss.
Mit 820pF kommen 12,34 V raus.
Problem ist jetzt der Wirkungsgrad: Ich liege mit meinem Aufbau bei 50%. Das heißt 490mA auf 3.3V *boom* 8)
Bei 5V komme ich auf  250mA .. wobei dafür die Spule noch nicht passt ..
Bin noch am Testen. An der Diode liegte übrigends nicht.
JKW

DE8MSH

Den 1,3nF habe ich aber mitgeordert.
Look at
http://de8msh.blogspot.com/
and
http://www.youtube.com/user/de8msharduino

jkw

So, ich bin raus.
Mein bestes ergebniss liegt bei 350mA mit 3,3v.
Da wir für die beschaltung aber ohnehin ein exteres Netzteil nehmen müssten, können wir auch gleich eins mit 12v nehmen. Die 3,3x nehmen wir dann vom arduino.

Ärgerlich da kein standalone betrieb drin ist aber so passt vielleicht noch ein Wandler auf die platine.

Trotzdem Versuch mal ob dir noch was gelingt, wäre ja cool.

DE8MSH

Ja, genau das war schonmal im MCnet Thema. Ich habe das nur nicht mehr wiedergefunden. Da hatte jemand ähnliche Probleme/das gleiche Problem. Ich meine: 350mA sind besser als die 490mA  ;)  Aber nicht so gut wie 100mA  :-[

Look at
http://de8msh.blogspot.com/
and
http://www.youtube.com/user/de8msharduino

jkw

#71
Jan 13, 2011, 02:48 pm Last Edit: Jan 13, 2011, 02:49 pm by jkw Reason: 1
Vor allem ist es wesentlich zu weit weg von dem was der Arduino Stand-alone bieten könnte ...
Wenn man auf den ganzen Step Up Krams verzichtet und einfach direkt 12-15 V ans Display und 3.3 V vom Arduiino anlegt dann ist auf dem Board nur noch der ZIF, 1xR, 2xC und der Pinheader ... dann passen 4 Adapter dahin, wo vorher 2 waren ... hat auch was ;)
1,25x2,3 cm .. Inklusive 2x Haltelöcher, M3

DE8MSH

#72
Jan 13, 2011, 02:51 pm Last Edit: Jan 13, 2011, 02:53 pm by DE8MSH Reason: 1
Jaja.... Wie sagte Uwe damals:

Wieso nehmt ihr nicht die 5V als Spannungsquelle für den 12V DC/DC Converter?
Oder vesorgt den Arduino nicht gleich mit 12 am Netzteilstecker? So stehen 12 V an Vin zur Verfügung.


;)

Naja, meine Order war ja nicht ganz umsonst. So einen MC34063 kann man immer mal gebrauchen.  ;D
Look at
http://de8msh.blogspot.com/
and
http://www.youtube.com/user/de8msharduino

jkw

Sou, um mal eben den Thread hier upzudaten:
Die Schaltung zum erzeugen der 12V steht, sie zieht 105mA bei 5V und erzeugt damit 12,4V an einem 323 Ohm Widerstand (38mA). Das sollte etwa die Last widerspiegeln die das Displays bei maximaler Helligkeit erzeugt.





Die Platine ist in der Herstellung, leider habe ich den ZIF Stecker falsch herum kontaktiert, was nun dazu führt das man das Kabel vom Display geknickt einführen müsste. Das ist sehr unschön aber nicht zu ändern für den Moment.  Die aktuell verwendete 330uH Spule erzeugt ein leises Piepen, schwingt also. Wenn man größere Induktivitäten nimmt ( oder eben mehrere in Reihe ) hört es auf. Eine passende ist bestellt, dauert aber wohl bis sie da sein wird. Dem Wirkungsgrad hat es nur maginal etwas angehabt, dort bin ich recht stabil auf 88-89% gekommen.

Soweit dazu, das Thema lebt also noch, OLED stand-alone am Arduino ;)
Gruß JKW

DE8MSH

Ja, wenn das nachher rennt wird's schön.
Look at
http://de8msh.blogspot.com/
and
http://www.youtube.com/user/de8msharduino

Go Up