Pages: [1]   Go Down
Author Topic: problemas con arduino ide y xubuntu hardy  (Read 768 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola yo tengo una placa arduino serial hace un tiempo, antes la usaba en windows xp y xubuntu 7.10 indistintamente sin problemas, ahora luego de formetear mi pc e instalar xubuntu hardy tengo el siguiente problema, la ide de arduino no muestra la opcion "serial port"(esta en gris), por lo que no me deja programar la placa. He intentado con la version 10 y 11 de arduino, tambien probé todo lo que sale en la web de arduino en ingles, todas las recomendaciones para ububntu, pero no lo he podido hacer funcionar, he llegado a apensar que quizas xubuntu no me ha reconocido el puerto serial, alguien sabe como podria probarlo?, ojala alguien me pueda ayudar, gracias
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 43
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Me imagino que es el mismo problema que hay con Ubuntu:

sudo apt-get remove brltty

debería de resolverlo.

« Last Edit: May 18, 2008, 07:56:34 am by hj43us » Logged

Colombia
Offline Offline
Full Member
***
Karma: 0
Posts: 130
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Revisa este documento:

http://www.arduino.cc/playground/Learning/Linux
Logged


0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ya revise el documento y no tengo instalado el paquete brltty que causa el problema, pero no tengo solucion, presumo que no tengo bien configurado el puerto serial, pero la informacion que encuentro en internet me enseña como hacerlo modificando inittable, desafortunadamente ubuntu ya no usa ese sistema de arranque por lo que todavia sigo sin saber como configurarlo manualmente.
Logged

Colombia
Offline Offline
Full Member
***
Karma: 0
Posts: 130
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

cuando conectas la placa y le das dmesg deberia salirte algo como:
Code:
usb 3-2: FTDI USB Serial Device converter now attached to ttyUSB0
usbcore: registered new interface driver ftdi_sio
drivers/usb/serial/ftdi_sio.c: v1.4.3:USB FTDI Serial Converters Driver

si no te sale puede ser que tu sistema tenga problemas cargando el diver ftdi_sio.ko

Logged


0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
cuando conectas la placa y le das dmesg deberia salirte algo como:
Code:
usb 3-2: FTDI USB Serial Device converter now attached to ttyUSB0
usbcore: registered new interface driver ftdi_sio
drivers/usb/serial/ftdi_sio.c: v1.4.3:USB FTDI Serial Converters Driver

si no te sale puede ser que tu sistema tenga problemas cargando el diver ftdi_sio.ko


Agradezco la ayuda zea, pero como he escrito inicialmente, el problema es que mi placa no es USB sino una serial rs232 con atmega 168.
Creo (aunque me parece raro) que xubuntu no dejó bien configurado el puerto serial de mi pc luego de la instalacion, He tratado de configurarlo manualmente pero lamentablemente solo encuentro informacion  que me serviria para versiones antiguas de ubuntu que usaban inittab para configurar el arranque, actualmente ubuntu no usa este fichero para la configuracion por lo que si alguien sabe como configurar el puerto ttys0 en  (x)ubuntu 8.04 por favor indiqueme como.
Muchas gracias a todos los que me han repondido.
Logged

Colombia
Offline Offline
Full Member
***
Karma: 0
Posts: 130
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

acabo de hacer un rapido googling sobre el serial en ubuntu y encontre que puede existir un conflicto con un paquete llamado dkms (que no se que hace) y segun leo removiendolo del sistema puede solucionar el asunto.

puedes probar a ver si esto funciona
Logged


Pages: [1]   Go Up
Jump to: