Go Down

Topic: Problemilla con el IDE (Read 354 times) previous topic - next topic

KaR]V[aN

Buenas,

Soy bastante nuevo con Arduino y no consigo hacerlo funcionar.

Mi problema es que no consigo que el IDE me reconozca los puertos serie en mi Mac OS X Leopard (PowerPC G4).

Cuando le doy al menú 'Tools' se muestra en la consolita negra el mensaje 'java.lang.ClassCastException: gnu.io.RXTXCommDriver thrown while loading gnu.io.RXTXCommDriver', denotándose al mismo tiempo que el submenú 'Serial Port' no es seleccionable.

Tengo perfectamente instalado el driver ya que soy capaz de ver como un puerto serie se crea y se destruye cada vez que conecto y desconecto la placa Arduino de mi ordenador (ls /dev/tty.*) por lo que se a ciencia cierta que no se trata de un problema de hardware.

Por alguna razón que desconozco, el IDE Arduino 12 no puede listarme los puertos disponibles para escoger el puerto serie en el que está mi placa Arduino, todo lo que se es ese mensaje anodadante que lanza el IDE.

Una forma posible de arreglarlo podría ser decirle por algún parámetro de linea de comandos el puerto que uso o editando algun archivo de configuración, pero no se siquiera si es posible.

Un saludo y gracias
http://karman.cc

Outl4w

Hola karman, solo te puedo decir que a mi en concreto la versión 12 me esta dando bastantes problemas, aunque uso ubuntu (64 bits), y las versiones anteriores no me daban ningun tipo de problemas, te aconsejaría que probaras alguna versión anterior para ver si te sucede lo mismo porque ya te digo que a mi solo me está dando problemas parecidos esta versión.

El caso es que no sé dónde conseguir otra versión ya que en la web sólo encuentro la versión actual y al haber formateado no te la puedo pasar.

Siento no poder ayudarte más.

Ánimo y un saludo.

Go Up