Pages: [1]   Go Down
Author Topic: Arduino minimalista no funciona  (Read 536 times)
0 Members and 1 Guest are viewing this topic.
Euskadi
Offline Offline
God Member
*****
Karma: 16
Posts: 721
Arduinotarrak
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola,

He montado sobre placa perforada de fibra de vidrio un arduino minimalista, conectando un zócalo de esta manera:

- pin 1  con 10K a +5V
- pin 7 y pin 20 a +5V
- pin 8 y pin 22 a GND
- 100nF entre pin 7 y pin 8
-pin 9 y pin 10 a cristal de 16MHZ con dos 22pF a GND
- pin 13 a led + 220K a +5V

La alimentación se toma de un Arduino 2009, para descartar que fallo esté en la fuente (luego llevará alimentación independiente)

No tiene nada para cargar programas: por ahora utilizo el método más directo: utilizar el mismo atmega328 extrayendo de un zócalo e introduciendo en el otro. Con la ayuda de un pequeño destornillador plano el intercambio de chip no presenta ninguna dificultad (con la placa apagada por supuesto)

En el 2009 he cargado un sketch que enciende y apaga continuamente un led en pin 13. He extraído el atmega328 del zócalo del 2009 y lo he introducido en el zócalo minimalista. No funciona.

He comprobado tensiones en los pines del atmega328, pines 1, 7, 20, 8, 22, 13, no se ve nada anormal.
He vuelto a recolocar el atmega en el 2009, y funciona bien.

Podría ser algo relacionado con el cristal? Tiene escrito "16.000 KDS" (comprado en Electan)

¿Hay que hacer reset en un entorno como este para que empiece a funcionar un sketch?

Llevo varios días atascado ¿Qué más comprobaciones podría realizar?

Agradezco toda ayuda.


Logged

Offline Offline
Edison Member
*
Karma: 23
Posts: 1375
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Pon en el pin 13, el LED con una resistencia de 330 Ohm en serie a GND.
Con 220K Ohm es normal que no se te vea.

Un saludo
Logged

Mercadillo electrónico. Kit iniciación a Arduino, shield LCD a color y más cosas!

Euskadi
Offline Offline
God Member
*****
Karma: 16
Posts: 721
Arduinotarrak
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


He cometido un lapsus en el mensaje anterior, la resistencia que tiene en serie el led es de 220 ohm

Con el zócalo vacío, si conecto +5V al pin 13, se enciende el led
Logged

Pages: [1]   Go Up
Jump to: