Pages: [1] 2   Go Down
Author Topic: encender bombilla en alterna con piezo  (Read 4311 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hola,
algo aparentemente sencillo. he visto un video.
tenemos que encender una bombilla en alterna mediante arduino traves de lectura por piezolectrico.
aparentemente sencillo.
empleamos un rele para ello.
tengo info de uno de finder rs492 6710
alguien puede comentar o enviar el disgrama de conexionado? porque aparentemente parece intrincado, por lo menos para mi.
Logged

Forum Administrator
MMX
Offline Offline
Edison Member
*****
Karma: 37
Posts: 1139
hallo kompis
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola,

si vas a trabajar con reles, tendras que tener en cuenta que Arduino no puede hacer la conmutacion de las bobinas en los reles. Te va a hacer falta usar un transistor como conmutador para activar el rele que luego hara de interruptor mecanico de los 220Volt para encender la bombilla. He hecho unos dibujos para que veas de que hablo:



Por otro lado, el esquematico del circuito que tienes que montar para tu caso es como sigue:



Si necesitas ver las fotos a mas resolucion, echa un vistazo en mi cuenta de flickr:

http://www.flickr.com/photos/dcuartielles/sets/72157594415771641/

Un saludo,

/David
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 42
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

que transistor debo utilizar? Un BJT?
he visto un rele de omron que necesita 5V, justo lo que saca la placa.
http://www.micropik.com/provisional/PDF/g5v1.pdf

que opinas?

en caso de una conexion erronea y al tratarse de alterna revienta la placa?
Logged

Forum Administrator
MMX
Offline Offline
Edison Member
*****
Karma: 37
Posts: 1139
hallo kompis
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola,

el problema de los reles no esta solo en el voltaje que hace falta para activarlos, pero en la corriente que hace falta para mover la bobina del rele. Aunque los actives a 5V, es posible que los pines del Atmega8 en la placa Arduino no puedan proporcionar suficiente corriente.

Por otra parte, este rele que has elegido solo funciona hasta 125VAC (0.5Amp) o 24 VDC (1Amp), asi que no te valdra para controlar una lampara como propones

Respecto al transistor, el BD139 (http://www.fairchildsemi.com/ds/BD%2FBD139.pdf) puede estar bien, yo lo he utilizado y me funciono.

Un saludo,

/David
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

hola, yo acabo de comprarme una arduino + un relay Potter &Bruns.. de 12 volt + un aprotoborad, y tambien deseo predner una luz, lo que tienes al mediuo del diagrama es una resistencia ? y me podirias indicar como conecto too en la protoborad?

saludos
Logged

Forum Administrator
MMX
Offline Offline
Edison Member
*****
Karma: 37
Posts: 1139
hallo kompis
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Tienes hoja de caracteristicas de ese rele?

/d
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Perdon por no responder eesto a tiempo al final logre hacer que mi arduino prendiese/ apagase un bombillo conectado a los 220 V de la corriente del enchufe.

Solo puse un rele de 5v conectado a la arduino en sus terminales de entrada/sailida y luego programe una accion sencilla en arduino que esperase por la instrucción de corte de corriente en uno de los pines digitales. Ahora voy de salida pero pondre en este foro la construcción del sistema y la programación en flash y arduino para hacerlo funcionar.

Saludos
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok como les decia, aca va lo que yo hice para prender un dispositivo conectado a 220V de corriente alterna mediante un rele de 5V.

Especs del relé:
- TAHUQ (creo que es la marca)
- 5A/240VAC, 10A/127VAC, 5A/24VDC, COIL: 6VDC

lo Primero fue cablear el rele a la arduino tomando como salida de voltaje para mover la bobina el pin digital 10.
Para controlar la corriente del pin digital 10 me base en un tutorial de enciendido de leds via arduino/Macromedia flash. (http://www.cristalab.com/tutoriales/202/controlar-hardware-electronico-con-flash-y-arduino)

Foto del setup: http://www.flickr.com/photos/theguaz/1855952245/
Foto del relé: http://www.flickr.com/photos/theguaz/1856935946/

NOTA: en la oportunidad que logre hacer el setup por 1º vez estaba trabajando en un PC, ahora trabajo full macbook, y resulta que al tratar de replicar ayer este setup me encontre con la ocntrariedad de no poder configurar el serproxy.cfg correctamente para ver a la arduino desde flash. Lo logre con esta configuracion (ojo donde dice cu en vez de tty):

# Config file for serproxy
# See serproxy's README file for documentation

# Transform newlines coming from the serial port into nils
# true (e.g. if using Flash) or false
newlines_to_nils=true

# Comm ports used
comm_ports=1,2,3,4

# Default settings
comm_baud=19200
comm_databits=8
comm_stopbits=1
comm_parity=none

# Idle time out in seconds
timeout=300

# Port 1 settings (ttyS0)
net_port1=5331

# Port 2 settings (ttyS1)
net_port2=5332

# Port 3 settings (ttyS2)
net_port3=5333

# Port 4 settings (ttyS3)
net_port4=5334

serial_device1=/dev/cu.usbserial-A4001nLe


Hecho esto solo tuve que darle bien la ruta de mi servidor arduino en la clase de actionscript y listo.


Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 42
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola David, siguiendo tu consejo de montaje, el mismo obtenido en:
http://www.arduino.cc/playground/uploads/Learning/relays.pdf
no me funciona. La cosa es que estoy probando primero en continua, iluminando una bombillita halógena de 20W. Se debe iluminar un poquito porque con 5V ya he probado, pero quiero hacerlo con el rele. Un finder de hasta 10A y 6VDC, de 5 pines. Ya subiré el circuito, pero he usado un transistor bd139. Tu pones que lo use en AC, pero lo hago en DC. No funciona, ni chasquea el rele.
si conecto directamente la bolbilla al rele, y este a la alimentaicon del arduino, no se ilumina nada pero chasquea el rele.
Puede ser que sea por el transistor y deba usar un 2N222PN ?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 42
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

El relé usado está en esta dirección un poco más especificado: :-/
http://www.electan.com/catalog/rele-tipo-contacto-amp-bobina-6vcc-finder-p-1453.html
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Estoy buscando reles parecidos al que has usado y como no tengo ni idea de electricidad pues pongo aqui unos links para que recomendeis cuales de los que hay en esta pagina pueden usarse para encender bombillas normales usando la arduino.
http://www.electan.com/catalog/reles-c-120.html
http://www.elrafel.com/tienda/index.php?page=pp_producto.php&md=0&codp=1994&PHPSESSID=ffd55f788631f68cca1ac9a58d9c291
http://www.amidata.es/cgi-bin/bv/rswww/searchBrowseAction.do?N=4294963884&name=SiteStandard&forwardingPage=browse&callingPage=/jsp/line/line.jsp&BV_SessionID=@@@@1031502788.1197129332@@@@&BV_EngineID=cccjaddmkdlhflecefeceeldgondhgi.0&cacheID=esnetscape&Nr=avl:es
 Me pierdo con el tema de la tension nominal los amperajes y demas, a ver si podeis aclararme las cosas un poco.
¿la bobina tiene que ser de 6V? el amperaje de 5A, o podria usarse reles de menos amperaje? etc....
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 42
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

A ver, he comprado un rele finder de 6V de continua de 5 patillas. 2 para el +/- de la bobina de 6Vcc, otro GND, y los dos para activar la salida por + o -. Como no se muy bien cual de esta dos es la correcta he probado con ambas.

He seguido la conexión de la imgane de arriba.

estoy en DC, no en AC. Recomendaste el BD139 para AC. Yo uso ése pero en DC, ¿es ese un error, o por el contrario si que tolera el montaje?

Conecto la masa de arduino a la tierra del relé y al colector del DB139. El pin digital 10, sobre el que meto un delay para activar y desactivar la salida al relé se conecta a la resistencia, la cual va a la base del BD139.
El colector se conecta al + del relé. El relé conmuta una bombilla DC de 12V halógena. Arduino saca 5V, que es una iluminación parcial de la bombilla. si que se ve que ilumina, eso está claro, no hay duda por ahí. Como dije, no se cual de los pines es el +/- en la salida del relé, por lo que he probado con ambos.
También puede que haya colocado al revés el BD139, estando cambiados el Emisor y colector. También he probado invirtiendo.
No se que pasa.
Lo que si sé es que el relé no conmuta con transistor, pero conectada la bombilla al rele y éste a arduino conumta el rlé pero no ilumina. Tal vez por falta de corriente. Los 5V que saca arduino son suficientes para los 6V del relé, eso también está bien.
Tal vez el BD no vale.
adjunto fotos.
http://www.flickr.com/photos/21664172@N07/

relé
http://www.electan.com/catalog/rele-tipo-contacto-amp-bobina-6vcc-finder-p-1453.html
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 42
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

El tema del amperaje, es el máximo admisible, si vas a usar poco puedes usar el de máximo 10 A.
Arduino saca 5V en DC de la placa por lo que necesitas un relé que se active con 5 o poco más, que es el de 6V DC porque creo que no hay más bajo. Esos relés, los de finder por lo menos, los encuentras facilmente en cualquier sitio a esos precios.
Luego están los contactos del relé. El de 2 que uso yo es para pasar de un estado a otro, o eso creo.
Explica para que los quieres, quizá vas en dirección errónea. Lo digo por propia experiencia.
Logged

Madrid
Offline Offline
Full Member
***
Karma: 0
Posts: 217
¡¡ Siempre aprendiendo !!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


Aunque este post es viejo y seguramente lo hayais resuelto ...

http://www.arduino.cc/es/Tutoriales/Rele

Salu2,

Igor
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 24
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Aunque es antiguo quiero corregir el link de Igor porque a mi no me funciona y como estoy empezando y para muchos como yo, es muy interesante el tema de RELES.

http://www.arduino.cc/es_old/Tutoriales/Rele

Yo le en encontrado en GOOGLE, si por alguna ocasión ese link no debe usarse ya, por favor quitar este POST.

Un saludo
Logged

Pages: [1] 2   Go Up
Jump to: