Go Down

Topic: No me reconoce Arduino Uno. (Read 12 times) previous topic - next topic

Pere Cordonet

Hola a todos,

Hace unos días me compre mi primer arduino.

El hecho es que despues de hacer una prueba con el robot roomba, ahora conecto el arduino a mi pc y este no lo reconoce.

Alguien me puede echar una mano?

Muchas gracias de antemano.
Pere.

MSL

No se si haz instalado los drivers, o cheka esta página si es que usas Windows:

http://arduino.cc/es/Guide/Windows

Pere Cordonet

Gracias por responder.

El problema que yo conecto con el cable usb que viene con arduino al ordenador y no me sale el dialogo de nuevo hardware. Lo que si se enciende el led de "on" o sea que le llega la corriente.

Sirve de algo esto ?

Muchas gracias.


chiva

¿has probado con más ordenadores, otros sistemas operativos, otro cable, otro puerto USB? me imagino que no llegará a aparecerte en el administrador de dispositivos, ¿no?

Y si no, pues regraba el bootloader

Un saludo
Mercadillo electrónico. Kit iniciación a Arduino, shield LCD a color y más cosas!

Pere Cordonet

#4
Jan 08, 2011, 02:06 pm Last Edit: Jan 08, 2011, 02:21 pm by pcordonet Reason: 1
He probado con otro ordenador, todos con windows xp y tampoco me aparece el dialogo de nuevo hardware.

Tampoco me apararece en el administrador de dispositivos.

Como puedo ragrabar el bootloader ??

Gracias.

chiva

#5
Jan 08, 2011, 02:46 pm Last Edit: Jan 09, 2011, 12:12 pm by chiva Reason: 1
Con un Arduino de la generación anterior, con un programador de AVR, o con el puerto paralelo
http://arduino.cc/en/Hacking/ParallelProgrammer
Mercadillo electrónico. Kit iniciación a Arduino, shield LCD a color y más cosas!

Pere Cordonet

Voy a ver si puedo comprar o hacer el cable para cargar bootloader.

Muchas gracias por tu ayuda.
Pere

chiva

Mercadillo electrónico. Kit iniciación a Arduino, shield LCD a color y más cosas!

Heke

Pero el robot roomba no tiene nada que ver con arduino !!!

Si es un aspirador movil !!

Lo que es posible es que simplemente tenga que desinstalar el driver o conectar el arduino en otro USB distinto porque el software del roomba este ocupando el puerto de este pero de ahi a perder el bootloader....

No creo por lo que explica que lo haya perdido, simplemente que windows tenga otro driver en ese USB, probablemente, como bien le has dicho, si revisa el administrador de dispositivos de windows, vea que tiene algo mal puesto.
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

Pere Cordonet

#9
Jan 11, 2011, 11:07 pm Last Edit: Jan 11, 2011, 11:09 pm by pcordonet Reason: 1
Hola, Heke.

El tema de la Roomba, es porque había intentado hacer este proyecto.
http://www.netfluvia.org/layer8/?p=127

El problema que me puede haber pasado, es el tema del voltaje, aun no lo tengo demasiado claro. Me dejé un paso no puse el regulador de voltage y conecté directamente al arduino, lo he fundido ??? .


El tema del driver, supongo que no pude ser, ya que he probado el arduino en otro pc, donde nunca ha estado instalado, y tampoco me pide el dialogo de hardware nuevo.

Alguna teoria ????

Muchas gracias de nuevo.
Pere


chiva

No se muy bien que conexiones hay hechas ahi y que función tiene el regulador que está en la placa blanca. Si pudieras poner una foto de lo que tienes
Mercadillo electrónico. Kit iniciación a Arduino, shield LCD a color y más cosas!

Heke

#11
Jan 12, 2011, 08:10 pm Last Edit: Jan 12, 2011, 08:10 pm by Heke Reason: 1
Por lo poco que he visto...

Conectaste (corrigeme si me equivoco) la tension de las baterias del  roomba para alimentar el arduino directamente a los pines de la placa (que en realidad son la salida y no entrada) y no a traves del jack de alimentacion pero ademas lo hiciste sin poner antes un regulador integrado tipo lm7805 verdad??

Si es asi casi seguro te has cargado o el arduino o el chip que se encarga del usb, que en arduino-uno me parece que ya no es un ftdi pero bueno, no tengo esa placa no lo puedo asegurar al 100%.

No se en esa pagina, porque, el que hace ese hack al roomba, prescinde de la seguridad que le da el regulador integrado que ya trae arduino en su placa, desde mi punto de vista lo veo una burrada pero vamos... igual esta bien y tiene sus motivos, yo al menos no lo haria asi.

Mira a meter tension desde usb y con el polimetro ver la salida del regulador de placa del arduino y vas aislando posibles averias.

En el peor de los casos que solo sea el regulador se puede cortar y sustituir por otro, en el caso del chip USB, al tratarse de smd la unica opcion es prescindir de el y si el arduino esta bien, programarlo en otra placa e insertarlo en esta, para aplicaciones que no hagan uso del usb.

Esto es por aprovechar alguna parte de ese uno si se ha escoñado solo un componente, no se me ocurre mas.

Eso si, toca el chip del arduino con el dedo por si detectas que se calienta mas de la cuenta.
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

chiva

Aaaaa!!, vale!!
Está alimentando el Arduino por los pines 5V y GND, que creía que estaba conectado a una batería por el jack...

Entonces perfecto, pero es que la imagen es del que hizo el blog, no estaría mal ver el montaje que has hecho tú.

@Heke: los pines de alimentación no son ni salida ni entrada, son lo que haga falta en cada momento. Y como ves, en la protoboard tiene el regulador, que suple el del Arduino, asi que todo correcto. :)

Un saludo
Mercadillo electrónico. Kit iniciación a Arduino, shield LCD a color y más cosas!

Go Up