Go Down

Topic: INSTALACION. (Read 1 time) previous topic - next topic

LADG

Señores.
Saludos.
Estoy empezando con Arduino UNO, pero no he podido instalar el IDE, lo puedo bajar, pero cuando trato de descomprimirlo me aparece el siguiente mensaje.COULD NOT FIND THE MAIN CLASS: PROCESSING.APP.BASE.  PROGRAM WILL EXIT. He actualizado JABA.
sin resultado.
Una experta mano no me vendría mal.
PD. Mi OS es windows XP

eried

Lo descomprimes y te sale ese mensaje?

Creo que tienes una confusión de conceptos
My website: http://ried.cl

LADG

Es posible, ¿pero cual concepto?, es una operación directa, lo bajas, descomprimes con win zip, seleccionas EXE del IDE y nada, te aparece el fulano mensaje.
Por lo simple que parece ( seguramente a otros foristas no le a sucedido lo mismo) es que he solicitado asesoria de los expertos

eried

Bueno, entonces es al ejecutarlo.

Puedes probar rápidamente 2 cosas, si actualizaste java en tu máquina, puedes renombrar el directorio "java" de la carpeta Arduino a otra cosa como "java2".

Si eso no funciona puede ser que tu descarga esté corrupta, intenta limpiando el historial y temporales del navegador y bajando el archivo de nuevo.

Y si eso no funciona, puede ser el problema expuesto acá http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1237584502/all
My website: http://ried.cl

LADG

Seguiré tus indicaciones, he visto el caso al que me referiste y es idéntico.
Gracias.

LADG

Feliz Año 2011.
Para mi ha sido un completo fracaso el intentar abrir el IDE de ARDUINO. He reinstalado el mismo cualquier cantidad de veces, he hecho lo mismo con JAVA, todas las versiones y nada, he seguido los concejos de los expertos y NADA.
Mi S/O es Windows XP. SP3, mi ARDUINO es UNO, cuando lo conecto al puerto USB, el LED de ON se ilumina y el del pin 13 destella a un ritmo regular, el mensaje de nuevo hardware encontrado aparece, seguido de no se encontró el driver adecuado.
En lo referente a el IDE un mensaje de JAVA diciendo que no encuentra la base, es constante y se sierra.
Seguro que en algo estoy fallando ò esto no es tan amistoso como lo presentan. ¿alguna orientación ?
                   

Heke

Hola

Si te dice que no encuentra el driver adecuado, ¿como esperas que funcione?

Mirate el manual de instalacion del ide que es muy sencillo, y veras que te dice:
  "...cuando te pide el driver, le tienes que decir que no lo busque él, que tu le vas a decir la ruta..."

  Esa ruta donde lo vas a dirigir es precisamente la carpeta llamada "driver" que viene en el IDE cuando lo descomprimiste.

Mientras no tengas el driver bien instalado no va a funcionar ni por asomo.

Una vez que este instalado, y arranque, hay que decirle en el IDE que tienes una placa de tipo "arduino UNO" y el puerto en el que esta conectado (yo empleo un truco para saber que puerto es cuando tengo varios y es abrir el ide y ver la cantidad de puertos serie que detecta para seleccionar y luego enchufo el arduino y me aparece el nuevo que ha encontrado que no estaba antes y ya me pongo a trastear con el.

Cuentanos si lo consigues o no para que podamos ayudarte.

PD: yo tambien uso XP SP3 y funciona bien
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

LADG

De acuerdo Amigo.
Es posible que no me explicara correctamente.
Lo que me indicas es el modo en que debía funcionar, pero no es así.
Como lo hago: Descomprimo el IDE, selecciono Drivers, conecto ARDUINO UNO, aparece el mensaje de nuevo hardware encontrado, a continuación, aparece el cuadro al que haces referencia, le digo que no  lo busque por si mismo, en la ventana siguiente aparece un directorio amplio con todos los dispositivos que maneja el sistema, pero no me permite agregar los driver que tengo en la carpeta de arduino.

Heke

#8
Jan 02, 2011, 09:38 pm Last Edit: Jan 02, 2011, 09:39 pm by Heke Reason: 1
Compañero, no lo haces bien, estas esperando (por lo que dices) que te aparezca el driver y no es asi, le tienes que decir tu MANUALMENTE donde esta.

Sigue este enlace que te lo explica muy sencillo y con ejemplos graficos, la unica diferencia sera el nombre de la carpeta "drivers-ftdi usb drivers" pero el procedimiento es el mismo.

Recuerda que no te importa los dispositivos que maneje el sistema, simplemente es instalar manualmente un driver como cualquier otro driver de windows, de hecho, tu problema no esta con el arduino, tu problema esta en saber instalar drivers dentro de windows independientemente sean de un controlador usb de arduino o de cualquier otra cosa.

Hazme caso, sigue este link pero paso por paso y veras como al final lo consigues:

http://www.arduino.cc/es_old/Software/Windows

Un saludo.
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

LADG

Seguí tus indicaciones y pude instalar el IDE, todo funciona bien, pero no he podido instalar los driver, las ventanas que me presenta Window no son las mismas y no responden de acuerdo a los tráficos que muestran las guias, cuando conecto ARDUINO no aparece la ventana de nuevo hardware encontrado.
Al conectar la tarjeta el LED conectado a el pin 13, empieza a destellar con una cadencia particular, cuatro destellos largos y uno corto ( el numero 9 en morse)( la analogía es mía)

Heke

Bueno LADG, algo es algo....

Aunque tu problema ya no corresponde con arduino, mas bien esta en instalacion y desinstalacion de drivers en windows XP, vamos a ver si podemos sacarte de este entuerto.

Por lo que veo, no te pide el controlador porque facil que lo tenga mal instalado o tenga otro que no le corresponde, lo que vas a hacer es reinstalar el controlador, en el enlace que te pongo, explica muy bien el instalar o reinstalar un driver para una tarjeta wifi pero en tu caso, es lo mismo, salvo que en vez de tarjeta wifi, lo que vas a instalar es el driver del arduino, el cual no necesitas ningun CD de instalacion pues los drivers los tienes en la carpeta "driver" del IDE del arduino.

Sigue mas o menos los pasos tal y como indican en esta pagina e intenta instalar como si de una tarjeta WIFI (que es el ejemplo de la pagina) se tratara, salvando las distancias en que lo que vas a instalar es un driver de puerto USB.

http://www.seguridadwireless.net/hwagm/wireless-windows-drivers.html

Espero que lo consigas...

Un saludo.

PD: Aparte de todo, recuerda que en la pagina principal de arduino tambien explica paso a paso la instalacion del ide y de los drivers, un repaso igual venia bien. Suerte.
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

LADG

Estimado.
Saludos.
Siguiendo su indicación accedí a el link recomendado, y efectué todos los pasos, que se cumplieron en la forma esperada, hasta el Administrador de dispositivos, en donde empezaron los problemas, en este aparece en OTROS DISPOCITIVOS: ARDUINO UNO. al seleccionarlo se muestra "El dispositivo no está configurado correctamente. (Código 1)" "Para volver a instalar los controladores para este dispositivo, haga clic en Reinstalar controlador." lo hago y Comienza el proceso de nuevo, llego a la ventana TIPO DE HARWARE y no aparece nada donde pueda ubicar ARDUINO,¿ en cual categoría lo puedo ubicar? en todas pide disco y cuando le señalo uno C:D.E Etc. dice reiteradamente que la información no se encuentra en esa ubicación ubicación.

Heke

#12
Jan 11, 2011, 08:05 pm Last Edit: Jan 11, 2011, 08:10 pm by Heke Reason: 1
Ladg, si te sale "tipo de hardware" lo estas haciendo mal, estas yendo por otro lado.

Tu tienes que ir a inicio, luego a panel de control luego a... bueno, te  pongo aqui abajo la secuencia separada por guiones:


inicio -> panel de control -> sistema(hardware) -> administrador de dispositivos,

Veras todos los dispositivos del sistema y ahi, eliges "arduino uno" estando encima de el, con el boton derecho del raton eliges la opcion de "actualizar controlador"

En el "asistente para actualizacion de hardware" eliges "instalar desde una lista o ubicacion especifica" y le das al boton de "siguiente"

En la siguiente pantalla dejas marcada la opcion de
"buscar el controlador mas adecuado en estas ubicaciones"

Y desmarcas la de "buscar en medios extraibles (disquete CDROM...)"

Marcas la opcion de "incluir esta ubicacion en la busqueda"

Le das al boton "examinar" y te mueves por las carpetas de tu disco duro hasta llegar a la carpeta donde hayas descomprimido el IDE del arduino y dentro de el la carpeta driver

Como ejemplo, si la has descomprimido dentro del disco duro C: y en raiz, te habra quedado mas o menos esta ruta:

   "c:\arduino-022\drivers" y es esa ruta la que debe figurar en la casilla que has dado de "examinar"

Llegados a este punto, le das a siguiente y el resto ya lo hace el solo.
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

LADG

BINGO. AL FIN.
Gracias Amigo Muchas Gracias
Esto puso a prueba mi paciencia, y yo la suya, ya todo funciona, baje algunos proyectos y corrieron muy bien.
Sin la asistencia y sabiduría de Uds. no podría haberlo logrado, no es fácil

Heke

Me alegro compañero.

Ahora si podemos decir eso de:
 
   BIENVENIDO AL MUNDO ARDUINO.
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

Go Up