Go Down

Topic: Documentation for older versions of libraries? [Or: how to update a library?] (Read 296 times) previous topic - next topic

012anonymousxyz

I'm using an intel edison which comes with its own version of the arduino IDE and thus I have an older version of the SPI library (e.g. the header does not contain a definition for SPISettings).

Where can I find documentation relating to the older version of the SPI Library, or, how can I update the current library?

MorganS

It's open source. Look at the library files you have. (The latest IDE buries them in an odd place, but they're still there for you to inspect and modify.)

It might be possible to simply copy the newer ones over the top but there could be a few things to tweak.
"The problem is in the code you didn't post."


Go Up