Pages: [1]   Go Down
Author Topic: [Debutant] Choix d'un composant  (Read 1351 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour à tous,

Débutant en électronique, j'ai besoin d'aide pour trouver un composant.
En effet, je dois lire une tension qui transite dans un circuit sans interférer dans celui-ci. L'idée en fait est de se repiquer sur le faisceau électrique d'une moto pour y lire une valeur indiquant le rapport de vitesse engagé. Mais je ne voudrais pas interférer sur ce circuit déjà existant.
Mes vagues souvenirs du collège me feraient penser à un ampli opérationnel mais je cherche l'avis de spécialistes.

D'avance merci de votre aide
Logged

Geneva
Offline Offline
Faraday Member
**
Karma: 30
Posts: 3228
Yoplait... le pt'it suisse
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Est ce que tu as un affichage du rapport engagé au tableau de bord ?

si ce n'est pas le cas il est fort probable que tu doives installer un système qui te permet de contrôler quel rapport est engagé.

Sur quelle marque et quel type de moto tu compte faire ça ?
Logged

MacBook intel core 2 duo  os X snow Leopard 10.6<br/> eMac PPc G4  os X Leopard 10.5<br/>powerbook G4 os X Leopard 10.5
imac PPC G3 os X Pa

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Il n'y a pas d'indicateur, c'est justement le but de mon montage.

Pas besoin de modifier quoi que ce soit, l'information existe déjà (elle sert en fait au réglage de l'allumage). Mon seul souci est de ne pas interférer. Il s'agit donc de lire une tension sans injecter ni prendre de courant (ou très peu).

Pour info voici les tensions lues:
      Rapport 1 = 1.782v
      Rapport 2 = 2.242v
      Rapport 3 = 2.960v
      Rapport 4 = 3.630v
      Rapport 5 = 4.310v
      Rapport 6 = 4.660v
      Point mort = 5.000v

D'avance merci de votre aide  smiley
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salut,
Tu peux utiliser l'ADC en considérant que
0V = 0
1,782V = 363
2,242V = 459
2,960V = 606
3,630V = 743
4,310V = 882
4,660V = 954
5,000V = 1023

Comme tes tensions des <> rapports sont pas "exactes", tu devras travailler avec une fourchette.
Exemple: si l'ADC donne une valeur entre 700 et 800 tu considères que le rapport engagé est le 4ème. Ainsi de suite pour les autres valeurs lues.

A+

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

C'est effectivement comme ça que je souhaitais procéder mais je me demandais si le fait de se "repiquer" sur ce circuit ne risquait pas d'en modifier les caractéristiques.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Voici une petite video du montage terminé

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Maintenant que mon montage fonctionne je cherche à stabiliser l'alimentation de l'arduino notamment lors du démarrage de la moto.
J'alimente l'arduino avec le 12V de la moto, mais lors du démarrage du moteur il y a une micro-coupure qui réinitialise l'arduino. J'aurais aimé stabiliser cette alimentation et donc pallier à cette micro-coupure.
J'avais pensé mettre un condensateur qui prendrait le relais. Qu'en pensez-vous?
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 61
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
C'est effectivement comme ça que je souhaitais procéder mais je me demandais si le fait de se "repiquer" sur ce circuit ne risquait pas d'en modifier les caractéristiques.

sans aucun doute, tout appareil de mesure influence le système mesuré. le secret c'est que l'influence soit suffisamment faible pour ne pas fausser les mesures ou mettre en panne le système mesuré. (oui même les appareils de mesures genre pince ampérmétrique ont une influence...) donc sans connaitre l'éléctronique de ta motos ça sera dur de le dire... si l'entrée d'un A/D sur un arduino a une impédance trop basse il y a des montages pour adapter l'impédance... mais vu que c'est un montage sur une motos qui doit donc résister à pas mal de bruit, je doute qu'une impédance tel qu'une entrée d'un A/D puisse poser problème...


pour le condensateur, oui c'est une bonne idée, mais il va falloir y ajouter en tous cas une diode, ton condensateur ne va pas suffire à lisser la tension d'alimentation s'il alimente aussi le démarreur... quand à un dimensionnement et un montage correct ça dépasse mes compétences, ça fait assez longtemps que je ne fait plus d'électronique.
« Last Edit: December 11, 2009, 10:52:51 am by elwing » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci beaucoup pour ton explication, je suis effectivement parti du principe que l'ADC de l'Arduino ne viendrait pas "polluer" le circuit et à priori ça fonctionne bien...

Pour le montage d'un condensateur en parallèle de l'alimentation, peux tu m'en dire un peu plus sur le montage de la diode?
Logged

France
Offline Offline
Faraday Member
**
Karma: 36
Posts: 3435
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

La diode c'est pour empêcher de vider le condensateur lorsque tu actives le démarreur. Il faut la brancher anode vers la batterie et cathode sur le condensateur.

Le problème c'est que le démarreur fait chuter la batterie à quelques volts pendant plusieurs secondes et il fa falloir un condensateur énorme (de l'ordre du farad) pour continuer à alimenter ton montage pendant ce temps là.
Il y a 2 solutions à ton problème:
1) tu oublies l'idée d'alimenter ton montage pendant le démarrage (solution la plus simple mais qui ne dispense pas de mettre quand même un condensateur pour te protéger d'autres perturbations moins violentes qu'un démarrage)
2) tu utilises non pas un condensateur mais une petite batterie. Évidemment c'est un peu plus volumineux. Il faut aussi dans ce cas placer une diode pour que ta seconde batterie ne soit pas sollicitée au démarrage.
« Last Edit: December 11, 2009, 12:08:11 pm by fdufnews » Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 61
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Le problème c'est que le démarreur fait chuter la batterie à quelques volts pendant plusieurs secondes et il fa falloir un condensateur énorme (de l'ordre du farad) pour continuer à alimenter ton montage pendant ce temps là.

sur de toi? il n'est pas possible de séparer l'alimentation de l'arduino du reste du montage est de n'assurer que cette alimentation? ça doit être alimentable quelque secondes facilement un arduino tout seul, non?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

En fait la chute de tension n'a pas lieu systématiquement et doit dépendre de la tension de la batterie en fait. A froid après une nuit de repos, j'ai une chute sous 6V de 300ms (mesuré avec ... un arduino smiley-grin). Par contre après avoir roulé, l'alternateur ayant chargé la batterie au maximum je ne descends qu'a 8V et l'arduino ne coupe pas.
D'après mes calculs en supposant qu'un arduino consomme 10mA, il me faudrait un condensateur de 470uF/16V.
J'ai commandé quelques condensateurs 1000uF/16V (je n'ai pas trouvé de valeur intermédiaire) et des diodes pour faire mes essais.
Logged

Pages: [1]   Go Up
Jump to: