Pages: [1]   Go Down
Author Topic: Demande de vérification d'un schéma  (Read 586 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

Après quelques temps de recherches, lectures de datasheet, etc. Je viens vers vous pour une vérification de mon schéma électronique.  smiley-wink

Avant de vous le présenter, je vous explique la philosophie du robot :
- J'utiliserai une carte Arduino pour mon robot. Pas de contraintes particulières, mais notez que l'alimentation est en 5V.
- Mon robot aura 2 moteurs pas-à-pas bipolaires qui me permettront d'avancer / reculer / tourner. Ces moteurs auront une tension d'alimentation de 12 V (le choix n'est pas encore défini... mais ils ne seront PAS de 5 V comme la carte Arduino)
- A priori, je n'ai aucun soucis pour brancher mes capteurs / actionneurs. Mais je voudrais une vérification pour mes moteurs pas-à-pas.
- les câbles sont inversées sur le 2ème L297 pour une histoire de sens des moteurs (n'oublions pas qu'ils sont inversés et que pour avancer dans un sens, ils doivent tourner en sens inverse).

Donc :
- J'aurai 2 types de batteries : 5 V pour l'arduino et capteurs et 12 V pour les moteurs pas-à-pas
- 2 moteurs pas-à-pas bipolaires implique 2 montages : un pour chaque moteur. Mais il faut les synchroniser.

Voici le schéma :


Mes questions :
1- Sur les masses, j'ai différencié celles pour la batterie 12 V et celles correspondant à la batterie 5 V : ai-je fait des erreurs ? Ai-je raison ?
2- J'ai relié les RESET car ça me semble plus logique : on reset tout ou rien. Pouvez vous me confirmer ?
3- Pour synchroniser mes L297, j'ai suivi la datasheet : je relie les SYNC et je relie OSC à la masse...
4- CONTROL est mis à 0 parceque, d'après ce que j'ai compris, cela permet de jouer sur le pont en H grâce à INH1 et INH2 et non pas sur les phases ABCD... ai-je raison ?

Enfin :
Ce montage vous semble-t-il judicieux ?  :-[

Je vous remercie de votre aide  smiley
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Petit oubli de ma part : il faut que je relie le HALF / FULL à la masse... pour fonctionner en pas normaux (et pas en demi).

J'ai aussi rajouté un potentiomètre à l'entrée de Vref pour éviter de griller le moteur !


« Last Edit: December 13, 2009, 01:36:16 pm by Glius » Logged

Sophia-Antipolis (06)
Offline Offline
God Member
*****
Karma: 4
Posts: 618
Rejoignez le club !
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Il faut relier les masses, et utiliser le châssis du robot pour cela, pas juste du câblage.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Il faut relier les masses, et utiliser le châssis du robot pour cela, pas juste du câblage.

Ok. J'avais un doute... mais si tu me dis qu'il faut mettre toutes les masses au même potentiel, je te crois.

Si je ne m'abuse, il faut aussi que je mette des condensateurs de découplages pour les sources de courant ! :-[
Logged

Pages: [1]   Go Up
Jump to: