Pages: [1]   Go Down
Author Topic: Sauvez des piles, utilisez une alim' de PC!  (Read 1860 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Full Member
***
Karma: 0
Posts: 104
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour, je viens partager une petite astuce, j'avais déja vu ça sur un autre site et aujourd'hui je me suis lancé!

j'ai utilisé une vieille alimentation de PC pour alimenter des actionneurs (moteurs, leds etc)

Une petite photo de l'alim avec toutes les fiches IDE, SATA etc enlevés, groupés par tension:



le code couleur pour ceux que ça intéresse:

Ceux groupés, on peut tirer de la puissance:
Noir: ground
orange: 3.3V
rouge: 5V
Jaune: 12V

fils uniques, limités en intensité:
bleu: -12V
blanc: -5V (perso j'en ai pas  smiley-sad )
vert: ON, le relier à un fil noir pour lancer l'alim
pourpre: +5 VSB (on peut mettre une LED entre celle-ci et le ground, c'est l'indication "standby")
gris: même principe que pourpre, indication "en fonctionnement"

Voilà si d'autres personnes ont des conseils moi jusqu'à maintenant ça fonctionne et rien n'a explosé 8-)!
Logged

J'apprends tous les jours!

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 90
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Petite question: utiliser directement le 5V de ce type d'alimentation pour alimenter un atmega standalone est-il sans danger pour le microcontroleur ?
Logged

0
Offline Offline
Full Member
***
Karma: 0
Posts: 104
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Je suis pas si calé que ça en électricité, donc ce que je vais dire est peut etre faux  :-X
Tout ce que je sais est qu'il est parfois nécessaire, pour que l'alim démarre, de rajouter une "charge" (pour moi c'est un moteur CC) sur le 5V car si il n'y a pas assez de courant consommé, soit l'alim ne démarre pas soit les tensions sont mal régulées (pour régler ce problème, sur ce site http://sites.google.com/site/lemondedefred/alim#fr ils mettaient directement une résistance de puissance; mais moi je n'en ai pas chez moi :smiley).


Donc mon raisonnement: (corriger si quelqu'un qui connait ce type d'alimentation passe par là) si on ajoute une charge, surtout comme un moteur qui va lisser le courant, la régulation interne de l'alim fonctionnera "de façon optimale" et on devrait pouvoir alimenter l'Atmega en direct.

Je pense que la régulation d'une alimentation de PC est assez efficace car elle sert à alimenter des composants très sensibles (processeurs etc) mais encore une fois, il faut une charge (sur un PC c'est apparemment réalisé par le disque dur)

voilà j'espère avoir été clair ^^

P.S.: cette alim ne me sert que pour l'expérimentation, ensuite je passe sous des solutions moins encombrantes, car niveau rendement il y a quand même franchement mieux.
Logged

J'apprends tous les jours!

Ales
Offline Offline
Faraday Member
**
Karma: 39
Posts: 3645
Do or DIY
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Aucun danger pour alimenter un atmega directement avec ce type d'alim. En revanche ce sont des alimentations à découpage : haut rendement mais moins stable qu'une alimentation stabilisée. Ce que je ne peux pas dire c'est si sur des applications simples cela se voit ... Concernant la résistance de charge, je pense plutôt que c'est pour contourner une sécurité interne de l'alim.
Logged


0
Offline Offline
Full Member
***
Karma: 0
Posts: 104
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Voilà une réponse directe ^^
le rendement au sens strict est bon, sauf que l'alim ne se met en route que si on a une charge suffisante. Si la charge n'est pas suffisante on doit en rajouter, ce qui fait baisser le rendement...  smiley-grin
Logged

J'apprends tous les jours!

0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Une Alim de PC recycler me sert d'alim fixe 5/12V sur mon bench
et comme mes vieux yeux demandent une bonne luminosité pour travailler

bin joindre l'utile à l'agréable
10 res de 22 Ohm
10 Led Haute lum qui tirent 100mA chaque
= 1Amp de charge sur le rail 5V

prix inférieur à la Res de 10 Ohm 10W

monté sur une règle ne plexi et roule

@++

branché sur le rail
Logged

Pages: [1]   Go Up
Jump to: