Go Down

Topic: Alimentation capteur avec alim externe (Read 759 times) previous topic - next topic

andromeda

Bonjour,

j'expose mon probleme, sur un topic en dessous de celui ci j'avais un probleme avec la librairie sdfatlib et les sdcard et au bout de deux jours en alimentant mon module sdcard sur les pin vcc et +5v du mega2560 ca a marche, j'avais remarquer ca aussi avec d'autres capteurs comme les modules srf04 mais j'avais passer outre en puisant sur l'alimentation de l'arduino.

Je voulais savoir si quelqu'un avais deja eu ce probleme ?

sinon ca voudrais dire que je ne peux plus alimenter en 5 v d'autres capteurs.

a moins que des sortie de pin mise a zero doivent utiliser la masse de l'alim du capteur.

Merci de votre aide.

Teiva

Dans le doute, tu as bien relié les 2 masses (gnd) de tes 2 alims ensemble ???

A+ Teiva


www.Zartronic.fr : Votre source Arduino en France


www.Zartronic.fr : Arduino & Robotique

andromeda

non car j'alimentait le module avec un bloc de pile a part et les pin spi je les connectais sur l'arduino.

mais je pense que ca devais venir de ca.

sinon le module sd card en lui meme est tres bien, je l'ai meme teste avec une carte sdhc de 8go panasonic ca marche impecable.

Teiva

Quote
mais je pense que ca devais venir de ca.

Oui c'est exactement ça, dans les montages il faut avoir une masse commune, relier les différentes Gnd (-) ensemble, sinon c'est plein de problèmes bizarres  ;)

A+ Teiva


www.Zartronic.fr : Votre source Arduino en France


www.Zartronic.fr : Arduino & Robotique

Go Up