Pages: 1 2 [3]   Go Down
Author Topic: utiliser un atmega sans arduino  (Read 3334 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Sr. Member
****
Karma: 0
Posts: 316
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

merci a toi mais je ne trouve pas mes LTC ni meme mes 74HC595
Logged


0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 59
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

Juste une question que je me pose, si sur une carte standalone on met 2 atmega, il faut mettre 2 Crystal 16 MHz ou ils peuvent se partager le même et donc un seul suffit ?  :-?

Merci

Mcmf

Logged

0
Offline Offline
Sr. Member
****
Karma: 0
Posts: 316
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

me semble que tu est pas dans le bon post mais bon ^^
que veut tu dire par une carte standalone ??
Logged


0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 59
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ce que je veux dire c'est :

si je souhaite utiliser 2 ATMEGA168 sans la carte Arduino, sur une carte que je conçois, dois-je mettre 2 Crystal 16 Mhz (1 pour chaque ATMEGA168) ou alors 1 seul suffit (il serait relié aux pins des 2 ATMEGA168) ?



Logged

0
Offline Offline
Sr. Member
****
Karma: 0
Posts: 316
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

je peut franchement pas te dire mais pourquoi as tu besoin de 2 atméga ?
Logged


0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 59
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Pour un test fait avec 2 cartes arduino qui communiquent donc 2 atmega.

Logged

0
Offline Offline
Sr. Member
****
Karma: 0
Posts: 316
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

je te dit ca en tant qu'amateur mais les 2 arduino peuvent avoir le même crystal enfin je pense
après vu le prix du crystal ca change pas grand chose si ten prends 2 ^^
Logged


0
Offline Offline
Sr. Member
****
Karma: 0
Posts: 316
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

je suis de retour ^^
j'ai tout recu et j'ai fait tout mes circuits
par contre je bloque au niveau du code
je lit les données via les 74HC595 et j'execute le code via les TLC5940 avec une transmission sans fils ( liaison série ) entre les deux
mais deux question me viennent a l'esprit
je doit traité les infos des potars de quel cotés
j'envoie la valeur des potars sur l'autre arduino et la je traite pour faire bougé les servo en consequence ou sinon je traite la valeur des potars et j'envoie la valeur sur l'autre arduino qui envoie au servo ?
grande question ^^
ensuite tu ma donné du code mais je n'arrive pas a le séparé
c'est a dire qu'il me faudrait deux code l'un pour lire les infos des potars et l'autre pour envoyé les infos au servo avec entre les deux une liaison série
et la je voit vraiment pas
pour lire les valeurs des potars pas de soucis
pour envoyé au servo pas de soucis
ce qui me pose vraiment un probleme c'est comment envoyé toutes les infos via une liaison série et comment les lire de l'autre cotés
j'ai regardé la librairies sérial mais j'arrive vraiment pas a savoir quoi mettre
une idée ?
merci
Logged


Pages: 1 2 [3]   Go Up
Jump to: