Go Down

Topic: Comportamento anomalo (Read 4451 times) previous topic - next topic

andrea80

Non appena collego arduino alla porta USB comincia a lampeggiare L ininterrotamentee non smette più!
Faccio di tutto ma il problema persiste!!!!!!
Che si fa?!?

Andrea

Federico

Ma che cos'e' che lampeggia? Quale led?
Federico - Sideralis
Arduino &C: http://www.sideralis.org
Foto: http://blackman.amicofigo.com

andrea80


Federico

Non e' che c'e' caricato su lo sketch blinkled? Se carichi altri sketch cosa fa?
Federico - Sideralis
Arduino &C: http://www.sideralis.org
Foto: http://blackman.amicofigo.com

andrea80

Sempre la stessa cosa..:-(

uccio

ma riesci a caricarne altri di sketch?

andrea80

Qualsiasi skect carichi ottengo ora questi errori:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

quindi come se ci fossere impostsazioni sbagliate.
La board è impostata giusta, mentre come bootloader cosa metto?

uccio

sei sicuro che in tools-> board sia impostata la tua board?
per il bootloader se NON sbaglio l'uno vale l'altro

andrea80


garinus

prova a tener resettato qundo inizi a caricare un nuovo sketch


andrea80


andrea80

Code: [Select]
int Led = 12;
int value =LOW;

int Csharp;
#include <avr/io.h>
#include <avr/wdt.h>

#define Reset_AVR() wdt_enable(WDTO_30MS); while(1) {}

void setup() {
 Reset_AVR();

 Serial.begin(9600); // opens serial port, sets data rate to 9600 bps
 pinMode(Led, OUTPUT);
}

void loop() {

 if (Serial.available() > 0) {

   Csharp = Serial.read();

   Serial.println(Csharp, DEC);




     if (value == LOW) value = HIGH;
     else value = LOW;

     digitalWrite(Led, value);}


 }



Ecco con questo semplice codice ho combinato il pasticcio : Il pin 13 da quando ho caricato questo sketch lampeggia all'impazzata....!
Cosa c'è che non va?!?
L'obiettivo di questo codice è resettare arduino da software in modo tale da non premere ogni volta che ricollego l'apparecchio al PC il tasto reset sulla scheda.

Grazie in anticipo

garinus

#13
Jun 03, 2009, 09:25 pm Last Edit: Jun 03, 2009, 09:26 pm by garinus Reason: 1
forse sbaglio ma il comando nel setup non resetta ad ogni accensione facendo un cilco continuo?

andrea80

Si è vero! Quale sarebbe la soluzione più idonea?!

Go Up