Pages: 1 2 [3]   Go Down
Author Topic: Problema  con sistema di accensione spegnimento  (Read 1525 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 50
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ho provato ad implementare l'idea del pmos come interruttore ed ho qualche problema.


Ricapitolando: ho la batteria, una cella al litio, ed il circuito utilizzatore. Ho interposto un pmos http://www.fairchildsemi.com/ds/FD/FDN304P.pdf tra questi due collegando il source alla batteria e il drain al carico. Secondo le mie simulazioni se do 0-Vth V al gate allora il mosfet è in conduzione mentre tra Vth-Vmax è spento. Ho modificato il circuito ed aggiunto il pmos ma non funziona, non si spegne mai ed ho una inspiegabile caduta di tensione di 0.5V quando dovrebbe essere spento e funziona bene quando dovrebbe essere acceso. Guardando il datasheet noto la presenza di un diodo che ha l'anodo al drain e catodo al souce quindi quando il transistor è spento non dovrebbe condurre e invece lo fa. Cosa sbaglio?
Logged

cuneo
Offline Offline
God Member
*****
Karma: 3
Posts: 785
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

non che devi invertire source e drain?
o hai colegato polarità invertite?
« Last Edit: June 25, 2010, 09:32:46 am by garinus » Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 50
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No, se invertissi avrei una corrente di drain Id positiva mentre i pmos prevedono una Id negativa. I collegamenti li ho fatto bene. Sembra che il diodo interno sia messo al contrario di quanto segnato nel datasheet.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 50
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Mi basterebbe anche un idea o domanda su cui indagare. Perché un pmos che dovrebbe essere spento conduce? Nel frattempo ho indagato sui mosfet e da nessuna parte ho lretto che il diodo formato da substrato drain sia di tipo zener.
Logged

cuneo
Offline Offline
God Member
*****
Karma: 3
Posts: 785
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

appunto sembra che tu abbia il diodo in conduzione che fa sì che abbia una caduta di circa mezzo volt
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 50
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Però quando abbasso la tensione di gate e lo mando in conduzione la tensione Vds è circa 0. Il diodo nel datasheet è messo in modo che sia sempre interdetto.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 50
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Possibile che sia sbagliato il datasheet?
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 50
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Funziona. Avevo interposto il mos tra batteria e carico interrompendo una pista, evidentemente la pista l'ho tagliata male.
Logged

Pages: 1 2 [3]   Go Up
Jump to: