Go Down

Topic: PIR sensor e PC (Read 2970 times) previous topic - next topic

f.schiano

Nono, il codice che ho postato io funziona quasi sicuramente...in quanto se vedi sul datasheet c'è scritto che il bit ALARM è normalmente alto (=1)...mentre quando rileva un movimento diventa basso !!!

fammi sapere se hai altri problemi... :I ciaooooo
L'impossibile...richiede solo piu' tempo!

Jeeg

Ciao f.Schiano,
grazie per le info... stasera riprovo e ti dico; Solo una domanda: Ma quando provi il PIR con il programma da te scritto, il LED si accende solo se passi per esempo una mano davanti? Il mio rimaneva sempre acceso... Oh è troppo sensibile o qualcosa non quaglia:(

GRazie!!!

cesco

in questo esempio :
http://www.arduino.cc/playground/Code/PIRsense

il codice è scritto al contrario. ovvero quando c'è un movimento va in HIGH ...

Usano un PIR della Parallax

Hai provato ad invertire il codice? ...

f.schiano

Quote
Ciao a tutti,
anch'io ho fatto lo stesso programma con gli stessi componenti (Arduino 2009 + PIR uguale a quello postato) ma una volta caricato il programma si accende il LED e non si spegne più anche se non c'è nulla che si muove. Dove sbaglio? I collegamenti di quel sensore sono come in figura 3: Marrone al centro, Rosso e Nero. Il rosso è il + il nero è il GND e il marrone il cavo dati. Corretto???
Grazie a tutti!


Lui ha detto che il sensore è uguale al mio ...quindi dovrebbe funzionare così, ma provare non costa nulla, anzi...prova e vedi cosa succede!

ma....facci sapere!!!
L'impossibile...richiede solo piu' tempo!

Jeeg

Ciao,

scusate ma ieri non sono riuscito a testare ma stasera sicuramente provo. No non è dlla Parallax ma è uguale a quello postato da f.schiano. L'ho preso on-line da futura!

f.schiano

Oggi stavo provando il sensore per altri motivi e ho riscontrato un problema...se lo collego al pin 13 non mi funziona, se lo collego al pin 7 funziona...

tienine conto e fammi sapere...

p.s. non sono ancora riuscito a capire il perchè, se ho qualche novità ti faccio sapere!
L'impossibile...richiede solo piu' tempo!

Testato

ricordate che al pin 13 c'e' il led e la resistenza onboard
- [Guida] IDE - http://goo.gl/ln6glr
- [Lib] ST7032i LCD I2C - http://goo.gl/GNojT6
- [Lib] PCF8574+HD44780 LCD I2C - http://goo.gl/r7CstH

Jeeg

Ciao a tutti!!!
Ho riprovato! Però non mi convince molto il funzionamento di questo PIR: Il LED si accende e spegne secondo me indipendentemente dai movimenti percepiti. Mi spiego meglio: Se passo una mano davanti al sensore il LED non sempre si accende. Se tutto è fermo capita che il LED si accende. Ho la sensazione che questo sensre abbia dei problemi! Non è che avete un piccolo filmatino per capire come dovrebbe funzionare? Per vedere come funziona il vostro?
Grazie

jonnylike

Visto che ho un problema di instabilità della lettura del PIR volevo chiedere se qualcuno ha qualche consiglio da darmi.
Ho controllato che tutto sia correttamente collegato e come sketck ho
provato quello disponibile in rete ma praticamente ho lo stesso problema descritto da Jeeg

f.schiano

Postate il codice... E i collegamenti precisi...!!!
L'impossibile...richiede solo piu' tempo!

Go Up