Go Down

Topic: pin 7, 8 e 9 che non funzionano in PWM... ma perch (Read 733 times) previous topic - next topic

Paolo S

Oct 08, 2010, 04:35 pm Last Edit: Oct 08, 2010, 04:50 pm by paolosanna Reason: 1
Saluti a tutti ....
.. sull'arduino Uno il pin 9 è marcato con il segnetto di una onda, quindi credo intenda che si tratti di un'uscita analogica PWM... ma niente... cè qualcosa che mi sfugge ??... cioe attivandolo come uscita PWM non funge. ... lo schetc va tutto bene sugli altri pin, su quelli analogici vedo esattamente la gradualità dell'uscita, su quelli digitali vedo il salto brusco da alto a basso e viceversa... sul pin 9 niente. non funziona come PWM ma solo come digitale.

cosè che mi sfugge?

Grazie

cesco

hai l'Arduino Uno?

io ho lo stesso problema con quella.


Federico Vanzati

F

lesto

#3
Oct 09, 2010, 01:10 am Last Edit: Oct 09, 2010, 01:13 am by lestofante Reason: 1
è un bug noto, non ho capito se risolto con la 0021 e se bisogna uppare il nuovo bootloader...

http://code.google.com/p/optiboot/issues/list

edit: ho dato un'occhiata al link di Federico Vanzati, in pratica la cosa è spiegata meglio... e dai commenti il problema non è ancora stato risolto
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

uwefed

Ciao a tutti
Non ha capito se si parla solo del pin 9 o come come nel titolo dei Pin 7,8 e 9.

I pin 7 e 8 hanno la funzionalitá PWM perché non previsto;

Nella pagina: http://arduino.cc/en/Main/ReleaseNotes
é scritto riguardante la versione IDE 0021:

* Fixing analogWrite() bug on pins 9 and 10 (Arduino Uno).

Non so come interpretare questo; se vale solo per l'Arduino UNO e non per i modelli piú vecchi oppure l'hanno scritto per differenziarlo rispetto i mega.

Ciao Uwe



Paolo S

#5
Oct 11, 2010, 08:06 am Last Edit: Oct 11, 2010, 08:07 am by paolosanna Reason: 1
Grazie per le risposte... mi sono potuto collegare solo adesso.. mi leggerò i vs link.. grazie ... comunque io sto usando l'IDE 020.. ..

Paolo S

Ho capito che cè un bug...  .. non sò se il problema è software o hardware, intanto usiamo gli altri....

uwefed


Go Up