Pages: [1]   Go Down
Author Topic: Bruciato il chip FDTI?  (Read 1493 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 13
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salve, sto usando l'Arduino Duemilanove da un po' e finora non avevo avuto nessun problema. L'altra sera invece attaccandolo alla presa USB per programmarlo, il computer non lo vedeva più, come non fosse attaccato niente (ho provato sia sotto Linux con dmesg che non dava nessun segno di connessione di una periferica su USB, sia sotto Windows, con lo stesso risultato). Miei amici che lavorano nel campo dell'elettronica mi hanno detto che probabilmente è saltato il chip FDTI, perchè poi l'Arduino in se funziona, l'ultimo sketch che avevo programmato e che si trova sul ATMega328 è ancora funzionante.
Volevo sapere da qualcuno con più esperienza se il non funzionamento del FDTI è una cosa che succede spesso o ci sono cose particolari che lo possono causare. Lo chiedo perchè avrei intenzione di ricomprare una scheda Arduino, ma non vorrei che il guasto fosse per causa mia e che quindi possa distruggere anche quello nuovo. IL sospetto che la colpa sia mia è dovuto al fatto che quando ha smesso di funzionare avevo montato sull'Arduino una shield, la Voice Box della Sparkfun e forse ho combinato qualche pasticcio. In realtà l'unica cosa "particolare" che ho fatto è stata di saldare delle strip sulla Voice Box per poterla montare, ma ho controllato tutti i contatti per vedere se non avevo cortocircuitato qualcosa e mi sembra sia tutto a posto.
Logged

BZ (I)
Offline Offline
Brattain Member
*****
Karma: 251
Posts: 21252
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Non credo che sia bruciato il FDTI;
Fai le prove senza scheda aggiuntiva col Arduino nudo.
Quando attachi il cavo USB si accendono brevemente il led TX e RX in contemporanea?
Cambia il cavo USB;
Ciao Uwe
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 13
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ho già fatto le prove con Arduino senza attaccato niente e ho anche usato un altro cavo USB: quando lo attacco si accende solo il led dell'alimentazione e brevemente anche quello del reset, ma nè il led Tx nè l'Rx si accendono e dmesg non evidenzia nessun messaggio del kernel.
Quindi è un evento raro che smetta di funzionare il FDTI?
Logged

Torino, Italy
Offline Offline
Sr. Member
****
Karma: 2
Posts: 309
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Mah, se mandi in corto prendendo voltaggio dal 3.3v penso proprio tu possa bruciare l'FTDI.

A me era successo di mandarlo in corto e dopo pochi secondi il chip era rovente.. fortuna che me ne accorsi e non si danneggio'.. pero' secondo me si puo' bruciare eccome!

Qui il post di qualcuno che l'ha bruciato ed e' anche riuscito a sostituirlo!

Devi pero' essere certo che sia quello il problema: rimuovi tutti i fili, shield, etc dall'arduino e collegalo al pc.. se non va prova con un'altro pc.. se ancora non va.. beh... allora mi sa proprio che si e' bruciato!
« Last Edit: December 17, 2010, 07:10:37 pm by fax8 » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 13
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Si, ho provato l'Arduino "nudo" anche su un altro PC su cui solitamente andava e il risultato è lo stesso, non viene rilevato dal SO e le luci di Tx e Rx non si accendono. Io non ho sentito nessuna puzza di bruciato e non riesco a capire come possa averlo messo in corto circuito semplicemente attaccandoci sopra il Voice Box ed è questa la cosa che più mi preoccupa, perchè non vorrei ripetere il problema sull'arduino nuovo che ordinerò. Ho visto il post che hai indicato e potrebbe essere un problema simile al mio, solo che nel suo caso le luci tx e rx rimaneva accese, mentre nel mio sono spente.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 13
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Dopo il post di Fabio mi è tornato in mente che la settimana scorsa in effetti avevo inavvertitamente cortocircuitato i 5V dell'Arduino con terra (noi pivelli usiamo dei fili volanti che poi a volte si toccano :-), quindi forse potrebbe essere quello ciò che ha bruciato l'FTDI, anche se in effetti è stata questione di pochi secondi. Inoltre a un mio amico è successa una cosa simile ma lui non ha riportato danni: può essere dovuto che l'Arduino era attaccato a un alimentatore USB esterno e non al computer?
Infine, ho letto qua
http://www.arduino.cc/playground/Main/FTDI
che l'FDTI potrebbe aver cancellato la EEPROM: vi sembra compatibile con la mia situazione e se sì posso provare a fare quanto indicato in quell'articolo senza fare ulteriori danni?
Logged

Torino, Italy
Offline Offline
Sr. Member
****
Karma: 2
Posts: 309
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Dopo averlo cortocircuitato funzionava o da li ha cominciato a non funzionare piu'?

Non ho mai sentito questo problema del cancellamento della EEPROM.. quindi non posso aiutarti su quello.
Logged

Torino, Italy
Offline Offline
Sr. Member
****
Karma: 2
Posts: 309
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Qui c'e' qualcun'altro con i led sempre accesi: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1283175287/0

Danno anche consigli su come verificare che FTDI e' bruciato.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 13
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Dopo averlo cortoicircuitato io ho solo provato a testarlo su un programma che era già caricato, quindi in quel senso funzionava, mi sono accorto del problema dell'FTDI solo qualche giorno dopo quando ho provato a riprogrammarlo.
Grazie per il link, ho letto e ho provato a misurare la tensione sull'uscita a 3.3 e mi misura 5 V, è un segno che è bruciato? se sì qualcuno sa perchè?
Logged

Torino, Italy
Offline Offline
Sr. Member
****
Karma: 2
Posts: 309
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Beh sicuramente non e' un bel segno!!! Pero' non so dirti se questo e' sicuramente un sintomo di un chip bruciato.. potresti provare a postare sul forum inglese, magari li c'e' qualcuno che ha avuto una esperienza simile.. In bocca al lupo.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 13
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Grazie, farò come dici.
Logged

BZ (I)
Offline Offline
Brattain Member
*****
Karma: 251
Posts: 21252
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Il ftdi ha uno stabilizzatore 3,3 V integrato che puó dare fino a 50mA. Se leggi 5V vuol dire che quello é rotto.
Hai provato di toccare il FTDI? diventa caldo?
Ciao Uwe
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 13
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ho provato per 5 minuti ma non si scalda, dovrei tenerlo attaccato di più?
Sul forum inglese mi hanno consigliato o di staccare il FTDI e sostituirlo, ma non penso di essere in grado, non l'ho mai fatto e tutti quei piedini così vicini mi mettono un po' di panico :-), oppure di tagliare il pin da cui prende la 5V per evitare che lui succhi corrente inutilmente. Quest'ultima proposta mi sembra più ragionevole, solo che non so bene dove tagliare: dallo schema del Duemilanove penso di dover tagliare il pin 17, ma se anche fosse quello dove taglio e con cosa (scusate la mia ignoranza)?
Logged

Forum Administrator
Torino, Italia
Offline Offline
Sr. Member
*****
Karma: 4
Posts: 386
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ciao alekos.
Ti consiglio di fare riferimento al rivenditore a cui hai comprato l'arduino, spiegandogli la situazione. Mi sembra che il problema sia l'FTDI.

ciao davide
Logged

Pages: [1]   Go Up
Jump to: