Go Down

Topic: serial port already in use - out of the blue (Read 3138 times) previous topic - next topic


I've been working with my arduino for a few weeks, and all of a sudden I'm getting "Serial port 'dev/cu.usbserial-A700063cV' already in use. Try quitting any programs that may be using it."

Obviously, I've quit every program and done everything I can think of to make sure nothing else could be using the same port, but nothing works. I've tested the arduino on another mac and it works fine, and I've created a new user account on my mac, and I get the same issue.

Thoughts? Any way to check in the terminal to see what could be blocking it?

Thanks in advance....


I know this is a PC type solution and you have a Mac but try un-installing the USB / serial driver and then re installing it and re booting.


Each serial device has two device special files - /dev/tty.whatever and /dev/cu.whatever.  This is two different ways for accessing the same port.  Make sure you aren't accidentally accessing the /dev/tty.* version from elsewhere.

Sometimes the network subsystem tries to grab serial ports, under the (old) assumption it is a modem.  That shouldn't happen without actually entering the network systems settings utility.

Are there lock files anywhere?  I don't recall...

I'm sure by this point you have tried the obligatory reboot to make sure any program that was using the port but went off into the bushes has been well and truly terminated.



Same problem for me here :(

busy usb port, I searched through the whole forum, installed and uninstalled the FTDI driver. But with no luck.

It did work until this morning: since then arduino program keeps giving the same error message:Serial port 'dev/cu.usbserial-A4001aGv' already in use. Try quitting any programs that may be using it."

So i am not able to communicate with the Arduino anymore. What am i doing wrong? Some help would be great.

I have an intel mac. v. 10.5.4
Arduino NG ATMEGA8
FTDI driver version 2.2.9 (i also tried it with 2.2.10)
Arduino 12


By reinstalling the system OS I managed to clear the usb/serial busy - thing. But there needs to be another solution for this... does it?



On a Mac I would run the "Activity Monitor" and close down applications and processes until the port came free.

You can do the same on a PC with task manager.


I am pretty sure that this is related to the rxtx library.

At one point I had to create a lock directory for rxtx (/var/lock, I think) because rxtx was looking for its lockfile there instead of wherever OSX normally puts it.

Robert Carpenter
(my hackery - http://robertcarpenter.net )


Thanks everyone for the replies, but amazingly I still haven't been able to fix this. I figured a reinstall of the OS would work (good call Wimbur), but I'm really trying to avoid that if possible.

Robacarp, I'm up for trying the rxtx idea, but I'm a bit beginner with terminal stuff though. Do you mind quickly writing out how to create that directory? Thanks in advance.


I would check that you don't have any copies of the RXTX library in any of your Java extension folders.


Yes, that last suggestion was exactly right. I had the same problem, and had just been trying to get Exemplar to run on my Mac. It required putting RXTX in the Java extensions. Once it was moved out, problem disappeared (Although I haven't gotten Exemplar to run - anyone else have any luck on OS X?)



I would check that you don't have any copies of the RXTX library in any of your Java extension folders.

And how do you do that, as im having the same trouble  :'(

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131