Go Down

Topic: Alimentare relays esternamente ad arduino (Read 1 time) previous topic - next topic

dr4gone

Jan 23, 2011, 08:28 am Last Edit: Jan 23, 2011, 08:32 am by dr4gone Reason: 1
Ciao ho la necessità di almentare 3 relays 5v con stadio pilota, che si trovano a 50 metri da arduino. Avevo pensato di alimentarli con un alimentatore universale che gia possiedo.

è un alimentatore mutitensione 1,5 - 3 - 4,5 - 6 - 9 - 12 , credo non stabilizzato. Ho provato a collegarlo alla batteria di relays selezionando prima una tensione di 4.5 e poi di 6 , la tensione arriva a ciascun relay, ma questi ultimi non scattano...

Quindi penso che sia perchè la tensione non è stabilizzata !?
A tal proposito ho cercato qualcosina su come fare a utilizzare sempre lo stesso aliementatore e a stabilizzare la tensione, e ho trovato http://www.gioblu.com/tutorials/elettronica/149-i-regolatori-di-tensione-lineari-serie-78xx-79xx questo.
Se ho capito bene basta questo circuitino con un LM7805 e 4 condensatori per risolvere la stabilizzazione...

Ma poi leggendo sino alla fine c'è stato un passaggio che mi ha fatto riflettere.

Cito: "In ultimo un piccolo consiglio... Non dimenticate di collegare la massa del nostro alimentatore autocostruito con quella di arduino, altrimenti quello che alimentiamo a parte rispetto ad arduino, non funzionerà."

A questo punto la mia domanda è: per far funzionare questi benedetti relays,  sono costretto a fare lo stabilizzatore di tensione o basta che collego la massa dell'alimentazione e la massa di arduino insieme?

Grazie e scusate la prolissità  ;)

P.S. I relays collegati direttamente ai 5v e gnd di arduino funzionanno alla grande...

Ciao dr4gone, faccio fatica a comprendere, ci provo.
Quote
Ciao ho la necessità di almentare 3 relays 5v con stadio pilota, che si trovano a 50 metri da arduino.


I relè con stadio pilota cosa sono?
Forse si tratta di una scheda relè con su montato anche un integrato il quale alimenta le bobbine dei relè.
Se è così già fornendo tensione alla scheda è al pin di controllo, il relè dovrebbe commutare, se non funge allora la scheda o il trasformatore non funzionano o ppure non è adatta la tensione che esce dall'alimentatore. Io direi che prima devi far funzionare la scheda relè senza arduino.

Quote
A questo punto la mia domanda è: per far funzionare questi benedetti relays,  sono costretto a fare lo stabilizzatore di tensione o basta che collego la massa dell'alimentazione e la massa di arduino insieme?


Le masse le devi collegare sempre, allora sono 3 relè quindi 3 fili lunghi 50 metri più uno di massa totale devi passare 4 fili. L'alimentatore devi comunque usarlo e metterlo nelle vicinanze della scheda relè.

La stabbilizzazione della tensione potrebbe non essere importante per le prove iniziali, una volta accertato che tutto funziona allora aggiungi uno stabilizzatore con 7805.

Ciao.


AvrDudeQui front end per avrdude https://gitorious.org/avrdudequi/pages/Home

dr4gone

#2
Jan 23, 2011, 09:45 am Last Edit: Jan 23, 2011, 09:47 am by dr4gone Reason: 1
ok..

Per relay con stadio pilota intendo proprio guidati da un transistor..

Dato che i relays quando sono alimentati direttamente da arduino funzionano bene, e che l'alimentatore no nstabilizzato con altri apparecchi funziona bene, direi che il problema è altrove.

Quindi sono propenso a pensare che sia perchè non ho collegato la massa di arduino alla massa dei relè, ma avevo collegato quest'ultima solo al gnd dell'alimentatore.

Per quanto riguarda i 4 cavi non ti ho capito... Secondo me basta solo uno che parte da arduino per la massa, e poi i 3 di segnale che servono per pilotare i relays.

Tu intendevi questo?

Cmq provo tra un po.

Quote
Tu intendevi questo?

Esattamente.
AvrDudeQui front end per avrdude https://gitorious.org/avrdudequi/pages/Home

dr4gone

Ok. Ho appena provato.
Come sospettavo il problema  era la massa che non collegavo su arduino.
Grazie.
Ciao

Go Up