Go Down

Topic: Centrale Antifurto (Read 17 times) previous topic - next topic

sgorghigolo

#29
Jan 19, 2011, 01:49 pm Last Edit: Jan 19, 2011, 01:54 pm by sgorghigolo Reason: 1
salve a tutti!
Mi intrometto anche io nella discussione perché è da un po' di tempo che ho in mente un progetto di questo tipo. In particolare quello che mi interessa è l'interfaccia GSM.

In rete l'oggetto più interessante che ho trovato, sia per il prezzo che per la semplicità di uso (apparentemente) è questo:
http://www.tekkna.it/product/23233/-MODEM-GSM-CON-MODULO-TC35-E-RS232.asp
Nel modulo indicato è installato su una board aggiuntiva che provvede ad alcune funzioni:  alimenta il modulo, accende il modulo, registra la SIM alla nerwork GSM, ed adatta i livelli elettrici per poter pilotare i moduli anche da un PC.
Quindi a quanto pare questo modulo è già predisposto per essere pilotato da una porta seriale RS232 tramite i comandi AT.

A quel che ho capito leggendo la documentazione di arduino, la comunicazione seriale di cui dispone usa livelli elettrici diversi rispetto la lo standard RS232.  

la mia domanda è: secondo voi è possibile usare interfacciarsi a questo modulo GSM con arduino?devo mettere un interfaccia tra arduino e il modulo (ad esempio realizzata con max232)???

Giuseppe G.

Per luigitessitore.

Ciao luigitessitore!

Ok! Attendo con ansia il post del tuo progetto. :-X

Io, intanto gioco un pò con il mio, dedicandomi se riesco ad utilizzare il GSM.

PS.: Solo un info.
Il protocollo, è utile per poter inserire i comandi corretti del telefono nel cip arduino! Se riesco a mettere in comunicazione il PC con il telefono, ho bisogno di sapere cosa devo fare e in che modo! :-/
Bisognerebbe essere svincolati dal modello di GSM, ma comunque, per iniziare và più che bene.

Posterò nei prossimi giorni un elenco dettagliato delle funzioni della centrale.
Gradirei, se non ti dispiace, avere un elenco, anche spartano, della tua, in maniera da non sovrapporre le cose ed eventualmente confrontare le idee.

Un saluto anche a te! ;D
Un saluto a tutta la comunità.
Giuseppe G.

Giuseppe G.

Caio angelo1950. :)

Ho una domanda da farti!
Hai inserito un  condensatore da 100nF in poliestere in parallelo all'ingresso? >:(
Se utilizzi un cavo schermato, collegando lo schermo a massa elettronica (GND) di arduino, riduci del 50% il problema dei disturbi. ;)

Per filtrare correttamente un segnale a + 5V senza schermarlo, devi usare degli optoisolatori, altrimenti, prova con un filtro RC passa basso con i relativi diodi di protezione per le extra tensioni (probabile causa del blocco di arduino). ::)

Se riesci, e se non ti dispiace, mandami lo schema del circuito di ingresso che hai utilizzato, vedrò cosa si può inserire come filtro, senza dover sostituire i cavi!

Bye :D
Un saluto a tutta la comunità.
Giuseppe G.

Luigi Tessitore

Per Giuseppe:

tu parli di protocollo, ma credo (al 90%) che tu possa dialogare con il Siemens come un normale modem, cioè con un set di comandi AT.
Se cerchi un pò anche in questo forum trovi il link del datasheet ufficiale con tanto di comandi.
Per il cavo, sinceramente credo che occorra il MAX232 anche solo per parlare con il Pc. Ad ogni modo esistono cavetti già fatti (almeno come primo test) che ti consentono di prendere dimestichezza con la "bestia".
Poi, una volta selezionato il set di comandi giusti, occorrerà portarli su Ardy.
Per quanto riguarda la lista che hai stilato credo sia troppo presto per parlare di dimensioni e/o feature troppo evolute: diamoci degli step e cerchiamo di rendere il codice più scalabile possibile.
D'accordo ad avere una "repository" comune: potrebbe essere anche buono accedere al playground.
Ripeto: il mio codice (che presto posterò) è funzionante al 80%.. ma le basi credo siano decenti.
Saluti.

angelo1950

#25
Jan 16, 2011, 09:32 pm Last Edit: Jan 16, 2011, 09:34 pm by angelo50 Reason: 1
ciao Giuseppe,
grazie per la risposta.
ti spiego il mio problema, ho assemblato un paio di arduino mettendo gli ingressi analogici chiusi al +5 con resistenza da 10K per tenerli stabili, gli ingressi analogici chiusi a massa sempre con la stessa resistenza e li chiudo con un pulsante NO sul +5. ad ogni ingresso mi chiude un'uscita che pilota i relè dopo lo stadio amplificatore.
il tutto funziona ma..... ogni tanto si blocca arduino e devo resettare.
premetto che i cavi che vanno ai pulsanti passano nello stesso cavidotto dei  cavi di porenza, pensi che basti metterli separati e magari  usando cavi schermati risolvo il problema?
grazia per la risposta

Go Up