Pages: [1]   Go Down
Author Topic: Does Morse library tutorial code work with 0018?  (Read 431 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am new to arduino development, and wanted to try the custom library tutorial out.

I am using the latest Ubuntu distribution and developing for the Duemilanove board.

I downloaded the .zip file which has the Morse directory structure in it and placed it in ~/arduino-0018/libraries/ directory.  The instructions were a bit vague on exactly where to put it, but this made the most sense to me, since the other libraries like Servo, Ethernet, etc were there.

The problem is that when I try the very first thing to use the library, I.E. #include <Morse.h> in global section of an otherwise working sketch, I get the No such file or directory error.

This seems to be an issue with the IDE, which according to the update log should work with custom libraries now.

What am I doing wrong?

Thanks,

-NoWorries
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Whoops.  That tutorial is a out-of-date.  I'll update it now.

You should put the Morse folder inside of a "libraries" folder inside your Arduino sketchbook folder (the location of which you can find / set in the preferences dialog).  You'll need to create the "libraries" folder if you haven't already.  I just tried it and the SOS example seems to work.  Let me know if you have problems.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes, that made it work.   smiley

Thanks,

-NoWorries
Logged

Pages: [1]   Go Up
Jump to: