Go Down

Topic: Arduino + Asus EEEPC works (Read 5512 times) previous topic - next topic

OK, I solved my own problem. Apparently the 2G Surf doesn't come with Java installed, and apparently Processing brings it's own Java along when you install it. This is why Processing Worked but Arduino didn't.  I followed these instructions fromm an eeepc forum: http://forum.eeeuser.com/viewtopic.php?pid=152939

Quote

I have just checked this link does work http://code.google.com/p/pimpmyeee/.

The download is very quick though and it may appear as if nothing has happened. Check your /home/user/ folder.

Once you have the repositories set up once, installing most programs is a doddle.

Here are ALL the hoops you have to jump through:

1.  Download pimpmyeee.sh to /home/user/
2.  Press Ctrl+Alt+t
3.  Type sh pimpmyeee-1.0.2.sh
4.  Press [ENTER]
5.  Press R
6.  Press [ENTER]
7.  Press q
8.  Press [ENTER]
9.  Type sudo apt-get install xandros-sun-j2re1.5
10. Press [ENTER]

OK, I still need help. I can get Arduino and Processing both working, but I just don't seem to have enough space to fit Java, Arduino, and Processing. I tried to remove some packages I wasn't going to use (like Chinese support for Open Office) but removing the packages didn't seem to free up any space. I removed well over 100MB of stuff, but no space has become available.

Any thoughts?

Thanks.


nathanxl

Hello. Im a noob with my 701 eeepc (although Ive owned it for years) and a COMPLETE noob with Arduino.
I have a Duemila that I so want to start playing around with but have run into a problem that I think is java issue.

I can write and save the Blinking LED sketch (from the book Getting Started with Arduino) but am unable to upload the sketch to the Arduino.
I get this message when I try to upload:

java.io.IOException: avr-gcc: not found


Please help.
N



Andrew

Have you followed the steps in the wiki page mentioned in reply #6?

http://www.arduino.cc/playground/Linux/Xandros

Andrew

nathanxl

I tried but I cant even get passed the first step of changing the lists. I get this message:

bash: /etc/apt/sources.list: Permission denied

Please help.
N

Andrew

Are you typing the command exactly as shown, including the "sudo" bit? That gives you root permissions so you should be able to move the file.

Code: [Select]
 sudo mv /etc/apt/sources.list /etc/apt/sources.list.backup

Andrew

nathanxl

#21
Jul 08, 2010, 07:44 pm Last Edit: Jul 08, 2010, 08:26 pm by nathanxl Reason: 1
Thanks Andrew.
Is there a space after "mv" and the first "list" ? If there are spaces then I have typed it in correctly.
The permission denied message only came up after typing the second line:

sudo echo "deb http://www.uk.debian.org/debian stable main contrib non-free" > /etc/apt/sources.list

Ive tried it 3more times and now another message comes up

mv: cannot stat '/etc/apt/sources.list': No such file or directory

after typing the first line when before i was able to type the second line without a message coming up until after the second line.

Im double checking and Im typing it all correct.
Im trying to upload a screenshot of the terminal window in this reply but I cant seem to.
Am I useless or is my machine not cooperating?

Can anyone help me?

ps. Ive just done an F9 restore and updated BIOS but I still get the same message:

mv: cannot stat '/etc/apt/sources.list': No such file or directory

after typing the first line in step one.


Lost.

Andrew

If you do a

Code: [Select]
ls   /etc/apt

Do you see a "sources.list.backup" file?

If so, the first command has worked and you can move on to the second one, the "sudo echo" command to create a new "sources.list" file.

Andrew

nathanxl

Thanks.
I did the:
ls /etc/apt
and

apt.conf.d/ sources.list.backup trustdb.gpg trusted.gpg"
secring.gpg sources.list.d/      trusted.gpg

Is all OK here?
I type the second line and I get the message as before previous:

bash: /etc/apt/sources.list: Permission denied

Appreciative but confused

Nathan

Andrew

Ok, the first command has worked, making a backup copy of your sources.list file. Now we need to create a new one with the source of the gcc installation files in it. I've added some extra spaces below to make it clearer where they go - any extra spaces where shown won't hurt anything. There are also spaces after "deb", "debian", "stable", "main" and "contrib". And don't forget the "sudo" at the beginning so the command is run as root.
Code: [Select]
sudo   echo   "deb http://www.uk.debian.org/debian stable main contrib non-free"   >   /etc/apt/sources.list

Andrew

nathanxl

Andrew, thanks for this.
Taking great care to get all the spacing correct I still get the same message as before:

bash: /etc/apt/sources.list: Permission denied

I hope you can help me further.
I cant find anything on the eeeuser.com forum

N

Andrew

You're typing the sudo at the beginning and it asks you for a password?

Andrew

nathanxl

Yes, Ive written it just as you have with the correct spacings and with Sudo at the start. Ive done it maybe 5 times and each time it gives me this reply:

bash: /etc/apt/sources.list: Permission denied

It doesnt ask for a password, it just gives me the "/home/user>" prompt.
Ive typed in my password just to see, but it gives back:

bash: my password: command not found

Man, I dont have a clue about this linux Xandros stuff, so great you can guide me through.

N

Andrew

OK, I've dug my eeePC out of storage and think I've got it figured out. Before you do the "sudo echo" command, first type

Code: [Select]
sudo touch /etc/apt/sources.list

then

Code: [Select]
sudo chmod ugo+rw /etc/apt/sources.list

and then carry on with the "sudo echo" command as before.

What that does is create a zero length empty file and make it writable by everybody. Once you've gone through the rest of the instructions and moved the original file back into place it will go back to having more restrictive permissions again.

Give that a go and see how you get on.

Andrew  

Macro

I had the exact same problem as nathanxl and I don't know my way around a command line as it scares me, but I did find out that /etc/apt/sources.list:is owned by root.  

I typed the following line to get root access:
 sudo bash

There always seems to be little inconsistencies in a lot of instructions that make it very difficult for noobs like me.  :(

That stopped the "bash: /etc/apt/sources.list: Permission denied" error so I could continue.

WARNING!  The first line in step 4 appears to be wrong.  
It reads:
 sudo mv /etc/apt/sources.list.back /etc/apt/sources.list

where it should read:
  sudo mv /etc/apt/sources.list.backup /etc/apt/sources.list

If it is easy for the experts to let typos creep in, imagine what my command lines look like!  :-X

I eventually got my Eeepc 701 talking to my Arduino, and now I am a happy camper once again.   :D

Go Up