Go Down

Topic: Arduino + Asus EEEPC works (Read 12659 times) previous topic - next topic


Arduino 0010 works on the Asus EEEPC in Advanced mode, just add the extra repositories, install gcc-avr and avr-libc and your good to go  ;D

The EEE is a nice little platform to work on, small and compact, I can now take my stuff with me and work on projects in a coffee shop.  Just need to get my USB oscilloscope working and I'll be all set.


Dec 20, 2007, 02:09 pm Last Edit: Dec 21, 2007, 10:32 am by Andrew Reason: 1
Works in simple mode too. Now I just need to add a nice chunky Arduino icon to the Play tab...


Edit - used the "loading.gif" from the Arduino distribution:


Could you provide a little more detail about what you did to get it up and running on your machines?


I just had to rebuild my Asus Eee PC (somehow I lost all sound output from Flash movies) and this time I kept a note of the steps I took to get Arduino running.

1. Add full Debian repository to your apt-get sources file:

 [font=Courier New]sudo vi /etc/apt/sources.list[/font]

and add a new line containing this:

 [font=Courier New]deb http://www.uk.debian.org/debian stable main contrib non-free[/font]

2. Update the apt-get indexes:

 [font=Courier New]sudo apt-get update[/font]

3. Get a working build environment and the AVR versions of tools:

 [font=Courier New]sudo apt-get install build-essential[/font]
 [font=Courier New]sudo apt-get install  avr-libc[/font]
 [font=Courier New]sudo apt-get install  gcc-avr[/font]

4. Install the Arduino files in your home directory:

 [font=Courier New]cd /home/user[/font]
 [font=Courier New]wget http://www.arduino.cc/files/arduino-0010-linux.tgz[/font]
 [font=Courier New]tar -xvzf arduino-0010-linux.tgz[/font]

5. Try it out:
 [font=Courier New]cd arduino-0010[/font]
 [font=Courier New]./arduino[/font]

Getting an icon to appear in the launcher is just icing on the cake which I haven't bothered to do this time.

Hope this helps.




Thanks.  Worked great.


Awesome.  Thanks for posting the instructions.  You should consider updating the Debian Linux page on the playground to use your steps.  The current instructions install an old version of the software that some MIT folks created a Debian package for, but which doesn't work (I think) with the Diecimila.  It would be cool to have up-to-date directions, especially since it seems pretty simple.


Jan 24, 2008, 02:58 pm Last Edit: Jan 24, 2008, 03:00 pm by Andrew Reason: 1
I've added it as a separate page for now (http://www.arduino.cc/playground/Linux/Xandros) as the Asus Eee PC already has Java installed whereas some random Debian distribution might not.





Thanks for adding a link to the Dev Tools page on the wiki - I hadn't found that one. Do you know if the wiki has the "show what pages link to this page" feature that MediaWiki has?



I am not having good luck with this.
I have followed the instructions but I'm not getting what I think I should be.
When I start up arduino from the command line I get the following screen:

And when I click on any file to open it I get the following:
java.lang.ClassNotFoundException: com.sun.java.swing.plaf.gtk.GTKLookAndFeel not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:lib/,file:lib/build/,file:lib/pde.jar,file:lib/antlr.jar,file:lib/oro.jar,file:lib/registry.jar,file:lib/mrj.jar,file:lib/RXTXcomm.jar], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
  at java.net.URLClassLoader.findClass(libgcj.so.70)
  at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.70)
  at java.lang.ClassLoader.loadClass(libgcj.so.70)
  at java.lang.ClassLoader.loadClass(libgcj.so.70)
  at java.lang.Class.forName(libgcj.so.70)
  at javax.swing.UIManager.setLookAndFeel(libgcj.so.70)
  at processing.app.Base.<init>(Base.java:131)
  at processing.app.Base.main(Base.java:104)
Stable Library
Native lib Version = RXTX-2.1-7
Java lib Version   = RXTX-2.1-7
./arduino: line 16: 24806 Segmentation fault      java processing.app.Base

I know I'm missing something, but I don't know what it is.
Can some one throw me a line here?


looks like you are using the gnu-gcj version of java which gives you this error.

There is a  command on the eeepc-OS that lets you switch to the Java-Runtime from Sun which is also installed on the eeepc by default. Open a terminal (Ctrl-Alt-T) and list the options for java
Code: [Select]

/home/user> sudo update-java-alternatives -l
java-1.5.0-sun 53 /usr/lib/jvm/java-1.5.0-sun

The following should switch to the sun-runtime
Code: [Select]

/home/user> sudo update-java-alternatives -s java-1.5.0-sun

Please report back if that works for you so we can update the playground-article




YEs! That worked perfectly. Thank you


I don't remember doing that - mine just worked with Java out of the box. Strange.



Hi, Andrew
I don't remember doing that - mine just worked with Java out of the box. Strange.

Yes it is, I also can't remember I had to do that when I installed the Arduino for the first time. But since I was only fooling around with the eeepc until I locked myself out of the System (or rather filled the disk to its last available byte) I can't tell any more. After restoring the system I installed the JDK 1.6 right away, so I don't know.

That tip with update-alternatives-java was just a wild guess. Maybe the problem with the gcj-lib goes away when the system  
is upgraded?

Anyway I will add this to the Playground-Article.



Jul 28, 2008, 09:25 pm Last Edit: Jul 28, 2008, 09:58 pm by falconphysics Reason: 1
I need some help. I followed the instructions outlined here to get Arduino working on a different eeePC and everything worked fine. So I ordered a couple 2G Surfs for my electronics class. I went through the instructions exactly as outlined and I get:

./arduino: line 16: java: command not found

I'm a total n00b when it comes to Linux, so any help would be greatly appreciated. So far I've tried:
  • Restarting
  • Running the update and install commands again (tells me everything is up to date)
  • Tried "sudo update-java-alternatives -s java-1.5.0-sun" but it told me the command was not found

So far I've only tried this on one of the two I ordered.

Any help would be greatly appreciated.

New Addition:
Java seems to be working, I downloaded Processing and it seems to run fine.

Go Up