Go Down

Topic: Problems with 0021 on Ubuntu 10.04 Lucid Lynx (Read 30268 times) previous topic - next topic

pluggy

Another success for reflashing the Uno USB chip.  Transformed the beast completely with my serial heavy sketch  :)
http://pluggy.is-a-geek.com/index.html

stimmer

#46
Dec 05, 2010, 04:02 pm Last Edit: Dec 05, 2010, 04:03 pm by stimmer Reason: 1
Muscatelle: It sounds like the firmware has uploaded correctly and now you just have the usual problems people have getting the IDE to upload. Make sure you have read/write permission on ttyACM0. It might be worth rebooting the machine in case there is some other process trying to open the serial port (the command "killall -KILL avrdude" is quite often necessary after a failed upload)
Due VGA library - http://arduino.cc/forum/index.php/topic,150517.0.html

pluggy

Now just reflash the main bootloader with a Duemilanove version and it might work 'live' as well...........
http://pluggy.is-a-geek.com/index.html

mellis

In your preferences.txt file (whose location is shown in the preferences dialog in the Arduino software), what is the serial.debug_rate?  It sounds like the IDE is trying to open the serial port with an invalid baud rate (or some other serial port parameter).

I've also been able to fix the Arduino UNO not working on Archlinux using the procedure from post #34.

I'm now able to upload code and use the serial monitor without problems.

Anyway, the tx led still remains on when no program is reading the serial port. Is this normal or also happens to you guys?

pluggy

My reference to the bootloader is related to this issue from before optiboot became 'official' :  http://code.google.com/p/optiboot/issues/detail?id=7

It never seemed to be resolved.  It uploads code fine and runs the serial out OK until its disconnected and hooked up to my 'live' home monitoring system when it appears to forget the sketch and returns to the default blink pattern.  It does it on either Uno or Duemilanove if I put the Uno (optiboot) bootloader on either. Both work Ok with the Duemilanove bootloader.  The USB 8U2 problem with the old firmware on the Uno is a seperate issue (or non issue with the new firmware).


http://pluggy.is-a-geek.com/index.html

rgm

Device Firmware Update is a USB standard, and is safe to use.  If you mess up, you can dfu reset and try again.  I'm cross posting stimmer's post from here:
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1285962838/10#10

To here in order to make the information available to non-forum members in the interest of free, wide dissemination of information.  The other forum requires login, this one doesn't.

-rgm
Quote

Here's a way to get the Uno into DFU mode without any soldering. Put two wires into GND pins on either side of the board. Then put the other ends of the wires on the board as follows:

The sequence is, hold the first wire on the top left 8u2 ICSP pad, then touch the second wire against the left side of the capacitor below the RX LED. Then remove both wires. It's slightly different to the sequence in the instructions but it seems to work.

Be careful with the second wire as the capacitor is quite near a 5v track. You can try using a low-value resistor instead of a wire if you are worried about blowing up your board.

To get back to normal mode, hold wire 1 in place as above, press the reset button, then remove wire 1. Or just unplug the USB cable and plug it back in.


erni-berni

#52
Dec 10, 2010, 07:26 pm Last Edit: Dec 10, 2010, 07:50 pm by erni-berni Reason: 1
Anybody here who tried the update on an Arduino Mega 2560? Does anybody know how to set the Atmega8u2 of this board in update mode ?
Reinhard

Lucretia

I just ran exercise 07 from the getting started with arduino book which locked up my Uno and was unable to upload. Same problem.

I would like to confirm that by unplugging the usb cable, holding down the reset button whilst plugging the usb back in and then (whilst still holding reset), upload, release reset. It worked. Got back to blink.

Code: [Select]

$ uname -a
Linux rogue 2.6.32-26-generic #48-Ubuntu SMP Wed Nov 24 10:14:11 UTC 2010 x86_64 GNU/Linux


Thanks,
Luke.

Eys

Thanks for help, for my first days in arduino, updating the firmware was... uncertain and doubtful for me.. I am still sweating but it's working fine.

ahven

Thank you also for the flashing instructions, serial monitor like a charm now :)

wombat42

Just installed the updated 8u2 firmware on my mega2560, and it runs like a charm now...

I even removed the 4 second delay on Serial.begin in my code, and the IDE still can program the mega. (I run Linux, IDE v0021)

In case anyone wonders, if you follow

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1285962838/10#10

wire 2 on the mega2560 needs to contact the left side of the capacitor immediately above the two pads labelled RESET-EN. This in just above the righthand of the two 47uF capacitors, not in the centre as  shown on the Uno. You know if the 8u2 is ready to program if it does not appear as ID 2340:0010 when you run lsusb - it appears under an Atmel ID

Also, if you have the problem of ttyACM0 not appearing in the serial port list, you can make ttyS7 be a symlink to it, and then it works...

I automated it in /etc/udev/rules.d/55-odd.rules

KERNEL=="ttyACM0", SYMLINK+="ttyS7"

Now I can get on using the mega2560 under Linux  8-)


MakerMann

Did you try running the windows version along side WINE.

wombat42

MakerMann

No,  I don't use WINE for the Arduino software - I use the arduino-0021.tgz to get the IDE.

Please remember if you want to use the mega2560, you also need the patched version of avr-gcc. Not sure if the windows software includes the patch. On linux you have to build avr-gcc yourself (or find a pre-compiled copy somewhere)

erni-berni

#59
Dec 27, 2010, 03:11 pm Last Edit: Dec 27, 2010, 03:58 pm by erni-berni Reason: 1
wombat42,

got it also working on my mega2560 after some trouble:
- on my debian in standard repository was only dfu-programmer Version 0.4.3. The at90usb82 device was not recognized (dfu-programmer: no device present) , although the device is listed when dfu-programmer is called with no options.
- upgraded to dfu-programmer 0.5.2 from source
reference: http://www.wiki.elektronik-projekt.de/mikrocontroller/avr/at90usb/dfu_programmer
Code: [Select]
svn co https://dfu-programmer.svn.sourceforge.net/svnroot/dfu-programmer dfu-programmer
cd dfu-programmer/trunk/dfu-programmer/
./bootstrap.sh
./configure
make
sudo make install

- dfu-programmer now recognizes the at90usb82
- erased with no error message
- when trying to flash got the message: Something went wrong with creating the memory image
- after some time of troubleshooting I found that the downloaded .hex file was wrong. I don't know why, but it was not possible to download the raw file with epiphany
- downloaded the .hex file with wget, flashed it and it works perfectly.
:) Reinhard

Go Up